Problem mit SASL nach Server Reboot

Dieses Thema im Forum "Server Administration" wurde erstellt von cob-web, 14. Apr. 2009.

  1. cob-web

    cob-web New Member

    Hallo,

    Ich habe heute früh meinen vServer rebooted (über control panel bei S4Y).
    Seit dem funktioniert kein E-Mail Versand mehr.
    Der SASL Dienst scheint irgendwie zu streiken - die Lösungen hier im Forum haben leider nicht gepasst bzw. nichts gebracht.

    Der Server ist Debian Etch 4.0 mit ISPConfig 2.2.32 (= habe gerade upgedatet - dachte, dass es danach evtl. wieder funktionieren wird - hat leider nicht geholfen)

    In der mail.log steht:
    Code:
    Apr 14 11:57:10 vsxxxxxx postfix/smtpd[24388]: connect from brln-4db9714b.pool.einsundeins.de[xx.xxx.xxx.xx]
    Apr 14 11:57:22 vsxxxxxx postfix/smtpd[24388]: warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied
    Apr 14 11:57:22 vsxxxxxx postfix/smtpd[24388]: warning: SASL authentication failure: Password verification failed
    Apr 14 11:57:22 vsxxxxxx postfix/smtpd[24388]: warning: brln-4db9714b.pool.einsundeins.de[xx.xxx.xxx.xx]: SASL PLAIN authentication failed: generic failure
    Apr 14 11:57:23 vsxxxxxx postfix/smtpd[24388]: warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied
    ps aux|grep saslauthd
    Code:
    root      3640  0.0  0.0   6216   992 ?        Ss   12:28   0:00 /usr/sbin/saslauthd -a shadow -n 5
    root      3641  0.0  0.0   6216   592 ?        S    12:28   0:00 /usr/sbin/saslauthd -a shadow -n 5
    root      3642  0.0  0.0   6216   536 ?        S    12:28   0:00 /usr/sbin/saslauthd -a shadow -n 5
    root      3643  0.0  0.0   6216   536 ?        S    12:28   0:00 /usr/sbin/saslauthd -a shadow -n 5
    root      3644  0.0  0.0   6216   536 ?        S    12:28   0:00 /usr/sbin/saslauthd -a shadow -n 5
    root      7310  0.0  0.0   1560   508 pts/0    S+   12:39   0:00 grep saslauthd
    
    /etc/default/saslauthd
    Code:
    #
    # Settings for saslauthd daemon
    #
    
    # Should saslauthd run automatically on startup? (default: no)
    START=yes
    
    # Which authentication mechanisms should saslauthd use? (default: pam)
    #
    # Available options in this Debian package:
    # getpwent  -- use the getpwent() library function
    # kerberos5 -- use Kerberos 5
    # pam       -- use PAM
    # rimap     -- use a remote IMAP server
    # shadow    -- use the local shadow password file
    # sasldb    -- use the local sasldb database file
    # ldap      -- use LDAP (configuration is in /etc/saslauthd.conf)
    #
    # Only one option may be used at a time. See the saslauthd man page
    # for more information.
    #
    # Example: MECHANISMS="pam"
    MECHANISMS="shadow"
    
    # Additional options for this mechanism. (default: none)
    # See the saslauthd man page for information about mech-specific options.
    MECH_OPTIONS=""
    
    # How many saslauthd processes should we run? (default: 5)
    # A value of 0 will fork a new process for each connection.
    THREADS=5
    
    # Other options (default: -c)
    # See the saslauthd man page for information about these options.
    #
    # Example for postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
    # Note: See /usr/share/doc/sasl2-bin/README.Debian
    PARAMS="-c -m /var/spool/postfix/var/run/saslauthd -r"
    Der Server lief bislang soweit ohne Probleme.

    An einem falschem PW kann es nicht liegen, da ich mich über Webmail einloggen und auch verschicken kann.

    Ich freue mich auf eure Ideen.

    Gruß,
    Tomas
     
    Zuletzt bearbeitet: 14. Apr. 2009
  2. Till

    Till Administrator

    das kann nicht helfen da ISPConfig sasl garnicht konfigureirt.

    das Problem wird irgend etwas mit den sasl Rechten sein. Am Besten gehst Du nochmal alle Email Config Schritte des perfect server für etch durch.
     
  3. cob-web

    cob-web New Member

    Danke Till!

    Das hier hat mein Problem gelöst:
    Code:
    adduser postfix sasl
    Gruß
    Tomas
     

Diese Seite empfehlen