Problem mit send copy eins Postfachs

Dieses Thema im Forum "Allgemein" wurde erstellt von Edi, 12. Dez. 2010.

  1. Edi

    Edi Member

    Hallo

    Send copy im Postfache geht nicht
    Email Weiterleitung geht

    Wird bei send copy in den Postfacheinstellungen eine Adresse eingetragen wird die email empfangen aber nicht weitergeleitet.
    Eine Emaiweiterleitung funktioniert.

    Editiert: Habe den falschen Text gelöscht.
    Der Eintrag in der ISPdb steht bei send copy unter mail_user bei cc und ist auch vorhanden.

    ISPConfig 3.0.3 mit SuSe 11.2 und 11.2 x86_64 funktioniert nicht,
    mit SuSe 11.1 geht es.

    Danke

    Edi
     
    Zuletzt bearbeitet: 12. Dez. 2010
  2. Till

    Till Administrator

    Dan schau doch mal ins mail log, warum suse 11.2 das nicht kann.
     
  3. Edi

    Edi Member

    Fehler gefunden:

    Es wurde kein Eintrag bei mailfilters gemacht.

    In dem Script for Automatically Setting up a Perfect Server On OpenSUSE 11.2 von George Yohn liegt die Lösung:

    Enable maildrop filters
    einfach die letzte Zeile des Scripts ausführen.

    Muß das jetzt nach jedem Update von ISPConfig wieder gemacht werden oder bleibt die Einstellung so erhalten?

    Danke

    Edi

    P.S. SUSE 11.2x64 mit dovecot läuft problemlos. Die Anleitung für 11.3 kann übernommen werden.
     
  4. Till

    Till Administrator

    Ok, danke für den Hinweis.

    Wenn Du mir sagst was für einen Befehl Du ausgeführt hats, dann kann ich versuchen es zu bantworten :)
     
  5. Edi

    Edi Member

    Den da:

    Quelle: Script von George Yohn.


    # enable maildrop filters

    ln -s /usr/local/ispconfig/server/plugins-available/maildrop_plugin.inc.php /usr/local/ispconfig/server/plugins-enabled/maildrop_plugin.inc.php
     
  6. Till

    Till Administrator

    ISPConfig verwendet mit dovecot deliver (also sieve) und kein maildrop als lda, deswegen darf das maildrop plugin auch nicht aktiviert sein wenn dovecot verwendet wird. Ich vermute mal Du hast bei Dir eine Mischung aus dem courier und dovecot setup am laufen, das wird so nicht unterstützt und daher auch vom installer nicht konfiguriert.
     
  7. Edi

    Edi Member

    Ich habe 4 Installationen gemacht 11.2 und 11.2x64 mit courier/maildrop,
    11,2x64 und 11.3x64 mit dovecot/sieve.
    Beide hatten das gleiche Problem mit courier. Ich glaube nicht dass ich etwas vermicht habe.

    Mache nochmal eine Installation mit 11.2 und der Anleitung für courier.
    Mal schauen was rauskommt.

    Danke

    Edi
     
  8. Till

    Till Administrator

    Stell sicher dass kein dovecot vorher installiert war und wenn das der fall war, dass es restlos entfernt wurde und nicht nur deaktiviert ist. sonst erkennt der installer das setup möglicherweise als dovecot installation und nicht courier.

    Für 11.2 gibt es ja auch nur ein courier perfect setup von uns und keines für dovecot:

    http://www.howtoforge.com/perfect-server-opensuse-11.2-x86_64-ispconfig-3
     
  9. Edi

    Edi Member

    Wird eine Neuinstallation nach Anleitung 11.2

    11.2 mit dovecot war einfach mal ein Test, mit Hilfe der Anleitung 11.3 geht es.
     
  10. Till

    Till Administrator

    Richtig, es iat auch ein anderes setup. Die 11.3 Anleitung verwendet ja wie oben beschrieben nicht maildrop mit courier sondern dovecot mit deliver. Was nicht geht ist daß Du es msichst, also maildrop ohne courier und dafür mit dovecot ohne deliver.
     
  11. Edi

    Edi Member

    Habe jetzt folgendes gemacht.

    Server neu installiert nach Anleitung perfect server suse 11.2 fuer ISPConfig3.

    Folgende Aenderungen sind aber notwendig:

    Symlink fuer clamav socket einfuegen
    mkdir -p /var/run/clamav
    ln -s /var/lib/clamav/clamd-socket /var/run/clamav/clamd

    Bei imap muss die ADRESS=0 eingetragen werden, sonst geht imap nicht.

    Alles noetige fur webdav eingefuegt.

    send copy geht aber nicht.

    Es mus folgendes ausgefuert werden:
    ln -s /usr/local/ispconfig/server/plugins-available/maildrop_plugin.inc.php /usr/local/ispconfig/server/plugins-enabled/maildrop_plugin.inc.php


    Mit diesen Aenderungen geht alles.

    Edi
     
    Zuletzt bearbeitet: 21. Dez. 2010

Diese Seite empfehlen