Problem mit sendmail_from/sendmail_path

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von KoloJay, 10. Juli 2013.

  1. KoloJay

    KoloJay New Member

    Hallo zusammen,

    ich bin vor kurzem von manueller Konfiguration aller Apache-Dateien auf ISPConfig umgestiegen und habe bisher auch alles so hinbekommen können, wie ich es benötigt habe.

    Jetzt stehe ich aber vor einem Problem da ich pro Domain einen Default-Mailsender einstellen möchte damit der Absender nicht [Benutzername]@[Hostname] lautet.

    Dazu habe ich versucht die PHP-Werte für sendmail_from und sendmail_path entsprechend zu setzen, z.B.
    (php_admin_value) sendmail_from no-reply@example.com
    (php_admin_value) sendmail_path '/usr/sbin/sendmail -t -i -fno-reply@example.com'

    Aber egal wo ich es versucht habe - über die Default-Vhost-Datei, über die Default-PHP.ini oder über die "Custom php.ini settings" oder die "Apache Directives" - bisher bin ich immer erfolglos, die PHPINFO() sagt mir immer, dass sendmail_sender den Wert "no value" hätte und so sehen die Absender dann auch aus wenn ich per mail() über PHP etwas versende.

    Hat jemand damit bereits Erfahrung? Ich bin mit meinem Latein hier echt am Ende uns weiß nicht warum sich die Angaben nicht "durchsetzen".

    Danke für sachdienliche Hinweise und viele Grüße aus dem sonnigen Frankfurt
    KoloJay
     
  2. KoloJay

    KoloJay New Member

    Lösung gefunden

    Okay, ich habe die Lösung gefunden: dummer Fehler von mir...

    Unter "Custom php.ini settings" habe ich nun Folgendes eingetragen:
    sendmail_from = no-reply@example.com
    sendmail_path = "/usr/sbin/sendmail -t -i -fno-reply@example.com -Fno-reply"

    Knackpunkt war also das "=". Ich hoffe es hilft dem ein oder anderen...
     

Diese Seite empfehlen