Problem mit User welcher E-Mail Adressen anlegen will

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von hunter999, 7. Mai 2009.

  1. hunter999

    hunter999 New Member

    Hallo,

    habe gerade mitgeteilt bekommen das ein Kunde keine E-Mail Adressen unter ISPConfig als "Kunde" anlegen kann.
    Die Mailboxen selbst werden angelegt aber Mails kommen keine an.
    Nach einer kurzen Recherche habe ich heraus gefunden das in der virtusertable keine Einträge dahingehen angelegt worden sind.

    Woran kann das liegen?

    Sys: ISPConfig 2 auf Debian Etch
     
  2. Till

    Till Administrator

    Dann scahu doch mal ins ispconfig.log und starte ispconfig mal neu.
     
  3. hunter999

    hunter999 New Member

    Also viel daraus nehmen kann ich mir leider nicht:

    Code:
    [I]web34_04:x:10089:10034:User A.:/var/www/web34/user/web34_04:/bin/false
    20.04.2009 - 10:41:32 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 910: setquota -u web34_04 0 0 0 0 -a &> /dev/null
    20.04.2009 - 10:41:32 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 911: setquota -T -u web34_04 604800 604800 -a &> /dev/null
    20.04.2009 - 10:41:32 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web34/user/web34_04/.forward
    20.04.2009 - 10:41:32 => INFO - USER: 
    web34_05:x:10090:10034:User A.:/var/www/web34/user/web34_05:/bin/false
    20.04.2009 - 10:41:32 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 910: setquota -u web34_05 0 0 0 0 -a &> /dev/null
    20.04.2009 - 10:41:32 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 911: setquota -T -u web34_05 604800 604800 -a &> /dev/null
    20.04.2009 - 10:41:32 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web34/user/web34_05/.forward
    20.04.2009 - 10:41:32 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
    20.04.2009 - 10:41:32 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
    20.04.2009 - 10:41:33 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: postmap hash:/etc/postfix/virtusertable
    20.04.2009 - 10:41:33 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1268: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
    20.04.2009 - 10:41:33 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2655: WARNING: could not . /etc/apache2/envvars && httpd -t  &> /dev/null
    20.04.2009 - 10:41:33 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2669: httpd syntax seems to contain errors, reloading with old configuration
    20.04.2009 - 10:41:33 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2670: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf_20-04-09_10-41-33
    20.04.2009 - 10:41:33 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2671: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf~ /etc/apache2/vhosts/Vhosts_ispconfig.conf
    20.04.2009 - 10:41:33 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 755: /etc/init.d/apache2 reload &> /dev/null
    20.04.2009 - 10:41:33 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2119: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
    20.04.2009 - 10:41:36 => INFO - Signalfile Set: update
    20.04.2009 - 10:41:44 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 259: setquota -g web34 1024000 1025024 0 0 -a &> /dev/null
    20.04.2009 - 10:41:44 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 260: setquota -T -g web34 604800 604800 -a &> /dev/null
    20.04.2009 - 10:41:44 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 279: Connected successfully
    20.04.2009 - 10:41:44 => INFO - USER: 
    [/I]
    Einzig das hier ist komisch:

    Code:
    [I][I]WARNING: could not . /etc/apache2/envvars && httpd -t  &> /dev/null
    [/I][/I]
     
  4. Till

    Till Administrator

    Also mit Emailadressen scheint da alles ok zu sein. Du hast aber ein Problem in Deiner httpd.conf, so dass ispconfig die apache Konfiguration nicht mehr updaten kann. Du findest das Problem so:


    mv /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf.orig
    mv /etc/apache2/vhosts/Vhosts_ispconfig.conf_20-04-09_10-41-33 /etc/apache2/vhosts/Vhosts_ispconfig.conf
    httpd -t
     

Diese Seite empfehlen