Problem-Server wieder in Multiserver-Setup eingliedern (ohne Neuinstallation?)

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von isp_geek, 11. Juni 2014.

  1. isp_geek

    isp_geek Member

    Hallo Leute, hallo Till,

    durch ein fehlgeschlagenes Upgrade war ich gezwungen für einen meiner Server ein Backup von letzter Wochen zurückzuspielen. Ich schildere mal was ich gemacht habe, vielleicht lässt sich mein Problem ja mit zwei Handgriffen beheben.

    Server A:
    -alle Webseiten auf Server D umgezogen - Daten in ISPconfig und Platte übertragen
    -alles nochmal gesichert und Backup(s) gemacht
    -Webseiten und alle Inhalte gelöscht - in ISPconfig und auf der Platte
    -ISPconfig3 3.0.5.4p1 deinstalliert - und die Daten von der Platte
    -ISPconfig3 mit expert neu installiert und den Server ins Ziel-Cluster eingebunden
    -usw. neue Webseiten auf den Server eingerichtet ... etc. pp.

    Jetzt kommt das Backup von letzter Woche. Der Grund dafür ereignete sich irgendwann nach dem Umzug aller Seiten auf Server D. (vermutlich apt-get upgrade mit corrupten packages)

    Ich möchte jetzt nicht nochmal dieses Prozedere durchlaufen und nachfragen wie ich den Server vielleicht ohne ISPconfig zu deinstallieren ins Cluster einbinden kann. Der Server existiert ja noch im Cluster. Die Daten in /var/www und den anderen Verzeichnissen sollen auch vorerst auf dem Server liegen bleiben.

    Was ich benötige:
    Deinstallieren der ISPconfig Weboberfläche:
    Reicht es aus die ispconfig.vhost zu deaktivieren, muss ich auch den /usr/local/ispconfig Ordner zu löschen? Hab gesehen, dass er auf den anderen Servern C und D da ist - in vollem Umpfang.

    Variante A
    ISPconfig deinstallieren und das so zu tun, dass keine Daten auf der Platte verloren gehen. Dann, Multiserver-Setup neu durchführen ...

    Variante B:
    Server ins Cluster (Multiserver-Setup) einbinden ohne ISPconfig zu deinstallieren.
    Kann ich die config einfach vom anderen Server (z.B. C oder D) nehmen und dann alles manuell anpassen? Worauf muss ich speziell achten?

    Variante C:
    Die notwendigen Dateien aus dem letzten Snapshot des vServers in die Verzeichnisse wiederherstellen, die sind ja alle da und entsprechen auch dem Stand des Master Servers. Aber welche alle sind das?

    In allen Fällen haben wir Version 3.0.5.4.p1

    Wie soll ich jetzt gescheit vorgehen?
    Wäre echt super, wenn mir jemand bei dem Manöver helfen würde, um mit so wenig Aufwand wie möglich den Server ins Cluster zu bekommen.

    Vielen Dank für eure Zeit und Mühe im Voraus.

    vg.ks
     
  2. isp_geek

    isp_geek Member

    Schade, dass bisher keine Antworten kamen, ich habe dennoch mit viel Aufwand den Zusammenschluss (hoffentlich richtig) hinbekommen:

    Vorgehen:
    -Sichern der Datenbank auf Server A
    -ISPconfig3 holen, ggf Servernamen anpasssen
    -deinstallieren, klappte ohne Probleme.
    -neu installieren mit Multiserver-Setup
    -auf Masterserver alle Domains anpassen
    (in dbispconfig Tabelle web-domain alle Einträge der entsprechenden Webseiten die server_id von der Alten auf die Neue ändern und dann im Adminpanel die Seiten deaktivieren und wieder neu aktivieren, damit die Änderung übernommen wird)
    -sicherstellen, dass keine web_id und client_id bzw. sonst eine ###_id auf dem Server A größer ist als die, die aktuell auf dem Masterserver vergeben werden.
    (keine Webseite oder andere Elemente auf dem Server A erstellt wurden, die es auf Masterserver gibt bzw. noch erstellt werden könnten)

    Hoffe das ist so richtig, wenn nicht, dann mich bitte korrigieren. vg.ks
     
  3. nowayback

    nowayback Well-Known Member

    hi,

    bin jetzt zwar nicht mehr in der Firma aber kann deine Vorschläge - wenn es heute nachmittag ruhig bleibt - gerne auf unseren Testsystemen testen.

    Generell kann ich dir aber nicht wirklich folgen...

    Wenn du ein Backup aller Daten hast, dann einfach den Server - as it was - installieren, backup einspielen (DBs, Configs, Verzeichnisse, /etc, ...) und alle anderen Server untouched lassen. Dann sollte es wieder funktionieren, da alle relevanten Daten ja darin vorhanden sind.

    Grüße
    nwb
     
  4. isp_geek

    isp_geek Member

    hi nwb,

    Variante A führte bei mir zum Erfolg, ISPconfig3 löscht anscheinen nur sich selbst, sonst nichts. Nach dem Multiserver-Setup mussten nur die default Webserver der Klienten im Admin angepasst und die server_id in Tabelle web-domain direkt in der Datenbank. Ändere ich jetzt die server_id der Webseite zurück, dann kann ich zwischen den beiden Servern (Webseiten) hin und her switchen.

    Datenbanken, FTP und der ganze Rest jetzt mal unberücksichtigt gelassen. Müssten aber auch noch (analog) angepasst werden.
     

Diese Seite empfehlen