Probleme bei den Domains im internen Nez

#1
ISPConfig 3.0.1 - Debian 5 Lenny - Testserver im Internen Netz
Dokumentation war die Perfekt Server für Debian 5.0 Lenny mit ISPConfig 3

Installtion lief wie laut Anleitung ohne fehler und komplikationen.


edit ... hmm der sendet aber schnell ab ^^

So folgende Situation bei mir:

Habe den Server auf einer Virtuellen Box im Bridge Modus laufen und wollte erstmal im home netz testen wie ispconfig funktioniert und es zu administrieren ist.

auszug aus ispconfig:

[global]
webserver=apache
mailserver=postfix
dnsserver=mydns

[server]
auto_network_configuration=
ip_address=172.16.40.100
netmask=255.255.255.0
gateway=172.16.40.78
hostname=server1.example.com
nameservers=172.16.40.100, 172.16.40.70 # die .70 ist der dns in meinem netzwerk

[mail]
module=postfix_mysql
maildir_path=/var/vmail/[domain]/[localpart]
homedir_path=/var/vmail
mailuser_uid=5000
mailuser_gid=5000
mailuser_name=vmail
mailuser_group=vmail
relayhost=
relayhost_user=
relayhost_password=
mailbox_size_limit=0
message_size_limit=0

[getmail]
getmail_config_dir=/etc/getmail

[web]
website_basedir=/var/www
website_path=/var/www/clients/client[client_id]/web[website_id]
website_symlinks=/var/www/[website_domain]/:/var/www/clients/client[client_id]/[website_domain]/
vhost_conf_dir=/etc/apache2/sites-available
vhost_conf_enabled_dir=/etc/apache2/sites-enabled

[fastcgi]
fastcgi_starter_path=/var/www/php-fcgi-scripts/[system_user]/
fastcgi_starter_script=.php-fcgi-starter
fastcgi_alias=/php/
fastcgi_phpini_path=/etc/php5/cgi/
fastcgi_children=8
fastcgi_max_requests=5000
fastcgi_bin=/usr/bin/php-cgi

[jailkit]
jailkit_chroot_home=/home/[username]
jailkit_chroot_app_sections=basicshell editors extendedshell netutils ssh sftp scp groups jk_lsh
jailkit_chroot_app_programs=/usr/bin/groups /usr/bin/id /usr/bin/dircolors /usr/bin/lesspipe /usr/bin/basename /usr/bin/dirname /usr/bin/nano /usr/bin/pico



so nun zum problem:

erstmal ich komme auf die http://172.16.40.100 - It works (dass soll ja so sein - oder!?)
komme auch auf dass cp von ispconfig mit http://172.16.40.100:8080

fort habe ich als erstes einen benutzer angelegt, anschließend eine domain test.tdl angelegt

Server server1.example.com
Kunde kunde
IP-Adresse *
Domain test.tdl
rest gelassen und noch
auto-subdomain auf www.
und für php fast-cgi gewählt.
häckchen bei aktiv war drin.

Gut - die webseite hat er schonmal angelegt!

Als nächstes bin ich auf den DNS Add Zone Wizard gegangen und habe folgendes eingegeben:

template Default
server server1.example.com
client kunde
domain test.tdl
ip-address server1.example.com
ns1 server1.example.com - ich glaube hier sind meine fehler
ns2 ns.server1.example.com

email mail.test.tdl


Die einträge sahen danach dann so aus:

A mail server1.example.com 0
A test.tdl. server1.example.com 0
A www server1.example.com 0
MX test.tdl. mail.example.com. 10
NS test.tdl. ns.server1.example.com. 0
NS test.tdl. server1.example.com. 0


Ich weiß nicht was ich falsch mache denn ich komme nicht auf die seite.
Probiert habe ich folgendes im Browser: test.tdl, www.test.tdl,
172.16.40.100/test.tdl
Bei letzterem kommt ein 403 - Fehler (Forbidden)

Bin um jede Hilfe dankbar - auch wenn irgendwelche logs oder sonstwas gebraucht werden zur Problembehebung oder einfach nur ein DNS - Eintrag fehlt oder es sich doch um eine fehlinstallation handelt - bitte schreiben

Danke :D

mfg
Cryar
 
Zuletzt bearbeitet:
#2
im lokalen netz musst den bei dem host der die seite auf ruft die domain in die host datei aufnehmen.

woher soll der denn wissen wonach er die domain auflösen soll selbst dein dns eintrag in ispconfig kann er ja nicht kennen.
 
#3
heh Burge

Benütze ein Windows XP Client
Folgendes steht in meiner hosts datei:

127.0.0.1 localhost
172.16.40.100 server1.example.com
172.16.40.100 test.tdl
ist dass so richtig !?

Weil ich komme so ebenfalls nicht auf die Seite.

Bei Eingabe im Webbrowser "test.tdl" kommt: Apache Start: It works!
Also genau dass selbe wie bei server1.example.com

Wie muss die Hostdatei bei mir denn aussehen damit er mich auch wirklich auf den Webordner von test.tdl bringt ?
 
#4
deine hostdatei ist richtig schau mal das du auf deine isp server unter server einstellung auch die ip eingetragen hast und dann bei den webseiten nicht das * aus wählen sondern die ip adresse.
 
#5
ah ich danke dir ich glaube dass sind die ersten schritte richtung besserung :D

ich bekomme nun zumindest wenn ich server1.example.com/test.tdl eingebe einen 404 fehler ^^

mit test.tdl komme ich allerdings weiterhin nur auf it works verzeichnis ...

wie kann man das beheben und auch dass er die index.html anzeigt und nicht den 404 error ? Die datei ist da und sollte eigentlich gelesen werden können.
 
#6
das sind namensbassierete vhost du gibst gar kein verzeichniss an ruf ein domain auf von deinem xp rechner mit der angepassten host datei.
 
#7
dann ist irgendwo noch ein fehler wohl drin.

Komme nur auf die Apache IT works seite

hier ein auszug aus der test.tdl.vhost datei:

<Directory /var/www/test.tdl>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost 172.16.40.100:80>
DocumentRoot /var/www/test.tdl/web

ServerName test.tdl
ServerAlias www.test.tdl
ServerAdmin webmaster@test.tdl

ErrorLog /var/log/ispconfig/httpd/test.tdl/error.log

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /var/www/test.tdl/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client2/web6/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all
</Directory>

# php as fast-cgi enabled
<Directory /var/www/test.tdl/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web6/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride all
Order allow,deny
Allow from all
</Directory>


</VirtualHost>
ist dass die datei worauf es ankommt oder könnte in einer anderen datei ein fehler sein ?

Nochmals vielen dank für die Hilfe


€dit:

Habe im ISPC Cron Protokoll noch folgende Einträge gefunden:

[Wed Jun 16 14:14:07 2010] [warn] NameVirtualHost 172.16.40.100:443 has no VirtualHosts
/bin/sh: /usr/local/ispconfig/server/scripts/run-getmail.sh: Permission denied
 
Zuletzt bearbeitet:

Till

Administrator
#8
Du hast in Deinen DNS Einträgen den Punkt am Ende der vollständigen Domainnnamen (FQDN) vergessen. Du hast also nur relative records zur Zone erstellt und keine absoluten.

Es muss also heißen:

test.tdl.

und nicht

test.tdl

Des weiteren hast Du DNS A-Records angelegt, die auf eine Domain verweisen. Sowas ist im DNS nicht vorgesehen. DNS A-Records verweisen immer auf eine IP.

Der vhost Auszug aus Post #7 ist korrekt. Du hast also ein DNS problem und keines mit dem Apache.

Des weiteren setzt Du eine ziemlich alte ISPConfig Version ein. Aktualisier mal auf das aktuelle Release (3.0.2.1 oder 3.0.2.2 beta).
 
#9
Guten Morgen,

Danke für die Hinweise, habe nun meine Records angepasst. Komme nun auch über test.tdl auf die richtige Seite :) Schonmal danke dafür

hier meine records:


habe nun auch ispconfig geupdated auf version 3.0.2.1

nach updates finished kamen zwar folgende fehler:

/usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 8: f: command not found
/usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 9: syntax error near unexpected token `then'
/usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 9: `then'

aber auf den ersten blick scheint alles zu funktionieren,

nochmal vielen dank für eure Hilfe, wenns produktiv werden sollte und ich Probleme habe, werde ich mich gerne nochmal an die Community wenden :D ihr seit spitze

mfg,
Cryar
 
#10
Kurz zur DNS-Konfiguration im Heimnetz:
Bei einem handelsüblichen DSL-Router mit DHCP Server kann man ja einige Daten angeben, die an die DHCP Clients weitergegeben werden.
Wenn ich dort angebe, dass meine DHCP Clients den ISP3 Server als 1. und den Router als 2. NS bekommen können die Clients die Domains auf dem ISP3 Server problemlos auflösen, ohne hosts-Eintrag.
 

Till

Administrator
#11
nach updates finished kamen zwar folgende fehler:

/usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 8: f: command not found
/usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 9: syntax error near unexpected token `then'
/usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 9: `then'
Das ist ok. Das war ein Bug in der 3.0.1 Version, der macht eine etwas 'häßliche' Ausgabe auf der Shell hat aber keine Auswirkungen auf die Funktionen.
 

Werbung

Top