Probleme beim Zustellen von Mails

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Lonesome Walker, 13. Dez. 2007.

  1. Lonesome Walker

    Lonesome Walker New Member

    Langsam aber sicher verzweifle ich mit meiner Kiste.
    Da ich leider genötigt wurde, eine GUI zur Serververwaltung einzusetzen, bin ich nun bei ISPConfig hängen geblieben, und muß sagen, sieht nett aus, und funktioniert auch außerordentlich gut.

    Server war schnell installiert und konfiguriert.

    Jetzt gehts ans Eingemachte, Fehler korrigieren:

    Ich kriege von vereinzelten Mitarbeitern die Fehlermeldung, daß deren Mails nicht zugestellt werden können, weil sie angeblich SPAM sind.

    Wie bitte? Haben wir nicht SPF?

    Okay, hier eine Fehlermeldung:

    Code:
    Reporting-MTA: dns; 85-10-198-90.clients.your-server.de 
    X-Postfix-Queue-ID: E2D4D2014B3A 
    X-Postfix-Sender: rfc822; mitarbeiter@domain.de 
    Arrival-Date: Thu, 13 Dec 2007 06:06:28 +0100 (CET) 
     
    Final-Recipient: rfc822; ziel@domain.com 
    Original-Recipient: rfc822;ziel@domain.com 
    Action: failed 
    Status: 5.0.0 
    Remote-MTA: dns; mx.domain.de 
    Diagnostic-Code: smtp; 550 <ziel@domain.com>: Recipient address rejected: 
    Mail appeared to be SPAM or forged. Contact YOUR Mail/DNS-Administrator to correct HELO and DNS MX settings or to get removed from DNSBLs; Please use DynDNS 
    
    Die RBL's habe ich gecheckt, kein Eintrag.
    Relaying ist ja auch nicht möglich.
    Somit liegts am Authentifizieren.

    Ein EHLO/HELO an die Domain bringt folgendes:

    Code:
    telnet domain.de 25
    -----
    Trying 78.47.170.94...
    Connected to domain.de
    Escape character is '^]'
    220 85-10-198.90.clients.your-server.de ESMTP Postfix
    HELO domain.de
    250 85-10-198-90.clients.your-server.de
    
    Okay, zur Erklärung:
    ISPConfig ist auf einem Hetzner-Server installiert, der hat 5 zusätzliche IP's.
    Ich habe domain.de eine andere als die Hauptdomain (85.10.198.90) zugewiesen (->78.47.170.94)


    Was ist jetzt in den DNS-Settings oder der Postfix-COnfig falsch eingestellt?

    Der Remote-MTA meckert ja, daß HELO oder DNS-Settings falsch sind.
    Meine Postfix-Config sieht so aus, wie auch im Perfect Etch Setup hier.
    Daher gehe ich im Moment erst mal davon aus, daß ich diese als Fehlerquelle ausschließen kann.

    Domain angelegt, Haken bei Standard-DNS und -MX-Record.
    Dann im DNS-Manager

    A-Records für www, ns und mail mit der IP
    dann
    CNAME für ftp mit der Domain (und nicht die IP),
    dann
    Mailserver: mail.domain.de Host: (leer)
    SPF:
    Host -> domain.de
    alle Dropdowns mit Ja

    Resultat -> Mails werden als SPAM von anderen MTA's rejected.

    Jetzt habe ich schon folgendes gemacht:
    bei SPF:
    Ja, Ja, Ja, andere IP's: 85.10.198.90, 85-10-198-90.clients.your-server.de
    und das letzte Dropdown mit Nein

    Trotzdem reject.

    Aaaargl.
    Habe ich irgendwo einen Denkfehler?

    THX
     
  2. Till

    Till Administrator

    Ok, erstmal vorweg, das hat alles nichts mit ISPConfig zu tun. Die von Dir gepostete Fehlermeldung is nämlich nicht von ISPConfig sondern vom Remote Server und Postfix Grundeinstellungen und den Hostnamen kannst Du garnicht in ISPConfig einstellen.

    Als erstes solltest Du mal checken, dass der Hostname (hostrname und hostname -f) Deines Servers mit dem Hostnamen in der Postfix main.cf übereinstimmt. Als nächstes musst Du Hetzner sagen, dass sie diesen Hostnamen (muss ein fully qulified hostname sein) als reverse record für die IP eintragen sollen.

    Zu Deinen DNS Einstellungen: Bist Du sicher, dass der ISPConfig Server der authoritive Nameseerver für domain.de ist?
     
  3. Lonesome Walker

    Lonesome Walker New Member

    :D

    Also, hostname und hostname -f sind natürlich passend.
    Reverse Record ist schon seit Beginn gesetzt, funktioniert auch prima.

    Die Domain ist korrekt eingerichtet, jedoch bin ich mir mit den Settings im ISPConfig alles andere als sicher :( (sind ja nicht gerade wenig...)

    Du hast PN.
     

Diese Seite empfehlen