Probleme mit dem Mail-Server

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von herosalex, 2. Sep. 2012.

  1. herosalex

    herosalex Member

    Hallo zusammen,
    ich habe einen Server mit Ubuntu eingerichtet und ISPconfig3 installiert.Soweit funktioniert auch alles, bis auf den Mail-Server.

    Problem:

    • kein Login und Abfrage von Mails über Thunderbird und Outlook möglich.
    • Server empfangt keine externe Mails. Es kommt nur eine Antowrt-Mail. Undelivered Mail Returned to Sender
    • Über Roundcube können interne Mails ohne Fehlermeldung verschickt werden, aber sie kommen nicht an.
    • Über Roundcube externe Mails verschicken ist nicht möglich. (Fehlercode 554)

    Da ich eine dynamische IP habe, hab ich meinen Server mit einem Smarthost verbunden.
    Anleitung: email-versand_mit_dynamischer_ip [fezzo's howto's]
    Was kann ich machen, damit der Mail-Server läuft?
     
    Zuletzt bearbeitet: 2. Sep. 2012
  2. F4RR3LL

    F4RR3LL Member

    Na am besten erstmal die Logfiles kontaktieren.
    Ohne deren Inhalt ist weitere Hilfe Glaskugelroulette.
    Welches Howto wurde benutzt? Wurden irgendwelche *persönlichen vorlieben* als Abweichung zum Howto verwendet. Wenn welche.

    Gruß Sven
     
  3. herosalex

    herosalex Member

    Zur verwendeten Anleitung, es war die aktuellste die beim Download dabei war. Abweichungen gibt es keine.
    /var/log/mail.err

    Log in ISPconfig3 - Mail-Protokoll
    Mir scheint, dass die Domain nicht gelistet ist. Was tun?
     
  4. Till

    Till Administrator

    Das Problem ist dass Du eine Domain die für den emailempfang verwendet werden soll als mydestination in postfix main.cf eingertragen hast was dazu führt das Postfix die Emails nicht mehr zustellen kann. Editier die main.cf und trage dort eine subdomain ein wie z.b. server1.mydomain.tld und starte postfix neu.
     
  5. herosalex

    herosalex Member

    Da ich meinen Server zerschossen habe, hab ich ihn neu aufgesetzt.
    Habe deinen Rat befolgt, jetzt funktioniert es teilweise besser.

    aktuelle Fehler:
    kein Login und Abfrage von Mails über Thunderbird und Outlook möglich.
    Über Roundcube externe Mails verschicken ist nicht möglich. (Fehlercode 554)
     
  6. Till

    Till Administrator

    Welche Fehlermeldungen erhältst Du im Log?

    Und welch Anleitung hast Du verwendet? Alle aktuellen Anleitungen sind auf ispconfig.org bzw. ispconfig.de verlinkt, anleitungen im ispconfig tar.gz können veraltet sein, die würde ich nicht verwenden.
     
  7. herosalex

    herosalex Member

    Mail-Error - Log
    Mail - Log
     
  8. Till

    Till Administrator

    Zu den mailclinets: Da der Imap Login per webmail laut Log funktioniert,liegtw ahrscheinlich ein konfigurationsproblem in outlook bzw. Thunderbird zu. Die clients neigen gerne mal dazu den usernamen zu zerstückeln. Der username ist die komplette emailadresse und nicht nur der teil vor dem @. Versuche auch mal die IP des Servers als imap und smtp server zu nehmen um dns Probleme auszuschließen und scahlte ssl imclient aus.

    Zum externen versenden: Laut Log hat arcord die email angenommen:

    Sep 3 16:10:10 meinserver postfix/smtp[19298]: 801A740FD9: to=, relay=mail.arcor.de[***.***.**.***]:25, delay=0.3, delays=0.01/0.02/0.14/0.14, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 6A609270C8)
     
  9. herosalex

    herosalex Member

    Bis auf den Mailversand über Roundcube läuft alles.
    Laut Roundcube ist kein Versand möglich, da kein Empfänger gesetzt werden könnte.
    SMTP Fehler (554)
     
    Zuletzt bearbeitet: 3. Sep. 2012
  10. Till

    Till Administrator

    Schau bitte mal ins mail.log welcher Fehler genau zu der Fehlermeldung in roundcube dazugehört,also welche meldungen neu im log auftachen wenn Du den fehler erhältst.
     
  11. herosalex

    herosalex Member

    Zeitgleich beim verschicken der Mail mit Roundcube, Fehlercode 554.
     
  12. Till

    Till Administrator

  13. herosalex

    herosalex Member

    Der Absender ist von Roundcube vorgegeben und den Empfänger habe ich manuell ohne Anführungszeichen eingegeben. Mit Anführungszeichen kann ich keinen Empfänger angeben.
     

Diese Seite empfehlen