Probleme mit mehr als einer IP

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von SAVERSERVER, 5. Aug. 2010.

  1. SAVERSERVER

    SAVERSERVER Member

    Ich mache besser noch mal einen eigenen/neuen thread auf, sonst findet es warscheinlich keiner! Das ist für mich derzeit ein sehr brennendes PROBLEM! Ausserdem muss es doch jemanden geben, der eine Server bzw. ispconfig3 mit mehr als einer IP nutzt.

    Bekomme endlich doch noch in der nächsten Stunde einen weiteren /24 Adressraum!

    Noch mal eine Allgemein Frage!

    Also unter
    System > Server IP bearbeiten > Neue IP Adresse hinzfügen
    wenn möglich für jede Domain eine IP anlegen.

    Dann kann ich unter
    Sites > Website > Neue Website hinzufügen
    die auswählen und der Domain zuordnen.

    Das ist dann auch die IP wo der Mailserver läuft.
    Also wo der MX hinzeigen soll.

    Danke und
    lg loisl


    Soo habe mal eine weitere (externe)IP für eine Website eingetragen und diese angelegt:
    Nun wenn ich auf dem Server ein

    # traceroute saverserver.eu
    traceroute to <domain.tld> (xx.190.114.xx), 30 hops max, 40 byte packets using UDP
    1 * * *
    2 * * *
    3 * * *
    4 * * *
    5 * * *
    6 <server1.domain.tld> (xx.190.114.x)(H!) 2984.360 ms (H!) 2983.291 ms (H!) 2982.220 ms

    # ping <domain.tld>
    PING <domain.tld> (xx.190.114.xx) 56(84) bytes of data.
    From <server1.domain.tld> (xx.190.114.x): icmp_seq=2 Destination Host Unreachable
    From <server1.domain.tld> (xx.190.114.x) icmp_seq=2 Destination Host Unreachable
    From <server1.domain.tld> (xx.190.114.x) icmp_seq=3 Destination Host Unreachable
    ^C


    und von extern nicht erreichbar!
    $ traceroute <domain.tld>
    traceroute to <domain.tld> (xx.190.114.xx), 64 hops max, 52 byte packets
    1 fritz.box (192.168.178.1) 1.456 ms 1.690 ms 0.915 ms
    2 ppp-default.m-online.net (82.135.16.28) 26.639 ms 27.927 ms 33.702 ms
    3 * * *
    4 xe-1-3-0.r3.muc2.m-online.net (82.135.16.205) 26.205 ms 26.700 ms 25.321 ms
    5 ge5-1.cr3.muc1.content-core.net (80.81.202.1) 26.740 ms 26.894 ms 26.071 ms
    6 p2-92.rtr1.colo3.muc1.content-colo.net (212.123.123.178) 26.153 ms 26.791 ms 26.640 ms
    7 * * *
    8 * * *
    9 * * *
    10 * * *
    11 * * *
    12 * * *
    13 * * *
    14 * * *
    15 * * *
    16 * * *
    17 * * *
    18 * * *
    19 * * *
    20 * * *
    21 * * *
    22 * * *
    23 * * *
    24 * * *
    25 * * *
    26 * * *
    27 * * *
    28 * * *
    29 * * *
    30 * * *
    31 * * *
    32 * * *
    33 * * *
    34 * * *
    35 * * *
    36 * * *
    37 * * *
    38 * * *
    39 * * *
    40 * * *
    41 * * *
    42 * * *
    43 * * *
    44 * * *
    45 * * *
    ^C

    ?????


    Habe in der zwischenzeit noch einen anderen Server aufgesetzt ...
    gleiches ERGEBNIS!

    Wenn ich eine neue Domain anlege und als IP-Adresse "*" (also die IP vom Server) dann ist die Domain erreichbar. Wenn ich eine (wirkliche) IP aswähle, dann ist die Domain nicht erreichbar!

    Folgende ist mir noch augefallen:
    Code:
    [COLOR=Red]
    x705:/ # /etc/init.d/apache2 restart
    [Thu Aug 05 15:18:07 2010] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Thu Aug 05 15:18:07 2010] [warn] NameVirtualHost xx.190.114.xx:443 has no VirtualHosts
    Syntax OK
    Shutting down httpd2 (waiting for all children to terminate)                                                                                         done
    Starting httpd2 (prefork) [Thu Aug 05 15:18:08 2010] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Thu Aug 05 15:18:08 2010] [warn] NameVirtualHost xx.190.114.xx:443 has no VirtualHosts
    Unable to store vlogger data in database
                                                                                                                                                         done
    x705:/ # 
    [/COLOR]
     
  2. Burge

    Burge Member

    wo hin ist das subnetz den geroutet?
    Hast du die ips auch auf dem server selber eingetragen?
     
  3. SAVERSERVER

    SAVERSERVER Member

    DANKE ... bingo, genau da liegt das Problem.

    Muss jetzt nur mal schauen wie das jetzt wieder unter SUSE geht.

    grüsse loisl
     
  4. SAVERSERVER

    SAVERSERVER Member

    Die Nameservereintrage von der Domain zeigen auf die neue IP .

    mittlerweile habe ich auch im yast die Eintrage für die /etc/hosts gefunden und eingetragen.

    wo sich die /etc/network/interfaces versteckt in SUSE bin ich noch am suchen

    grüsse loisl
     
  5. Burge

    Burge Member

    aber du hast bestimmt ein guten und wichtigen Grund Suse zunutzen statt eines guten Debian oder ?

    *grins*
     
  6. SAVERSERVER

    SAVERSERVER Member

    ja leider ;-(

    1) aktueller XEN-Kernel
    2) fertiges HowTo für XEN-basierendes Servercluster (mindestens 5 Clusterserver) mit iSCASI-SAN (zwei SAN mit je 22TB)

    Grüsse loisl
     
  7. SAVERSERVER

    SAVERSERVER Member

    sooo jetzt gefunden:

    # yast2

    Network Devices > Network Settings > Overview
    (Netzwerk-Schnittstelle auswählen) und Edit

    > Adress > Add

    Alias Name : <DOMAINNAME>
    IP Adress: neue IP eintragen
    Netmask: /24

    > OK > Next > OK


    Network Services > Hostnames > Add

    IP Adress: neue IP eintragen
    Hostname: <DOMAIN.tld>
    Hostname Aliases: <DOMAIN.tld>

    > OK > OK


    > Quit
     
  8. SAVERSERVER

    SAVERSERVER Member

    das Rooting klappt nun perfekt ...
    ... jetzt bleibt offensichtlich nur wieder ein SUSE Problem ;-)

    /etc/apache2/sites-available/<Domain.tld>.vhost
    legt nur
    <VirtualHost xx.190.114.xx:80>
    an!!!

    die für port 443 fehlt !!!!!!!

    somit ist die Domain mit https:// nicht erreichbar

    Wo kann ich die Eintrage vornehmen, damit 443 mit angelegt wird
    (so wie es halt unter Debian läuft!)
     
  9. Burge

    Burge Member

    Bin mir nicht sicher aber sollte doch reichen wenn du nun in dem web einfach die option ssl einschaltest.
     
  10. SAVERSERVER

    SAVERSERVER Member

    also wenn Du auch im ISPCONFIG Control-Panel auf der Website administration den Hacken bei SSL meinst, dann ist der drinnen!

    Bei lenny geht das auch so!

    SUSE hat auch keine /etc/apache2/sites-available/default bzw. /etc/apache2/sites-available/default-ssl !!!!
     
    Zuletzt bearbeitet: 5. Aug. 2010
  11. Burge

    Burge Member

    *arg* da hab ich dann auch kein Plan, dachte eigentlich die verwaltung der vhost datein würde isp complett erledigen so das, daß unabhänig von der dist. wäre.

    Mal schaun sicher hat Til da ein Tip.
     
  12. SAVERSERVER

    SAVERSERVER Member

    sehr

    aber gleich noch Problem

    trotz Einträge unter VirtualHost

    Code:
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
    
    und dem vorhandensein des Verzeichnisses /web/error...

    erfolgt die Weiterletung auf die Standard-Errorseiten von APACHE !!!!
     
  13. Till

    Till Administrator

    schau mal in die nicht ispconfig apache config dateien, da steht vermutlich irgendwo ein alias für error drin.
     
  14. SAVERSERVER

    SAVERSERVER Member

    Hi Till,

    Danke um die error-Config kümmere ich mich später ...
    ... habe gerade was am Routing geändert und muss schnell ins RZ fahren!
    ... ist auch nicht so wichtig im gegensatz zu den Virtualhost-Einträgen, hast Du da noch einen Lösungsansatz???


    Besten Dank und
    Liebe Grüsse
    Loisl
     
  15. Till

    Till Administrator

    Die wird nur eingetragen wenn Du über ispconfig ein funktionierendes SSL Cert angelegt hast. Sonst würde der apache ja anicht mehr starten. Erzeuge ein SSL cert in ISPConfig für die website und der 443 Eintrag wird automatisch erstellt.
     
  16. SAVERSERVER

    SAVERSERVER Member

    Zertifikat habe ich über ispconfig erstellt und dann nachträglich mein signiertes in der /ssl drüberkopiert ...

    Aber wie gesagt, kann es im moment nicht nachvolliehen
    Kann es später noch mal neu testen

    Danke grüsse
    loisl
     
  17. SAVERSERVER

    SAVERSERVER Member

    Also folgendes:
    ich gehe auf die (neue) Domain auf SSL
    Einträge in Bundesland .... SSL Domain www.<Domain.tls>
    und SSL Aktion Create Cerificate

    Folgende Datein werden erstellt:
    /srv/www/<Domain.tls>/ssl/www.<Domain.tls>.crt
    /srv/www/<Domain.tls>/ssl/www.<Domain.tls>.csr
    /srv/www/<Domain.tls>/ssl/www.<Domain.tls>.key
    /srv/www/<Domain.tls>/ssl/www.<Domain.tls>.key.org

    Die CSR hat einen Gültigen und Richtigen Inhalt!

    im ispconfig wird automatisch die
    CSR >> SSL Request
    CRT >> SSL Zertifikat
    eingetragen.

    noch einen Hacken bei Domain > SSL

    Aber der <VirtualHost IP:443> wird nicht angelegt
    /etc/apache2/sites-available/<Domain.tls>.vhost

    Wenn ich nochmals im Web Domain > SSL
    auf SSL Aktion Save Certificate gehe,
    dann werden noch folgende Dateien angelegt (identischer Inhalt)
    /srv/www/<Domain.tls>/ssl/<Domain.tls>.crt
    /srv/www/<Domain.tls>/ssl/<Domain.tls>.csr

    Aber der <VirtualHost IP:443> wird nicht angelegt !!!

    Jetzt habe ich den FEHLER!!!
    cp /srv/www/<Domain.tls>/ssl/www.<Domain.tls>.key /srv/www/<Domain.tls>/ssl/<Domain.tls>.key

    und SSL Aktion "Save Certificate"

    Problem liegt an den www !!!!
    jetzt werden die <VirtualHost IP:443> erzeugt und Apache bringt auch keine Fehlermeldung mehr.

    unter https: ist die Seite dennoch nicht erreichbar!

    telnet
    <Domain.tls> 80
    Trying xx.190.114.xx...
    Connected to
    <Domain.tls>.
    Connection closed by foreign host.

    telnet
    <Domain.tls> 443
    Trying xx.190.114.xx...
    telnet: connect to address xx.190.114.xx: Connection refused
    telnet: Unable to connect to remote host

    AUCH GELÖST:
    ==========

    Code:
    [COLOR=Red][COLOR=Black]Wenn Port 443 geschlossen:
    ##########################
    
    # nano /etc/apache2/listen.conf
    
    Suchen und Kommentar entfernen:
    Listen 443
    
    Neustart:
    # /etc/init.d/apache2 restart
    [/COLOR][/COLOR]
     
    Zuletzt bearbeitet: 7. Aug. 2010
  18. SAVERSERVER

    SAVERSERVER Member

    Standard-Errorseiten von APACHE auf EIGENE ändern!

    Das habe ich schon mal gelöst:

    LÖSUNG:
    Code:
    # nano /etc/apache2/httpd.conf
    Suchen nach:
    # set up (customizable) error responses
    Include /etc/apache2/errors.conf
    Ersetzen mit:
    # set up (customizable) error responses
    #Include /etc/apache2/errors.conf
    ServerRoot "/etc/apache2"
    
    Apache neu starten:
    # /etc/init.d/apache2 restart
    
     

Diese Seite empfehlen