Probleme mit Postfix Posteingang

#1
Hallo Liebe Community

Habe leider keine Ahnung von Linux, muste aber meinen Windows 2008 Server ersetzen, da er mit einer Flut an Spam angegriffen wurde.
Nach dieser Anleitung habe ich mir den Server aufgebaut.
Der Perfekte Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3)
Danke
So und nun zu meinem 1 Problem.
Bekomme im Log von ISPConfig3 folgende Meldung:

server1 postfix/smtp[1991]: D89B0DC1C8C: to=<www-data@server1.xiweb.ch>, relay=none, delay=0.09, delays=0.03/0/0.06/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.xiweb.ch type=A: Host not found)

Das 2 Problem ist das 99% aller Mails ankommen im Posteingang und dies nicht:
May 6 13:14:33 server1 postfix/smtpd[28196]: SSL_accept error from mail.zg.ch[193.134.12.15]: Connection timed out
May 6 13:14:33 server1 postfix/smtpd[28196]: lost connection after STARTTLS from mail.zg.ch[193.134.12.15]
May 6 13:14:33 server1 postfix/smtpd[28196]: disconnect from mail.zg.ch[193.134.12.15]
May 6 13:15:01 server1 postfix/smtpd[28196]: connect from localhost.localdomain[127.0.0.1]
May 6 13:15:01 server1 postfix/smtpd[28196]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
May 6 13:15:01 server1 postfix/smtpd[28196]: disconnect from localhost.localdomain[127.0.0.1]

Per Telnet geht ist es kein Problem

Danke für eure Hilfe PS: Nochmals bin Anfänger
 

Till

Administrator
#2
Zum 1. Fehler. "server1.xiweb.ch" ist scher der hostname Deines Servers? Der Hostname muss im DNS existieren, lege also im DNS Server der Domain xiweb.ch einen A-Record für "server1" an der auf die IP des ISPConfig Servers verweist.

Zum 2. problem. Der Server mail.zg.ch scheint keine Verbindungen von Deinem Server anzunehmen. das kann sehr gut mit dem Problem 1) zusammen hängen. denn die meisten Server lehnen email connects ab, wenn der hostname des sendenden servers im dns nicht existiert.
 
#3
Danke für die Rasche Antwort:

server1 A interne Server IP Adresse 192.168.xxx.xxx
xiweb.ch A FIX IP vom Provider 212.147.xxx.xxx

ist das so Korrekt?
 
#5
Nochmals Danke für die Hilfe

Diese Einstellungen hatte ich aber schon

May 6 21:40:02 server1 postfix/smtp[8651]: 292EFDC1C77: to=<root@server1.xiweb.ch>, orig_to=<root>, relay=none, delay=0.16, delays=0.08/0.01/0.06/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.xiweb.ch type=A: Host not found)

May 6 21:40:02 server1 postfix/smtp[8651]: 4EF5BDC1C8C: to=<www-data@server1.xiweb.ch>, relay=none, delay=0.1, delays=0.04/0/0.06/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.xiweb.ch type=A: Host not found)

May 7 13:30:02 server1 postfix/smtp[32668]: 835D0DC0C2A: to=<www-data@server1.xiweb.ch>, relay=none, delay=0.12, delays=0.03/0/0.09/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.xiweb.ch type=AAAA: Host not found)
 
Zuletzt bearbeitet:

nowayback

Well-Known Member
#6
es dauert eine weile bis dns einträge sich verbreitet haben...

ich habe eben mal deine namensauflösung getestet und bekomme aktuell nur eine ip zurück für den www A Record. Wenn du also alles richtig eingetragen hast, dann wirst du dich etwas gedulden müssen bevor du es weiter testen kannst. Außerdem würde ich die Zeit nutzen und checken ob auch der Reverse DNS Eintrag passt und auf server1.deinedomain.ch zeigt.
 
#7
Problem 2

Hallo und Entschuldigung

Leider scheint das Problem noch nicht behoben:

server1 postfix/smtpd[1366]: SSL_accept error from mail.zg.ch[193.134.12.15]: Connection timed out
May 7 14:23:00 server1 postfix/smtpd[1366]: lost connection after STARTTLS from mail.zg.ch[193.134.12.15]
May 7 14:23:00 server1 postfix/smtpd[1366]: disconnect from mail.zg.ch[193.134.12.15]

May 7 16:03:07 server1 postfix/smtpd[3926]: SSL_accept error from sbbmail04.sbb.ch[194.150.244.69]: Connection timed out
May 7 16:03:07 server1 postfix/smtpd[3926]: lost connection after STARTTLS from sbbmail04.sbb.ch[194.150.244.69]
May 7 16:03:07 server1 postfix/smtpd[3926]: disconnect from sbbmail04.sbb.ch[194.150.244.69]
May 7 16:03:17 server1 postfix/smtpd[3926]: connect from outmail64.swisscom.com[194.11.148.64]
May 7 16:03:17 server1 postfix/smtpd[3926]: SSL_accept error from outmail64.swisscom.com[194.11.148.64]: 0
May 7 16:03:17 server1 postfix/smtpd[3926]: warning: TLS library problem: 3926:error:14094438:SSL routines:SSL3_READ_BYTES:tlsv1 alert internal error:s3_pkt.c:1260:SSL alert number 80:
May 7 16:03:17 server1 postfix/smtpd[3926]: lost connection after STARTTLS from outmail64.swisscom.com[194.11.148.64]
May 7 16:03:17 server1 postfix/smtpd[3926]: disconnect from outmail64.swisscom.com[194.11.148.64]
May 7 16:03:32 server1 postfix/smtpd[3926]: connect from mail-gw23.credit-suisse.com[198.240.212.11]

May 7 17:08:07 server1 postfix/smtpd[6239]: SSL_accept error from sbbmail04.sbb.ch[194.150.244.69]: Connection timed out
May 7 17:08:07 server1 postfix/smtpd[6239]: lost connection after STARTTLS from sbbmail04.sbb.ch[194.150.244.69]
May 7 17:08:07 server1 postfix/smtpd[6239]: disconnect from sbbmail04.sbb.ch[194.150.244.69]
May 7 17:08:32 server1 postfix/smtpd[6067]: SSL_accept error from mail2.pixer.mobi[69.50.254.102]: Connection timed out
May 7 17:08:32 server1 postfix/smtpd[6067]: lost connection after STARTTLS from mail2.pixer.mobi[69.50.254.102]
May 7 17:08:32 server1 postfix/smtpd[6067]: disconnect from mail2.pixer.mobi[69.50.254.102]

Was jetzt noch kamm im Log war diese Meldung:

server1 postfix/smtpd[1701]: warning: TLS library problem: 1701:error:1409442E:SSL routines:SSL3_READ_BYTES:tlsv1 alert protocol version:s3_pkt.c:1260:SSL alert number 70:

Jetzt bekomme ich langsam Angst

May 7 18:08:09 server1 postfix/smtpd[7614]: connect from sbbmail04.sbb.ch[194.150.244.69]
May 7 18:08:09 server1 postfix/smtpd[7614]: SSL_accept error from sbbmail04.sbb.ch[194.150.244.69]: 0
May 7 18:08:09 server1 postfix/smtpd[7614]: warning: TLS library problem: 7614:error:14094438:SSL routines:SSL3_READ_BYTES:tlsv1 alert internal error:s3_pkt.c:1260:SSL alert number 80:
May 7 18:08:09 server1 postfix/smtpd[7614]: lost connection after STARTTLS from sbbmail04.sbb.ch[194.150.244.69]
May 7 18:08:09 server1 postfix/smtpd[7614]: disconnect from sbbmail04.sbb.ch[194.150.244.69]
May 7 18:08:53 server1 postfix/smtpd[7614]: connect from mail-gw23.credit-suisse.com[198.240.212.11]
May 7 18:15:02 server1 postfix/smtpd[7614]: connect from localhost.localdomain[127.0.0.1]
May 7 18:15:02 server1 postfix/smtpd[7614]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
May 7 18:15:02 server1 postfix/smtpd[7614]: disconnect from localhost.localdomain[127.0.0.1]
May 7 18:15:02 server1 dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
 
Zuletzt bearbeitet:
#9
Problem 2

Problem 2 überfordert mich dermassen das Ich Angst bekomme.
Bitte um Hilfe!
Es kann ja nicht seine das diese Absender (Sender) ihr Mails nicht ins Empfänger Postfach ablegen können. Vor meiner Umstellung auf Postfix lief das ohne Probleme auf dem hmailServer.
Ich Verzweifle bevor ich was mache an der Konfiguration bitte ich euch um eure Mithilfe.
server1 postfix/smtpd[1366]: SSL_accept error from mail.zg.ch[193.134.12.15]: Connection timed out
May 7 14:23:00 server1 postfix/smtpd[1366]: lost connection after STARTTLS from mail.zg.ch[193.134.12.15]
May 7 14:23:00 server1 postfix/smtpd[1366]: disconnect from mail.zg.ch[193.134.12.15]

May 7 16:03:07 server1 postfix/smtpd[3926]: SSL_accept error from sbbmail04.sbb.ch[194.150.244.69]: Connection timed out
May 7 16:03:07 server1 postfix/smtpd[3926]: lost connection after STARTTLS from sbbmail04.sbb.ch[194.150.244.69]
May 7 16:03:07 server1 postfix/smtpd[3926]: disconnect from sbbmail04.sbb.ch[194.150.244.69]
May 7 16:03:17 server1 postfix/smtpd[3926]: connect from outmail64.swisscom.com[194.11.148.64]
May 7 16:03:17 server1 postfix/smtpd[3926]: SSL_accept error from outmail64.swisscom.com[194.11.148.64]: 0
May 7 16:03:17 server1 postfix/smtpd[3926]: warning: TLS library problem: 3926:error:14094438:SSL routines:SSL3_READ_BYTES:tlsv1 alert internal error:s3_pkt.c:1260:SSL alert number 80:
May 7 16:03:17 server1 postfix/smtpd[3926]: lost connection after STARTTLS from outmail64.swisscom.com[194.11.148.64]
May 7 16:03:17 server1 postfix/smtpd[3926]: disconnect from outmail64.swisscom.com[194.11.148.64]
May 7 16:03:32 server1 postfix/smtpd[3926]: connect from mail-gw23.credit-suisse.com[198.240.212.11]

May 7 17:08:07 server1 postfix/smtpd[6239]: SSL_accept error from sbbmail04.sbb.ch[194.150.244.69]: Connection timed out
May 7 17:08:07 server1 postfix/smtpd[6239]: lost connection after STARTTLS from sbbmail04.sbb.ch[194.150.244.69]
May 7 17:08:07 server1 postfix/smtpd[6239]: disconnect from sbbmail04.sbb.ch[194.150.244.69]
May 7 17:08:32 server1 postfix/smtpd[6067]: SSL_accept error from mail2.pixer.mobi[69.50.254.102]: Connection timed out
May 7 17:08:32 server1 postfix/smtpd[6067]: lost connection after STARTTLS from mail2.pixer.mobi[69.50.254.102]
May 7 17:08:32 server1 postfix/smtpd[6067]: disconnect from mail2.pixer.mobi[69.50.254.102]

May 7 17:33:01 server1 postfix/smtpd[6239]: SSL_accept error from mail.zg.ch[193.134.12.15]: Connection timed out
May 7 17:33:01 server1 postfix/smtpd[6239]: lost connection after STARTTLS from mail.zg.ch[193.134.12.15]
May 7 17:33:01 server1 postfix/smtpd[6239]: disconnect from mail.zg.ch[193.134.12.15]

May 7 18:08:09 server1 postfix/smtpd[7614]: connect from sbbmail04.sbb.ch[194.150.244.69]
May 7 18:08:09 server1 postfix/smtpd[7614]: SSL_accept error from sbbmail04.sbb.ch[194.150.244.69]: 0
May 7 18:08:09 server1 postfix/smtpd[7614]: warning: TLS library problem: 7614:error:14094438:SSL routines:SSL3_READ_BYTES:tlsv1 alert internal error:s3_pkt.c:1260:SSL alert number 80:
May 7 18:08:09 server1 postfix/smtpd[7614]: lost connection after STARTTLS from sbbmail04.sbb.ch[194.150.244.69]
May 7 18:08:09 server1 postfix/smtpd[7614]: disconnect from sbbmail04.sbb.ch[194.150.244.69]
May 7 18:08:53 server1 postfix/smtpd[7614]: connect from mail-gw23.credit-suisse.com[198.240.212.11]
May 7 18:15:02 server1 postfix/smtpd[7614]: connect from localhost.localdomain[127.0.0.1]
May 7 18:15:02 server1 postfix/smtpd[7614]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
May 7 18:15:02 server1 postfix/smtpd[7614]: disconnect from localhost.localdomain[127.0.0.1]
May 7 18:15:02 server1 dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured

May 8 12:43:52 server1 postfix/smtpd[21965]: SSL_accept error from smtp.nfrance.com[80.247.228.92]: Connection timed out
May 8 12:43:52 server1 postfix/smtpd[21965]: lost connection after STARTTLS from smtp.nfrance.com[80.247.228.92]
May 8 12:43:52 server1 postfix/smtpd[21965]: disconnect from smtp.nfrance.com[80.247.228.92]
May 8 12:44:05 server1 postfix/smtpd[22105]: SSL_accept error from mail2.pixer.mobi[69.50.254.102]: Connection timed out
May 8 12:44:05 server1 postfix/smtpd[22105]: lost connection after STARTTLS from mail2.pixer.mobi[69.50.254.102]
May 8 12:44:05 server1 postfix/smtpd[22105]: disconnect from mail2.pixer.mobi[69.50.254.102]
 
Zuletzt bearbeitet:

Till

Administrator
#10
Wahrscheinlich ist das ssl Zertifikat von postfix auf Deinem server defekt. Erstell mal ein neues.

Code:
cd /etc/postfix/
mv smtpd.cert smtpd.cert.old
mv smtpd.key smtpd.key.old
openssl genrsa -out smtpd.key 2048
openssl req -new -x509 -key smtpd.key -out smtpd.cert -days 3650
chmod 640 smtpd.key
/etc/init.d/postfix restart
/etc/init.d/dovecot restart
 
#11
Problem 2 Behoben

Danke Till für alles nun ist auch diese Problem Behoben

Danke nochmals

Jetzt habe ich noch ein kleines Problem und zwar mit Amavis-Spam-Virenfilter

Log-Meldung:
Thu May 8 14:35:49 2014 -> Received signal: wake up
Thu May 8 14:35:49 2014 -> ClamAV update process started at Thu May 8 14:35:49 2014
Thu May 8 14:35:50 2014 -> WARNING: Your ClamAV installation is OUTDATED!
Thu May 8 14:35:50 2014 -> WARNING: Local version: 0.98.1 Recommended version: 0.98.3
Thu May 8 14:35:50 2014 -> DON'T PANIC! Read http://www.clamav.net/support/faq
Thu May 8 14:35:50 2014 -> main.cvd is up to date (version: 55, sigs: 2424225, f-level: 60, builder: neo)
Thu May 8 14:35:50 2014 -> Downloading daily-18945.cdiff [100%]
Thu May 8 14:35:54 2014 -> daily.cld updated (version: 18945, sigs: 937934, f-level: 63, builder: neo)
Thu May 8 14:35:54 2014 -> bytecode.cvd is up to date (version: 236, sigs: 43, f-level: 63, builder: dgoddard)
Thu May 8 14:35:59 2014 -> Database updated (3362202 signatures) from db.local.clamav.net (IP: 193.230.240.8)
 

Till

Administrator
#13
Die Warning oben ist kein Problem. Bitte nicht auf die Idee kommen da manuell ein update zu installieren, das schadet nur dem System. Ubuntu aktualisiert die Pakete per patches wenn nötig ohne die Versionsnummer zu erhöhen, daher kommen von clamav warnings da es das nicht mitbekommt und man kann die zu ignorieren.
 

Werbung