Probleme mit webdav

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von demmtree, 13. Mai 2009.

  1. demmtree

    demmtree New Member

    Hi,

    ich habe auf meinem ISPConfig 3 System Webdav nach folgendem Howto installiert: http://www.howtoforge.com/how-to-set-up-webdav-with-mysql-authentication-on-apache2-debian-lenny

    Funktioniert soweit alles auch, die mysql db wird gefunden und kann gelesen werden, ich und andere können sich mit Namen und PW einloggen, allerdings ist es nicht möglich Dateien hochzuladen. Hier mal das error.log:
    Code:
    [Wed May 13 11:08:44 2009] [error] [client 80.108.***.***] Unable to PUT new contents for /webdav/test.ics.  [403, #0]
    [Wed May 13 11:08:44 2009] [error] [client 80.108.***.***] (13)Permission denied: An error occurred while opening a resource.  [500, #0]
    
    und dann hier einmal der cadaver login mit anschließendem ls:
    Code:
    cadaver http://www.meinserver.org/webdav
    Authentication required for webdav on server `www.meinserver.org':
    Username: meinname
    Password:
    dav:/webdav/> ls
    Listing collection `/webdav/': succeeded.
    Coll:   error                                  0  Apr 15 18:22
    Coll:   stats                                  0  Mai  2 02:30
           *.htaccess                              0  Apr 15 18:22
           *favicon.ico                         1406  Apr 15 18:22
           *index.html                          1861  Apr 15 18:22
           *robots.txt                            34  Apr 15 18:22
    dav:/webdav/>
    

    Jemand eine Idee?
     
  2. demmtree

    demmtree New Member

    Bin alles nochmal von vorne durchgegangen, hat aber nicht viel gebracht. Wo erwartet Apache denn den entsprechenden Ortner für die Webdav-Inhalte? Im Howto wird ein solcher Ortner gar nicht erstellt.
     
  3. Till

    Till Administrator

    Das Tutorial is ja nicht für ispconfig 3, also bei ispconfig 3 fügst Du einfach das Folgende in das apache direktiven Feld der Website ein:

    Code:
    Alias /webdav /var/www/web1/web
    <Location /webdav>
    DAV On
    AuthBasicAuthoritative Off
    AuthUserFile /dev/null
    AuthMySQL On
    AuthName "webdav"
    AuthType Basic
    Auth_MySQL_Host localhost
    Auth_MySQL_User webdav_admin
    Auth_MySQL_Password webdav_admin_password
    AuthMySQL_DB webdav
    AuthMySQL_Password_Table mysql_auth
    Auth_MySQL_Username_Field username
    Auth_MySQL_Password_Field passwd
    Auth_MySQL_Empty_Passwords Off
    Auth_MySQL_Encryption_Types PHP_MD5
    Auth_MySQL_Authoritative On
    require valid-user
    </Location>
    wobei Du die Zeile:

    Alias /webdav /var/www/web1/web natürlich anpassen musst, die muss dann sowas sein wie:

    Alias /webdav /var/clients/client0/web1/web
     
  4. demmtree

    demmtree New Member

    Habe ich gemacht, funktioniert leider noch immer nicht.
    Code:
    [Sun May 17 17:01:45 2009] [error] [client 80.108.***.***] Unable to PUT new contents for /webdav/****-uni.ics.  [403, #0]
    [Sun May 17 17:01:45 2009] [error] [client 80.108.***.***] (13)Permission denied: An error occurred while opening a resource.  [500, #0]
    
    
    
     
  5. Till

    Till Administrator

    Stehst dazu noch etwas mehr im apache error log oder im error.log der webseite?
     
  6. demmtree

    demmtree New Member

    nein, leider nicht. also der gestern veröffentlichte auszug stammt aus dem error.log der webseite, im apache error.log finde ich nur sowas:

    Code:
    [Mon May 18 08:05:56 2009] [error] [client 204.225.***.***] Invalid method in request \x80z\x01\x03\x01
    [Mon May 18 08:08:31 2009] [error] [client 204.225.***.***] Invalid method in request \x80z\x01\x03\x01
    [Mon May 18 12:13:07 2009] [error] [client 128.2.***.***] Invalid method in request \x80z\x01\x03\x01
    [Mon May 18 12:15:24 2009] [error] [client 128.2.***.***] Invalid method in request \x80z\x01\x03\x01
    
    Scheint aber rein zeitlich keinen Zusammenhang mit den Webdav Problemen zu geben.
     
  7. demmtree

    demmtree New Member

    Kann ansonsten irgendein Admin das Thema in die Ispconfig Foren verschieben? Da ist irgendwie mehr los und das Thema ist dort eigentlich auch besser aufgehoben.
     
  8. demmtree

    demmtree New Member

    push :)

    falls es tatsächlich nicht möglich sein sollte Webdav auf Mysql basis zu realisieren, weiß eventuell jemand ein Howto mit dem Webdav anders eingerichtet werden könnte? System läuft unter ISPconfig 3
     
  9. Till

    Till Administrator

    Das sollte generell schon gehen. hab ich aber noch nicht gebraucht, also kann ich Dir auch nicht sagen wo genau das Konfigurationsproblem liegt. ISPConfig schreibt nur einen ganz normalen standard vhost, daran sollte es also nicht liegen. Must Du ggf, mal auf der Webseite vom webdav apache Modul oder in Google suchen, was Du zu dieser Fehlermeldung findest.
     

Diese Seite empfehlen