Problemsammlung SSL,Webmail,Configoberfläche,webalizer

#1
Hallo Leute,
als erstes möchte ich mich für das super Tool/Programm ISPConfig bedankten
es erleichtert die Arbeit wirklich ungemein!

Ich habe das nun mehrere Wochen im Test und mir sind mehrere Sachen/Probleme aufgefallen, was ISPConfig betrifft, vllt. sind es auch nur Konfiguration Fehler.
Konfiguration:
Der ISPConfig (Debian) ist im Standalone Betrieb bei mir im Homenetzwerk!
Auf meinem Router habe ich die nötigen Ports eingetragen und mit Portforwarding zu dem Server befördert.
Auf den ISP laufen mehrere Domain.
Den Nameserver der Domain regelt mein Domainanbieter.
Dort habe ich den „hostnamen“ (isp.isp.tld) per A-Eintrag zu meinem Router
Die Subdomain habe ich per CNAME-Eintrage (Aliase) auf den Hostnamen (isp.isp.tld) eingetragen
Die anderen Domain habe ich ebenfalls NUR per CNAME eingetragen (bis auf LEER.domain.tld das läuft er Weiterleitung auf www….)

- Der Server hat den Namen: isp.isp.tld
- eingetragenen Web/Mail Domain unterscheiden sich natürlich von der „Hostdomain“
Probleme:
1. Wenn ich nun meine IP direkt im Browser eingebe komme ich direkt auf /var/www
wenn ich aber zusätzlich noch Management Port angebe z.B. IP:8080 -> ispconfig,
genauso wenn ich einen andere Domain eingebe mit dem Port
Genauso komme ich da drauf wenn ich folgendes eingebe: IP/ispconfig
--> ich möchte das ISPConfig z.B NUR über den Port erreichbar ist
2. Das Verzeichnis /var/www/webalizer/ ist ohne Kennwort Abfrage abrufbar (Sicherheit Problem) kommt man ebenfalls leicht über IP/webalizer bzw. isp.isp.tld/webalizer drauf.
Der Ordner ist nur beim Anlegen einer Domain mit einem Kennwort möglich zu schützen, aber eben nicht im „root-Verzeichnis“ von www
3. Wie kann ich machen das jede Domain seinen eigenen webmailer über z.B. webmail.domain.tld abrufen kann und nicht global über isp.tld/webmail ????
4. SSL auf eine Website, im Handbuch Seite 263 steht das dort eine IP ausgewählt werden muss, bei mir ist nur ein WILDCARD vorhanden!
 

nowayback

Well-Known Member
#2
Moinsen,

trag mal unter System -> Server IP bearbeiten deine IP des Servers ein und dann wähle bei den Domains nicht * aus als IP sondern die IP.

Das sollte bereits viele, wenn nicht sogar alle deine Probleme beheben außer das webalizer Problem. Das kann ich persönlich auch nicht nachvollziehen, da ich awstats einsetze und da ist in jeder Domain das entsprechene stats Verzeichnis mit Kennwort versehen.

Grüße
nwb
 
#3
"3. Wie kann ich machen das jede Domain seinen eigenen webmailer über z.B. webmail.domain.tld abrufen kann und nicht global über isp.tld/webmail ????"

Denke das du da Hand anlegen muss, ich persönlich finde das auch blödsinig denn du kann den Link im Interface anlegen und man macht ja eine Hauptdomain zb. webmail.hosterdomain.de dort können alle Kunden zugreifen oder halt per Klick im Interface.

Mit den Stats mache ich das auch wie nowayback der rest deiner Probleme ist die IP.
 
#4
Danke schon mal für die Antwort, werde das mal am Montag versuche.

Aber welche IP kommt da rein, da ich es im Homenetzwerk betreibe, kommt da die externe oder interne IP rein?
 
#5
hast du ne dynamische IP ?

Das ist eine gaaanz schlechte Idee. Mailserver hinter Dial-In-Adressen sind immer "verdächtig".

Das größte Problem ist, daß man keinen Einfluss darauf hat, welche IP einem nach 24h zugewiesen wird. Das kann dann auch eine sein, deren "Vorbesitzer" einen Spamtrojaner auf'm Rechner hatte und die IP deshalb in nahezu allen Blacklists steht. Dann war's das mit dem Mailserver auf der IP...

Einzige Alternative: für Outgoing-Mail einen "echten" Mailserver als SMTP-Relay nutzen.
 
Zuletzt bearbeitet:

Till

Administrator
#7
Zu 1) Dann löschst Du einfach den Symlink für den Zufriff ohne Port:

rm -f /var/www/ispconfig

Zu 2) das ist kein verzeichnis von ispconfig. Vermutlich hast Du irgendwo noch einen crinjob für webalizer der zur Linux Distribution gehört am laufen. Der sollte gelöscht werden, ispconfig uft webalizer selbst auf und benötigt den system cronjob für webalizer micht.

zu 3) Der Aufruf ist normalerweise kundendomain.tld/webmail und nicht nur ispdomain.tld/webmail. Wenn Du eine eigene subdomain für jedes kundenwebmail haben möchtest, dann musst Du sie für jeden Kunden anlegen.

zu 4) Du musst die interne IP (also IP des servers) unter System > Server IP einfügen.
 
#8
Zu 1) Dann löschst Du einfach den Symlink für den Zufriff ohne Port:
rm -f /var/www/ispconfig
Ich will gerne das ich NUR über den Port zugreifen können, wenn ich den Symlink lösche, dann es nicht mal mehr über den Port, da der vhost eintrag besagt
<IfModule mod_fcgid.c>
DocumentRoot /var/www/ispconfig/
oder ist hier der
<IfModule mod_php5.c>
DocumentRoot /usr/local/ispconfig/interface/web/
aktiv?
Zu 2) das ist kein verzeichnis von ispconfig. Vermutlich hast Du irgendwo noch einen crinjob für webalizer der zur Linux Distribution gehört am laufen. Der sollte gelöscht werden, ispconfig uft webalizer selbst auf und benötigt den system cronjob für webalizer micht.
habe alles was die Installation betrifft strickt nach der Anleitung gemacht.
HowtoForge Linux Tutorials » Der Perfekte Server - Debian Squeeze (Debian 6.0) mit BIND & Dovecot [ISPConfig 3]
unter Punkt 15 steht das man den Cron-job nur für awstats deaktivieren soll.
Warscheinlich also noch zusätzlich cron.daily deaktivieren, damit er mir nichts in /var/www/webalizer mehr schreibt.
EDIT: Nach dem einfügen der IP bei den ganzen Domain, kann ich nun über ispdomain.tld/webalizer nicht mehr aufrufen. SUPER!!!

zu 3) Der Aufruf ist normalerweise kundendomain.tld/webmail und nicht nur ispdomain.tld/webmail. Wenn Du eine eigene subdomain für jedes kundenwebmail haben möchtest, dann musst Du sie für jeden Kunden anlegen.
kundendomain.tld/webmail diese Variante geht leider bei mir nicht.
ich Nutze dafür Roundcube und der ist installiert unter /var/www/webmail (noch), würde aber wie beschrieben gerne mail.kunde.tld habe, bzw. mail.ispdomain.tld würde mir aber auch schon reichen (aber dann soll ispdomain.tld/webmail nicht mehr möglich sein)

zu 4) Du musst die interne IP (also IP des Servers) unter System > Server IP einfügen.
Habe mal die interne IP (Privates Netz) in System/Server IP bearbeiten eingetragen und bei Webseiten bei der Domain / hinzugefügt.
 
Zuletzt bearbeitet:

Till

Administrator
#9
Ich will gerne das ich NUR über den Port zugreifen können, wenn ich den Symlink lösche, dann es nicht mal mehr über den Port, da der vhost eintrag besagt
<IfModule mod_fcgid.c>
DocumentRoot /var/www/ispconfig/
oder ist hier der
<IfModule mod_php5.c>
DocumentRoot /usr/local/ispconfig/interface/web/
aktiv?
Dann fehlt bei Dir mod_php, denn wenn mod_php aktiv ist, kannst Du den symlink problemlos löschen. Schau mal weiter unten im vhost.

kundendomain.tld/webmail diese Variante geht leider bei mir nicht.
ich Nutze dafür Roundcube und der ist installiert unter /var/www/webmail (noch), würde aber wie beschrieben gerne mail.kunde.tld habe, bzw. mail.ispdomain.tld würde mir aber auch schon reichen (aber dann soll ispdomain.tld/webmail nicht mehr möglich sein)
Das geht mit jedem Webmail, also auch mit roundcube denn es wird über einen alias in /etc/apache2/conf.d/ geregelt.
 
#10
Dann fehlt bei Dir mod_php, denn wenn mod_php aktiv ist, kannst Du den symlink problemlos löschen. Schau mal weiter unten im vhost.



Das geht mit jedem Webmail, also auch mit roundcube denn es wird über einen alias in /etc/apache2/conf.d/ geregelt.
Also mod_php ist doch aktiv:
<IfModule mod_php5.c>
DocumentRoot /usr/local/ispconfig/interface/web/
AddType application/x-httpd-php .php
<Directory /usr/local/ispconfig/interface/web>
# php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
php_value magic_quotes_gpc 0
</Directory>
</IfModule>

wie müsste den der alias in /etc/apache2/conf.d/ aussehen?

oder könnte ich den nicht eine sub anlegen und diese subdomain auf den Ordner verweisen lassen?
 
#11
Warum so umständlich, leg Dir eine Subdomain an.
Kopiere den Inhalt von /var/www/webmail/* nach /var/www/subdomain/web/ passe die Rechte des Inhaltes mit chown an, dann ist das sauber.
Um dann deine jeweiligen anderen Domains mit webmail.domain.tld erreichbar zu machen legst Du einfach eine Aliasdomain an.
 

Till

Administrator
#12
Das kannst Du daran aber nicht ablesen, denn die steht in einem if drin, sie wird also nur dann genommen wenn Du auch mod_php aktiviert hast.. Wenn Du wissen willst ob mod_php aktiv ist, dann ruf auf:

a2enmod php5

wie müsste den der alias in /etc/apache2/conf.d/ aussehen?
Schau mal ins perfect setup unter 20.2, dort steht das für squirrelmail drin und genauso kannst Du auch einen Alias für roundcube einrichten.

The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Dovecot [ISPConfig 3] - Page 6 | HowtoForge - Linux Howtos and Tutorials
 

Werbung

Top