ProFTP

#3
im syslog steht

Oct 26 21:10:04 meinServername proftpd[4821]: localhost.localdomain - Failed binding to 0.0.0.0, port 21: Address already in use
Oct 26 21:10:04 meinServername proftpd[4821]: localhost.localdomain - Check the ServerType directive to ensure you are configured correctly.
Oct 26 21:10:50 meinServername proftpd[4902]: localhost.localdomain - Failed binding to 0.0.0.0, port 21: Die Adresse wird bereits verwendet
Oct 26 21:10:50 meinServername proftpd[4902]: localhost.localdomain - Check the ServerType directive to ensure you are configured correctly.
Oct 26 21:12:57 meinServername proftpd[5053]: localhost.localdomain - Failed binding to 0.0.0.0, port 21: Die Adresse wird bereits verwendet
Oct 26 21:12:57 meinServername proftpd[5053]: localhost.localdomain - Check the ServerType directive to ensure you are configured correctly.
Oct 26 21:15:32 meinServername proftpd[5278]: localhost.localdomain - Failed binding to 0.0.0.0, port 21: Die Adresse wird bereits verwendet
Oct 26 21:15:32 meinServername proftpd[5278]: localhost.localdomain - Check the ServerType directive to ensure you are configured correctly.
Oct 26 21:19:09 meinServername inetd[3605]: ftp/tcp: bind: Address already in use
Oct 26 21:21:42 meinServername proftpd[5810]: connect from 213.229.106.224 (213.229.106.224)
Oct 26 21:21:42 meinServername proftpd[5810]: setting default address to 127.0.0.1
Oct 26 21:21:42 meinServername proftpd[5811]: localhost.localdomain - Failed binding to 0.0.0.0, port 21: Address already in use
Oct 26 21:21:42 meinServername proftpd[5811]: localhost.localdomain - Check the ServerType directive to ensure you are configured correctly.
Oct 26 21:29:09 meinServername inetd[3605]: ftp/tcp: bind: Address already in use
Oct 26 21:39:09 meinServername inetd[3605]: ftp/tcp: bind: Address already in use
Oct 26 21:49:09 meinServername inetd[3605]: ftp/tcp: bind: Address already in use
Oct 26 21:59:09 meinServername inetd[3605]: ftp/tcp: bind: Address already in use
Oct 26 22:09:09 meinServername inetd[3605]: ftp/tcp: bind: Address already in use
Oct 26 22:19:09 meinServername inetd[3605]: ftp/tcp: bind: Address already in use
Checke ich den Port kommt
PID ist
ps aux | grep 8001
root 8001 0.0 0.0 10132 676 ? Ss 16:26 0:00 /usr/sbin/inetd
root 11964 0.0 0.0 90012 816 pts/0 R+ 22:36 0:00 grep 8001
 
Zuletzt bearbeitet:
#5
Jetzt habe ich noch das Problem, dass ständig Mails kommen mit

sa-update Update Status for 2010_10_26 - Error
An error occured while attempting to download and extract updates. You are still running .
bei einem manuellen ausführen von sa-update erhalte ich

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update
Can't locate NetAddr/IP.pm in @INC (@INC contains: /home/admispconfig/ispconfig/tools/spamassassin/usr/share/perl/5.8.8 /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl) at /home/admispconfig/ispconfig/tools/spamassassin/usr/share/perl/5.8.8/Mail/SpamAssassin/NetSet.pm line 25.
BEGIN failed--compilation aborted at /home/admispconfig/ispconfig/tools/spamassassin/usr/share/perl/5.8.8/Mail/SpamAssassin/NetSet.pm line 25.
Compilation failed in require at /home/admispconfig/ispconfig/tools/spamassassin/usr/share/perl/5.8.8/Mail/SpamAssassin/Conf.pm line 86.
BEGIN failed--compilation aborted at /home/admispconfig/ispconfig/tools/spamassassin/usr/share/perl/5.8.8/Mail/SpamAssassin/Conf.pm line 86.
Compilation failed in require at /home/admispconfig/ispconfig/tools/spamassassin/usr/share/perl/5.8.8/Mail/SpamAssassin.pm line 71.
BEGIN failed--compilation aborted at /home/admispconfig/ispconfig/tools/spamassassin/usr/share/perl/5.8.8/Mail/SpamAssassin.pm line 71.
Compilation failed in require at /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update line 92.
BEGIN failed--compilation aborted at /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update line 92.
 
#6
Mir fällt gerade auf, dass ProFTP immer nach einem Neustart nicht geht. Nun habe ich, nachdem ich nochmal neu gestartet habe, wieder das gleiche Problem. Woran kann das liegen?
 

Till

Administrator
#9
Neustarten und dann "netstat -tap" aufrufen um zu sehen, ob dort ein anderer FTP läuft. Wenn es das nicht ist, dann kann es auch sein dass Dein FTP Startscript nicht im bootprozess registriert ist.
 

Werbung