pure-ftp Authentication failed for user

#1
Hallo, seit einem Update von ISPConfig funktioniert kein FTP User mehr, auch bei einer neue Domain und da einen neuen FTP User anlege... es klappt kein Verbindungsaufbau... egal ob die Firewall aktiv ist oder nicht, Ports sind eingetragen (auch sämtliches aus dem Forum hier versucht, aber kein Erfolg...
ispconfig_update.sh wurde auch nochmal durchgeführt... kein Erfolg
Hat jemand eine Idee?
Danke schon mal :)
 
#6
im debug:
[DEBUG] Command [user] [meinFTPUser]
[DEBUG] Command [pass] [<*>]
[DEBUG] Command [user] [meinFTPUser]
[DEBUG] Command [pass] [<*>]
[DEBUG] Command [user] [meinFTPUser]
[DEBUG] Command [pass] [<*>]
[DEBUG] Command [user] [meinFTPUser]
[DEBUG] Command [pass] [<*>]
 

nowayback

Well-Known Member
#7
pureftpd.log oder proftpd.log... [WARNING] Authentication failed for user [meinFTPUser] sagt aber einfach das irgendwie benutzername und pw nicht zusammen passen
 
#8
ich seh kein pureftpd.log, im /var/log/pure-ftpd/ sind nur transfer.log enthalten..
und ftpuser und pw wurden verschiedene neu angelegt, und mit copy paste ins ftp programm übertragen auch per hand eingetragen, da schliesse ich einen schreibfehler mal aus :(
 

nowayback

Well-Known Member
#12
ich weiß, sollte man in produktivsystemen nicht tun, aber verwende mal nen pw ohne sonderzeichen.

sonst bleibt eigentlich nicht mehr viel... loglevel höher drehen oder sql query debuggen
 
#13
das hatt ich ebenfalls schon versucht ...vergebens :(
eigentlich bin ich ja gar nicht so blöde, aber momentan steh ich vor einer Wand und find den Weg nicht drüber ...
 

Till

Administrator
#14
Schau mal ob Du pure-ftpd-mysql gestartet hast wenn es ein Debian / Ubuntu System is und nicht nur pure-ftpd. Denn das 2. wär die Variante ohne mysql support. Und schau mal ob es nicht zufällig einen Linux user in /etc/passwd mit dem selben Usernamen gibt, nichtdass da versucht wird sich gegen /etc/shadow zu authentifizieren anstatt gegen die MySQL Datenbank.
 
#15
es ist ein Debian 9.4
hmm, pure-ftpd-mysql:
service pure-ftpd-mysql status
● pure-ftpd-mysql.service
Loaded: loaded (/etc/init.d/pure-ftpd-mysql; generated; vendor preset: enabled)
Active: active (running) since Thu 2018-05-10 10:35:52 CEST; 2h 54min ago
Docs: man:systemd-sysv-generator(8)
Process: 6634 ExecStop=/etc/init.d/pure-ftpd-mysql stop (code=exited, status=0/SUCCESS)
Process: 6648 ExecStart=/etc/init.d/pure-ftpd-mysql start (code=exited, status=0/SUCCESS)
Tasks: 1 (limit: 4915)
CGroup: /system.slice/pure-ftpd-mysql.service
└─6660 pure-ftpd (SERVER)


Bzgl. User, nein die ftp user haben ja den Präfix vorne, den gibt es als Debian User nicht, habs sicherheitshalber auch kontrolliert...
 

Till

Administrator
#16
Nimm mal die mysql zugangsdaten und den mysql server namen aus /etc/pure-ftpd/db/mysql.conf und versuche dich damit mit dem mysql Befejl anzumelden an mysql:

mysql -h 127.0.0.1 -u ispconfig -p
 
#17
das klappt:
mysql -h 127.0.0.1 -u ispconfig -p
Enter password:
Welcome to the MariaDB monitor. Commands end with ; or \g.
Your MariaDB connection id is 23417
Server version: 10.0.30-MariaDB-0+deb8u2 (Debian)

Copyright (c) 2000, 2016, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]>
 

Werbung

Top