Pure-FTPd Server Offline

Dieses Thema im Forum "Server Administration" wurde erstellt von wasdim, 13. Mai 2015.

  1. wasdim

    wasdim Member

    Der Server wurde mit dieser Anleitung Installiert: The Perfect Server - Ubuntu 14.04 (Apache2, PHP, MySQL, PureFTPD, BIND, Dovecot, ISPConfig 3)
    Hier ist der Link wo der FTP zum Einsatz kommt: https://www.howtoforge.com/perfect-...hp-mysql-pureftpd-bind-dovecot-ispconfig-3-p5
    apt-get install pure-ftpd-common pure-ftpd-mysql quota quotatool
    Folgende Nachricht beim Versuch restart:
    Starting ftp server: /usr/sbin/pure-ftpd-wrapper: Invalid configuration file / etc/pure-ftpd/conf/passivePortRange: No corresponding directive
    root@server1:~# ps aux | grep ftp
    root 31039 0.0 0.0 4692 824 pts/0 S+ 15:50 0:00 grep --color=auto ftp
    root@server1:~# netstat -tap | grep ftp
    root@server1:~#

    root@server1:~# cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=14.04
    DISTRIB_CODENAME=trusty
    DISTRIB_DESCRIPTION="Ubuntu 14.04.2 LTS"
    root@server1:~# uname -a
    Linux server1.xxxxx.ch 3.13.0-52-generic #86-Ubuntu SMP Mon May 4 04:32:15 UTC 2 015 i686 i686 i686 GNU/Linux
     
  2. wotan2005

    wotan2005 Member

    und wieso machst du dafür jetzt ein zweiten Thread auf?
     
  3. wasdim

    wasdim Member

    Aus meiner Sicht hat das eine mit dem andern nichts zutun.
    Oder sehe ich das jetzt auch noch falsch?
     
  4. wotan2005

    wotan2005 Member

    dein anderer Thread geht doch genau um das selbe Problem, das dein FTP-Server nicht geht und Offline ist, oder habe ich da jetzt was falsch gelesen?
     
  5. wasdim

    wasdim Member

    Nein das erste Problem ist in Verbindung mit dem FileZila Client das kann ich nun nicht Testen, da mir der FTP-Server offline ging durch eine von mir falsche Manipulation am Server.
     
  6. gOOvER

    gOOvER Member

    Das ist das selbe Problem und ich denke hier wird Dir auch keiner helfen können. Auch wenn Du nen neuen Threadtitel nutzt ;) Und ausserdem ist es unhöflich, mehrere Threads zum gleichen Problem zu eröffnen. ;)

    Und der Fehler steht da eigentlich ;)

    Da sollte google definitiv was ausspucken ;)
     
  7. Till

    Till Administrator

    Versuch mal:

    Code:
    mv /etc/pure-ftpd/conf/passivePortRange /etc/pure-ftpd/conf/PassivePortRange
    und starte dann pure-ftpd neu. Die unter Debian und Ubuntu verfügbaren Optionen kann man hier leicht nachlesen: /usr/sbin/pure-ftpd-wrapper
     
    Zuletzt bearbeitet: 13. Mai 2015
  8. wasdim

    wasdim Member

    root@server1:~# mv /etc/pure-ftpd/conf/passivePortRange / etc/pure-ftpd/conf/PassivePortRange
    mv: das angegebene Ziel »etc/pure-ftpd/conf/PassivePortRange“ ist kein Verzeichnis
    root@server1:~#
     
  9. Till

    Till Administrator

    Das Forum hat da ein wenig den pfad zerhackt (leerzeichen). Versuch es nochmal mit dem code den ich jetzt oben eingefügt habe.
     
  10. wasdim

    wasdim Member

    Vorerst Danke Till und auch an das Forum
     
    Zuletzt bearbeitet: 13. Mai 2015

Diese Seite empfehlen