Quota Benachrichtigung zeigt falschen User

#1
Ich habe als Admin eine Benachrichtigung bekommen,
Code:
Username:                           web11_king
Used Storage Space:           87.13 MB
Allocated Storage Space:     1.00 MB
User's Real Name:               King
User's Email Address:           [EMAIL="king@daucity.de"]king@dn.de[/EMAIL]
Web Site:                             [URL="http://www.daucity.de/"]www.dn.de[/URL]
Group Of Web Site:             web11

[...]
Customer's Web Site:           [URL]http://zockertown.de/s9y/[/URL]

This customer does not belong to a reseller.
Ok, 1MB stimmt, aber der User (Mein Hund) ist nur eine Weiterleitung, nur ca. 180 K
Die Angabe 87 MB entspricht dem gesamt Verbrauch aller w11 email user.
Alle anderen haben 5GB space oder 1 MB eingestellt.
King ist der zweite imn der Usier_id Reihenfolge.
Wie kommt es, das ispconfig meint, King würde die Quota überschreiten?

Keine Error Meldungen in /home/admispconfig/ispconfig/ispconfig.log

Nur WARN wegen fehlerhaften anon ftp geschichten, aber das ist ein andere Thema :)
 
Zuletzt bearbeitet:
#3
Nein, bei gar keinen.
Das ist eine email domain, zwar mit webspace, aber ungenutzt.
Mittlerweile hatte ich auch noch den selben Text für eine weitere weiterleitungsadresse bekommen...

Ich setze jetzt mal bei meiner email adressen den Haken.
 
#6
Code:
 repquota -avug | grep web11_king
*** Report for group quotas on device /dev/md3
Block grace time: 7days; Inode grace time: 7days
                        Block limits                File limits
Group            used    soft    hard     grace    used   soft  hard  grace

web11_king +-   89220    1024    2048  4days   11289     0     0
 
#8
Dem Output nach ist das Quota des Users voll, also ist die Benachrichtigung korrekt und die Werte stimmen auch.
Ich kann dir soweit folgen, das es ein Quota Problem ist und nichts mit ISPConfig an sich zu tun hat.
Wahrscheinlich muss ich mich eingehender mit Quota und den Tools beschäftigen. Denn das ist definitiv eine falsche Aussage von Quota. Das Verzeichnis ist praktisch leer. Vielleicht hat es was mit user/group zu tun.
Allerdings sind die User korrekt angelegt worden.
Wenn ich die Lösung habe gebe ich Feedback.

Danke für deine Unterstützung.
 

Till

Administrator
#9
Quota bezieht sich auf alle Dateien die dem User gehören und nicht nur auf ein bestimmtes Verzeichnis. Schau z.B. mal in /var/spool/mail/ und /tmp nach.
 
#10
Eigentlich bezieht sich quota auch nur auf ein Filesystem. Bei mir also /dev/md3
Ich habe quotacheck /dev/md3, das selbe Ergebnis.
in /var/spool/mail sind nur 0 Byte grosse Dateien für die beiden betroffenen User
in /tmp auch nichts.

Wenn man da nicht die verältnismässig grosse Partition von 350 Gig eine Rolle spielt... Also es ist auf jeden Fall ein Bug ausserhalb von ISPConfig.
Ich werde noch ein wenig stöbern
 

Till

Administrator
#11
Mit dem find Befehl kannst Du auch nach Dateien suchen, die einem bestimmten User gehören. Such doch mal admit, woe die Dteien liegen. Habe die richtige Option gerade nicht parat, im Zweifelsfall mal mit "man find" nachsehen.
 
#12
Ich sage doch, web11_king ist nur ein Email User, da ist nichts, aber wirklich nichts auf dem Rechner außer der Struktur unter User im web11. (und den 0Byte in /var/spool/Mail)

Die Gesamtusage ist ja korrekt, nur einzelne user werden völlig falsch bewertet.
Schon sehr merkwürdig. die Userid ist eindeutig, offenbar ist mit der Group was faul. Ich werde mir mal ein eigenes Filesystem aufbauen und das detailliert untersuchen, irgendwo dran liegen wird es schon, aber eben nicht so offensichtlich.
 
#13
Grosser Meister Till::eek:

Du hast ja so recht.
Ich bin inzwischen zuhause und habe trotz besseres Wissens GottSeiDank den find abgesetzt.
Code:
 nice find / -user web11_king>/tmp/web11_king.txt
Siehe da: ...:eek:
Ich bin ja vor kurzem von eimem vserver auf einem richtigen rootserver umgezogen. Um nicht in Schwierigkeiten zu kommen, hatte ich die alten Sachen auf den neuen Server in einem Unterzeichnis kopiert und im selben Filesystem abgelegt.
Wie es so der Zufall will, gab es da zwar nicht die selben user, wohl aber die selben uid. Und da ich das als root ausgepackt hatte, waren nun dummerweise ein paar uid identisch mit dem neuen Server.
Ein chown -R root /pfad/zu/alten/dateien und der Spuk war vorüber.
ps: kann ich den Thread als gelöst markieren?
 
Zuletzt bearbeitet:

Werbung