Quota für Uploads über WordPress

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von hebbet, 1. Apr. 2016.

  1. hebbet

    hebbet New Member

    Hallo,
    ich habe ISPConfig gemäß der Anleitung "The Perfect Server - Debian 8 Jessie (Apache2, BIND, Dovecot, ISPConfig 3)" eingerichtet. Soweit läuft auch alles, wie es soll.
    Ich habe einem Auftritt ein Quota von 500MB gegeben. ISP listet eine Nutzung von 80MB an. Im /var/www/domainname.de/web liegen aber deutlich mehr als 80MB, nämlich 200MB.

    Scheinbar werden Uploads über WordPress nicht richtig ins Quota berechnet.
    Zum Testen habe ich eine 10MB Datei über FTP hochgeladen. Danach zeigt mir IPS nach einigen Minuten 90MB, lade ich eine andere 10MB große Datei über WordPress hoch, so sind auch nach Stunden noch nur 90MB in der Liste "Webseiten-Festplattenbeschränkung" aufgeführt.

    Gibt es eine Möglichkeit, dass auch uploads aus WOrdpress zum Quota zählen und Uploads ggf. abgelehnt werden, wenn der Platz voll ist?

    hebbet
     
  2. nowayback

    nowayback Well-Known Member

    evtl. falsche berechtigungen nach dem upload?

    also die hochgeladene datei gehört nicht webx:cy?
     
  3. Till

    Till Administrator

    1) Hast Du den richtigen PHP Modus eingestellt in der Webseite? Der sollte php-fcgi oder php-fpm sein.
    2) Ist die Checkbox "suexec" in der webseite aktiv?

    Wenn 1 oder 2 nicht stimmen, dann erfolgt der Upload unter einem falschen user www-data und kann daher nicht im Quota auftauchen.
     
  4. hebbet

    hebbet New Member

    ich nutz mod_php im apache. geht das damit auch?
     
  5. Till

    Till Administrator

    Nein, und mod_php sollte auch aus Sicherheitsgründen nicht mehr verwendet werden. Denn wenn Du mod_php verwendest dann hat ein Kunde oder Hacker der zugriff auf eine beliebige Website Deines servers hat auch zugriff auf alle anderen websites Deine servers haben da sie alle unter dem selben User laufen und website quotas kann es dann natürlich auch nicht geben, also sehr unsicher wie Du siehst.
     
  6. hebbet

    hebbet New Member

    Danke für die Antworten. Werde ich im laufe der nächsten Tage ausprobieren und mich ggf. dann erneut melden.

    hebbet
     
  7. Till

    Till Administrator

    Und denk bitte daran dass Du per chown alle Dateien im web verzeichnis auf den web user und die client Gruppe des webs ändern musst, denn Durch die vorherige Verwendung von mod_php haben hochgeladene media Dateien jetzt einen falschen Owner.
     

Diese Seite empfehlen