quota Software Raid

#1
Schönen Guten Tag,

ich bin nach dem Tutorial gegangen:
HowtoForge Linux Tutorials » Der Perfekte Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3)

Leider steht bei mir unter: /etc/fstab nur
proc /proc proc defaults 0 0
none /dev/pts devpts gid=5,mode=620 0 0
/dev/md0 none swap sw 0 0
/dev/md1 /boot ext3 defaults 0 0
/dev/md2 / ext4 defaults 0 0

leider habe ich nichts gefunden wie ich dieses einbinden kann jetzt.

Habe den EX5 von Hetzner mit Software Raid1

Bitte um hilfe bin schon ewig dran.

MFG
 
#3
Damit habe ich bis jetzt noch nichts mit gemacht. Wie mache ich das genau ?
proc /proc proc defaults 0 0
none /dev/pts devpts gid=5,mode=620 0 0
/dev/md0 none swap sw 0 0
/dev/md1 /boot ext3 defaults 0 0
/dev/md2 / ext4 defaults 0 0

Das steht bei mir drin aber was muss ich jetzt ändern ?
Bitte um verständniss habe damit noch nicht wirklich gearbeitet, weil ich das noch nie gebraucht habe bis jetzt...
 
Zuletzt bearbeitet:

Till

Administrator
#4
Code:
proc /proc proc defaults 0 0
none /dev/pts devpts gid=5,mode=620 0 0
/dev/md0 none swap sw 0 0
/dev/md1 /boot ext3 defaults 0 0
/dev/md2 / ext4 defaults,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 0
 
#5
Danke dir !!
Leider Spuckt er mir jetzt folgenden fehler aus

habe folgenden befehl verwendet: mount -o remount /
Bekam darauf die fehlermeldung:
[mntent]: warning: no final newline at the end of /etc/fstab
[mntent]: line 5 in /etc/fstab is bad
 

Till

Administrator
#6
Überprüf nochmal die Zeile, nicht dass dort irgenwo leerzeichen drin sind die da nicht hingehören. Habe sie nochmal im code formatierung einefügt. Außerdem muss die Datei mit einer Leerzeile enden.
 
#9
Diesmal kam ich zu folgenden fehlermeldungen :/

root@srv ~ # vi /etc/fstab
root@srv ~ # mount -o remount /
root@srv ~ # quotacheck -avugm
quotacheck: Scanning /dev/disk/by-uuid/9b0806ce-21c3-416e-a39e-b3271ebb4403 [/] done
quotacheck: Cannot stat old user quota file //quota.user: No such file or directory. Usage will not be substracted.
quotacheck: Cannot stat old group quota file //quota.group: No such file or directory. Usage will not be substracted.
quotacheck: Cannot stat old user quota file //quota.user: No such file or directory. Usage will not be substracted.
quotacheck: Cannot stat old group quota file //quota.group: No such file or directory. Usage will not be substracted.
quotacheck: Checked 8061 directories and 59509 files
quotacheck: Old file not found.
quotacheck: Old file not found.
root@srv ~ # quotaon -avug
/dev/disk/by-uuid/9b0806ce-21c3-416e-a39e-b3271ebb4403 [/]: group quotas turned on
/dev/disk/by-uuid/9b0806ce-21c3-416e-a39e-b3271ebb4403 [/]: user quotas turned on
root@srv ~ #

bezieht sich das nur auf alte files ? Die bei mir ja nicht existieren können weil ich vorher kein quata drauf hatte?
so langsam verzweifel ich.
 
#11
root@srv ~ # quotacheck -avugm
quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file.
Please turn quotas off or use -f to force checking.
 
#13
Schönen Guten Tag,

leider konnte ich mich jetzt erst melden um ein Doppelpost zu vermeiden. Mein Root hatte ein Kernel Panic der noch aus unerklärlichen gründen entstanden ist. Hetzner hat bereits ein Hardware Check durchgeführt der keine Fehler zeigte, jetzt heist es logs analysieren. Blos ich habe glaube ich einen kleinen denk fehler um auf die ISPConfig installation zurück zukommen.
Wie im Tutorial beschrieben führe ich mount -o remount / aus danach quotacheck -avugm aber dort wird mir dann das angezeigt
root@srv ~ # quotacheck -avugm
quotacheck: Scanning /dev/disk/by-uuid/07e60f9f-35ac-4990-a79f-cd84b81d702b [/] done
quotacheck: Cannot stat old user quota file //quota.user: No such file or directory. Usage will not be substracted.
quotacheck: Cannot stat old group quota file //quota.group: No such file or directory. Usage will not be substracted.
quotacheck: Cannot stat old user quota file //quota.user: No such file or directory. Usage will not be substracted.
quotacheck: Cannot stat old group quota file //quota.group: No such file or directory. Usage will not be substracted.
quotacheck: Checked 8060 directories and 59525 files
quotacheck: Old file not found.
quotacheck: Old file not found.
aber nachdem ich dann es anschalte mit quotaon -avug erhalte ich folgende meldung.
/dev/disk/by-uuid/07e60f9f-35ac-4990-a79f-cd84b81d702b [/]: group quotas turned on
/dev/disk/by-uuid/07e60f9f-35ac-4990-a79f-cd84b81d702b [/]: user quotas turned on
Ich kann es irgendwie nicht verfolgen warum ich erst eine fehlermeldung erhalte aber danach es angeschaltet wird ? Ist es so Korrekt oder ist dort echt der Fehlerteufel drin ? Ich denke es sind halt altdaten die gesucht werden ?
 

Till

Administrator
#14
Das ist korrekt. Denn der quotacheck Befehl hat ja nur festgestellt dass es keine alten quota dateien gubt und ers deswegen neue anlegt. da quota vorher ja naicht aktib war, sin diese Meldungen also richtig.
 
#15
Hallo, habe mir jetzt noch ein Root bestellt. Ist das richtig ?

PHP:
proc /proc proc defaults 0 0
/dev/md/0 none swap sw 0 0
/dev/md/1 /boot ext3 defaults 0 0
/dev/md2 / ext4 defaults,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 0
/dev/md/3 /home ext4 defaults 0 0
bei dem anderen war es ja auch auf md2 ?
Orginal sieht die datei so aus:

PHP:
proc /proc proc defaults 0 0
/dev/md/0 none swap sw 0 0
/dev/md/1 /boot ext3 defaults 0 0
/dev/md/2 / ext4 defaults 0 0
/dev/md/3 /home ext4 defaults 0 0
 

Till

Administrator
#16
Die Partitionierung bzw. Mountpoints sind möglicherweise nicht optimal, da /home wahrscheinlich die größte Partition ist, diese wird aber nicht von ispconfig verwendet. Poste bitte mal die Ausgabe von:

df -h
 
#17
Hier die Ausgabe:
Filesystem Size Used Avail Use% Mounted on
/dev/md2 1016G 1.1G 964G 1% /
udev 7.8G 4.0K 7.8G 1% /dev
tmpfs 3.2G 292K 3.2G 1% /run
none 5.0M 0 5.0M 0% /run/lock
cgroup 7.8G 0 7.8G 0% /sys/fs/cgroup
none 7.8G 0 7.8G 0% /run/shm
/dev/md1 496M 38M 433M 9% /boot
/dev/md3 1.8T 196M 1.7T 1% /home
Also sollte ich das auf home legen ?
Oder was ist jetzt am besten ?
 
Zuletzt bearbeitet:

Till

Administrator
#18
/home ist die größte Partition wie ich vermutet hatte, man sollte diese also als Speicherplatz für die Daten verwenden. Es gibt mehrer Möglichkeiten:

1) Du hast hauptsächlich Daten in den Webseiten, dann mounte /dev/md3 als /var/www und aktivieren Quota für /var/www

2) Du hast auptsächlich email Daten, dann Mounte /dev/md3 als /var/vmail und aktiviere Quota für /

3) Du hast sowohl viel email als auch web daten, dann gibt es 2 Möglichkeiten:

a) Betriebssysten neu installieren und /var als größte Partition erstellen da sich das Schema so im laufenden betrieb schlecht ändern lässt.

b) Du mountest /dev/md3 als /data und erstellst dann in der fstab 2 bind mounts und zwar /var/www auf /data/www und /var/vmail auf /data/vmail und legst dann quota auf /data
 

Werbung