recv() failed (104: Connection reset by peer)

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von bobbybackblech, 2. Okt. 2014.

  1. Ich habe jetzt gerade noch einmal meinen Shopware Shop auf den Server gespielt.
    Wenn ich nun einen Artikel aufrufen möchte bekomme ich einen 500er Error.
    Im Server Log habe ich nun wieder folgendes stehen:

    Code:
     [error] 10008#0: *41417 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 37.24.153.18, server: domain.de, request: "GET /artikelurl HTTP/1.1", upstream: "fastcgi://unix:/var/lib/php5-fpm/web14.sock:", host: "domain.de", referrer: "domain.de/artikel"
    Google spukkt mir dazu nichts aus, was kann denn hier der Fehler sein ?
    Kann es an den php-fpm Einstellungen liegen ?
     
  2. nowayback

    nowayback Well-Known Member

    das sagt dir, das fast-cgi nicht rechtzeitig geantwortet hat.

    kann verschiedene ursachen haben, aber ich würde mal hiermit anfangen:
    Code:
    fastcgi_read_timeout 300;
    fastcgi_send_timeout 300;
     
  3. Das dann einfach mit in die nginx Direktiven mit rein ?
     
  4. nowayback

    nowayback Well-Known Member

    normal in die nginx.conf
     
  5. Das hat leider nichts gebracht :(
    Allerdings bekomme ich es nur bei einer Artikel Ansicht.

    Startseite, Kategorien usw. funktionieren, sobald man auf einen Artikel klickt kommt direkt der 500er

    Was könnte es noch für eine Ursache haben ?
     
    Zuletzt bearbeitet: 2. Okt. 2014
  6. nowayback

    nowayback Well-Known Member

    poste mal deine entsprechenden configs. dann guck ich mal drüber, denn sonst wird alles weitere rätselraten. Du kannst auch nginx im debugmodus laufen lassen um mehr infos zu erhalten. Dazu im vhost hinter error_log /pfad/zum/log debug angeben. Nicht vergessen, das wieder zu ändern, sonst platzen die logfiles aus allen nähten
     
  7. Okay :)
    Kann ich die vhosts einfach so manuell editieren, ohne das ISPC da in die rumzickt ?
    Da die vhosts ja entsprechend ISPC anlegt und editiert.

    Das ist meine nginx.conf
    Code:
    cat nginx.conf
    user www-data;
    worker_processes 4;
    pid /run/nginx.pid;
    
    events {
        worker_connections 768;
        # multi_accept on;
    }
    
    http {
    
        ##
        # Basic Settings
        ##
    
        sendfile on;
        tcp_nopush on;
        tcp_nodelay on;
        keepalive_timeout 65;
        types_hash_max_size 2048;
        server_tokens off;
    
        # server_names_hash_bucket_size 64;
        # server_name_in_redirect off;
    
        include /etc/nginx/mime.types;
        default_type application/octet-stream;
    
        ##
        # Logging Settings
        ##
    
        access_log /var/log/nginx/access.log;
        error_log /var/log/nginx/error.log;
    
    fastcgi_buffers 32 32k;
    fastcgi_buffer_size 32k;
    fastcgi_read_timeout 300;
    fastcgi_send_timeout 300;
    ##
    #ngx_pagespeed module settings
    ##
    
    pagespeed on;
    pagespeed XHeaderValue "";
    pagespeed FileCachePath /var/ngx_pagespeed_cache;
    
        ##
        # Gzip Settings
        ##
    
        gzip on;
        gzip_disable "msie6";
    
         gzip_vary on;
         gzip_proxied any;
         gzip_comp_level 6;
         gzip_buffers 16 8k;
         gzip_http_version 1.1;
         gzip_types       text/plain application/xml text/css text/js text/xml application/javascript application/x-javascript text/javascript application/json application/xml+rss;
    
        ##
        # nginx-naxsi config
        ##
        # Uncomment it if you installed nginx-naxsi
        ##
    
        #include /etc/nginx/naxsi_core.rules;
    
        ##
        # nginx-passenger config
        ##
        # Uncomment it if you installed nginx-passenger
        ##
      
        #passenger_root /usr;
        #passenger_ruby /usr/bin/ruby;
    
        ##
        # Virtual Host Configs
        ##
    
        include /etc/nginx/conf.d/*.conf;
        include /etc/nginx/sites-enabled/*;
    }
    
    
    #mail {
    #    # See sample authentication script at:
    #    # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
    #
    #    # auth_http localhost/auth.php;
    #    # pop3_capabilities "TOP" "USER";
    #    # imap_capabilities "IMAP4rev1" "UIDPLUS";
    #
    #    server {
    #        listen     localhost:110;
    #        protocol   pop3;
    #        proxy      on;
    #    }
    #
    #    server {
    #        listen     localhost:143;
    #        protocol   imap;
    #        proxy      on;
    #    }
    #}
    
    Und das meine Direktiven in ISPC

    Code:
    client_max_body_size 100M;
    
    location ~ /(engine|images/[a-z]+|files|templates)/ {
    }
    
    location / {
             index index.html index.php shopware.php;
             rewrite shopware.dll /shopware.php;
             rewrite files/documents/.* /engine last;
             rewrite images/ayww/(.*) /images/banner/$1 last;
             rewrite backend/media/(.*) /media/$1 last;
             if (!-e $request_filename){
                rewrite . /shopware.php last;
             }
    }
    
    location ~ \.(tpl|yml|ini)$ {
             deny all;
    }
    
    location /install/ {
             location /install/assets {
             }
             if (!-e $request_filename){
                rewrite . /install/index.php last;
             }
    }
    
    location /update/ {
             location /update/assets {
             }
             location /update/templates {
             }
             if (!-e $request_filename){
                 rewrite . /update/index.php last;
             }
    }
    
    location /recovery/install/ {
             location /recovery/install/assets {
             }
             if (!-e $request_filename){
                rewrite . /recovery/install/index.php last;
             }
    }
    
    location /recovery/update/ {
             location /recovery/update/assets {
             }
             if (!-e $request_filename){
                rewrite . /recovery/update/index.php last;
             }
    }
    
    location @php { ##merge##
                #fastcgi_buffer_size 128k;
                #fastcgi_buffers 256 16k;
                #fastcgi_busy_buffers_size 256k;
                #fastcgi_temp_file_write_size 256k;
                fastcgi_temp_file_write_size 10m;
                fastcgi_busy_buffers_size    512k;
                fastcgi_buffer_size          512k;
                fastcgi_buffers           16 512k;
                fastcgi_read_timeout 1200;
    }
     
  8. nowayback

    nowayback Well-Known Member

    solange du nichts in der Website in ISPConfig änderst, ja. Wenn du dort was änderst werden wieder die eigentlichen Einstellungen geschrieben.
    Gerade zum debuggen kannst du aber den Eintrag auf debug ändern, nginx restarten und den Fehler reproduzieren. Danach kannst du es ja wieder zurück ändern, nginx restarten und fertig. ISPConfig schreibt den Vhost Eintrag nur neu bei Änderungen in ISPConfig.

    überschreibt den Wert aus der nginx.conf, ist aber nebensächlich.

    Funktioniert das? Als ich das vor einiger Zeit mal im server {} Block hatte, funktionierte es nicht. Da musste es explizit in den http {} Block in meinem Fall in der nginx.conf.

    Der Rest sieht gut aus und so sollte es auch funktionieren. Ich würde das wie gesagt mit client_max_body_size nochmal prüfen und wenn es dann nicht funktioniert anfangen zu debuggen (nginx und php-fpm)
     
  9. nowayback

    nowayback Well-Known Member

    zeig mir mal bitte noch die php-fpm konfiguration und das entsprechende debug log. Dein Problem scheint nicht bei nginx zu liegen.
     
  10. Danke schonmal im voraus tausend mal für die Hilfe an einem Feiertag :) :)

    Im log in /var/log/php5-fpm steht nichts drin.

    Code:
    cat /var/log/php5-fpm.log
    [03-Oct-2014 00:49:44] NOTICE: configuration file /etc/php5/fpm/php-fpm.conf test is successful
    Code:
     /etc/php5/fpm # cat php-fpm.conf
    ;;;;;;;;;;;;;;;;;;;;;
    ; FPM Configuration ;
    ;;;;;;;;;;;;;;;;;;;;;
    
    ; All relative paths in this configuration file are relative to PHP's install
    ; prefix (/usr). This prefix can be dynamically changed by using the
    ; '-p' argument from the command line.
    
    ; Include one or more files. If glob(3) exists, it is used to include a bunch of
    ; files from a glob(3) pattern. This directive can be used everywhere in the
    ; file.
    ; Relative path can also be used. They will be prefixed by:
    ;  - the global prefix if it's been set (-p argument)
    ;  - /usr otherwise
    ;include=/etc/php5/fpm/*.conf
    
    ;;;;;;;;;;;;;;;;;;
    ; Global Options ;
    ;;;;;;;;;;;;;;;;;;
    
    [global]
    ; Pid file
    ; Note: the default prefix is /var
    ; Default Value: none
    pid = /var/run/php5-fpm.pid
    
    ; Error log file
    ; If it's set to "syslog", log is sent to syslogd instead of being written
    ; in a local file.
    ; Note: the default prefix is /var
    ; Default Value: log/php-fpm.log
    error_log = /var/log/php5-fpm.log
    
    ; syslog_facility is used to specify what type of program is logging the
    ; message. This lets syslogd specify that messages from different facilities
    ; will be handled differently.
    ; See syslog(3) for possible values (ex daemon equiv LOG_DAEMON)
    ; Default Value: daemon
    ;syslog.facility = daemon
    
    ; syslog_ident is prepended to every message. If you have multiple FPM
    ; instances running on the same server, you can change the default value
    ; which must suit common needs.
    ; Default Value: php-fpm
    ;syslog.ident = php-fpm
    
    ; Log level
    ; Possible Values: alert, error, warning, notice, debug
    ; Default Value: notice
    ;log_level = notice
    
    ; If this number of child processes exit with SIGSEGV or SIGBUS within the time
    ; interval set by emergency_restart_interval then FPM will restart. A value
    ; of '0' means 'Off'.
    ; Default Value: 0
    ;emergency_restart_threshold = 0
    
    ; Interval of time used by emergency_restart_interval to determine when
    ; a graceful restart will be initiated.  This can be useful to work around
    ; accidental corruptions in an accelerator's shared memory.
    ; Available Units: s(econds), m(inutes), h(ours), or d(ays)
    ; Default Unit: seconds
    ; Default Value: 0
    ;emergency_restart_interval = 0
    
    ; Time limit for child processes to wait for a reaction on signals from master.
    ; Available units: s(econds), m(inutes), h(ours), or d(ays)
    ; Default Unit: seconds
    ; Default Value: 0
    ;process_control_timeout = 0
    
    ; The maximum number of processes FPM will fork. This has been design to control
    ; the global number of processes when using dynamic PM within a lot of pools.
    ; Use it with caution.
    ; Note: A value of 0 indicates no limit
    ; Default Value: 0
    ; process.max = 128
    
    ; Specify the nice(2) priority to apply to the master process (only if set)
    ; The value can vary from -19 (highest priority) to 20 (lower priority)
    ; Note: - It will only work if the FPM master process is launched as root
    ;       - The pool process will inherit the master process priority
    ;         unless it specified otherwise
    ; Default Value: no set
    ; process.priority = -19
    
    ; Send FPM to background. Set to 'no' to keep FPM in foreground for debugging.
    ; Default Value: yes
    ;daemonize = yes
    ; Set open file descriptor rlimit for the master process.
    ; Default Value: system defined value
    ;rlimit_files = 1024
    ; Set max core size rlimit for the master process.
    ; Possible Values: 'unlimited' or an integer greater or equal to 0
    ; Default Value: system defined value
    ;rlimit_core = 0
    
    ; Specify the event mechanism FPM will use. The following is available:
    ; - select     (any POSIX os)
    ; - poll       (any POSIX os)
    ; - epoll      (linux >= 2.5.44)
    ; - kqueue     (FreeBSD >= 4.1, OpenBSD >= 2.9, NetBSD >= 2.0)
    ; - /dev/poll  (Solaris >= 7)
    ; - port       (Solaris >= 10)
    ; Default Value: not set (auto detection)
    ;events.mechanism = epoll
    
    ; When FPM is build with systemd integration, specify the interval,
    ; in second, between health report notification to systemd.
    ; Set to 0 to disable.
    ; Available Units: s(econds), m(inutes), h(ours)
    ; Default Unit: seconds
    ; Default value: 10
    ;systemd_interval = 10
    
    ;;;;;;;;;;;;;;;;;;;;
    ; Pool Definitions ;
    ;;;;;;;;;;;;;;;;;;;;
    
    ; Multiple pools of child processes may be started with different listening
    ; ports and different management options.  The name of the pool will be
    ; used in logs and stats. There is no limitation on the number of pools which
    ; FPM can handle. Your system will tell you anyway :)
    
    ; To configure the pools it is recommended to have one .conf file per
    ; pool in the following directory:
    include=/etc/php5/fpm/pool.d/*.conf
    Und die www.conf ist hier -> http://pastebin.com/JDiKcJ4y
     
  11. nowayback

    nowayback Well-Known Member

    Kein Thema... Muss eh noch bis 2 Uhr arbeiten und Donnerstags is eh meistens Ruhe und Zeit für Onlinepoker :)

    ISPConfig erstellt eigene Configs für die einzelnen Webs... such mal hier:
    /etc/php5/fpm/pool.d/webxxxx.conf

    wenn nicht bereits drin, füge mal folgende Werte mit ein:
    Code:
    php_admin_value[max_execution_time] = 1200
    php_admin_value[max_input_time] = 1200
    danach /etc/init.d/php-fpm restart nicht vergessen
     
  12. Meine Augen fallen schon fast zu aber ich muss das zum laufen bekommen :)

    Stand nicht drin behebt aber auch nicht den Fehler :(

    Code:
    /etc/php5/fpm/pool.d # cat web14.conf
    [web14]
    
    listen = /var/lib/php5-fpm/web14.sock
    listen.owner = web14
    listen.group = client4
    listen.mode = 0660
    
    user = web14
    group = client4
    
    pm = dynamic
    pm.max_children = 10
    pm.start_servers = 2
    pm.min_spare_servers = 1
    pm.max_spare_servers = 5
    pm.max_requests = 0
    
    php_admin_value[max_execution_time] = 1200
    php_admin_value[max_input_time] = 1200
    chdir = /
    
    php_admin_value[open_basedir] = /var/www/clients/client4/web14/web:/var/www/clients/client4/web14/private:/var/www/clients/client4/web14/tmp:/var/www/domain.de/web:/srv/www/domain.de/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin
    php_admin_value[session.save_path] = /var/www/clients/client4/web14/tmp
    php_admin_value[upload_tmp_dir] = /var/www/clients/client4/web14/tmp
    php_admin_value[sendmail_path] = "/usr/sbin/sendmail -t -i -fwebmaster@domain.de"
    
     
  13. nowayback

    nowayback Well-Known Member

    fehlt immernoch das debug logfile von php-fpm :)

    Tipp: ersetze ;log_level = notice durch log_level = debug (Semikolon entfernen nicht vergessen) in php-fpm.conf und restarten

    Wieviel RAM hat die Kiste?
     
  14. Habs mal auf debug gesetzt
    cat /var/log/php5-fpm.log zeigt aber trotzdem noch keinen Fehler ..
    32 GB RAM hat der Server, daran sollte es nicht liegen :)
     
  15. nowayback

    nowayback Well-Known Member

    sehr seltsam...

    Schuss ins Blaue:
    web14.conf:
    php_admin_value[memory_limit] = 768M

    Sollte das nicht helfen dann mal bitte die vollständige Konfiguration von der Website (/etc/nginx/sites-enabled/100-domain.vhost)
    Domains, IPs etc. darfst du natürlich zensieren ;-)
     
  16. Der blaue schuss war leider daneben :p
    Die 100 vhost sieht so aus:

    Code:
    server {
            listen *:80;
    
    
            server_name domain.de www.domain.de;
    
            root   /var/www/domain.de/web;
    
    
    
            index index.html index.htm index.php index.cgi index.pl index.xhtml;
    
    
    
            error_log /var/log/ispconfig/httpd/domain.de/error.log debug;
            access_log /var/log/ispconfig/httpd/domain.de/access.log combined;
    
            location ~ /\. {
                deny all;
                access_log off;
                log_not_found off;
            }
    
            location = /favicon.ico {
                log_not_found off;
                access_log off;
            }
    
            location = /robots.txt {
                allow all;
                log_not_found off;
                access_log off;
            }
    
            location /stats/ {
    
                index index.html index.php;
                auth_basic "Members Only";
                auth_basic_user_file /var/www/clients/client4/web14/web/stats/.htpasswd_stats;
            }
    
            location ^~ /awstats-icon {
                alias /usr/share/awstats/icon;
            }
    
            location ~ \.php$ {
                try_files /b7acf85e51bea04bf1c65a2742797727.htm @php;
            }
    
            location @php {
                try_files $uri =404;
                include /etc/nginx/fastcgi_params;
                fastcgi_pass unix:/var/lib/php5-fpm/web14.sock;
                fastcgi_index index.php;
                fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                fastcgi_intercept_errors on;
                        fastcgi_temp_file_write_size 10m;
                        fastcgi_busy_buffers_size    512k;
                        fastcgi_buffer_size          512k;
                        fastcgi_buffers           16 512k;
                        fastcgi_read_timeout 1200;
            }
    
    
    
    
            client_max_body_size 100M;
    
            location ~ /(engine|images/[a-z]+|files|templates)/ {
            }
    
            location / {
                     index index.html index.php shopware.php;
                     rewrite shopware.dll /shopware.php;
                     rewrite files/documents/.* /engine last;
                     rewrite images/ayww/(.*) /images/banner/$1 last;
                     rewrite backend/media/(.*) /media/$1 last;
                     if (!-e $request_filename){
                        rewrite . /shopware.php last;
                     }
            }
    
            location ~ \.(tpl|yml|ini)$ {
                     deny all;
            }
    
            location /install/ {
                     location /install/assets {
                     }
                     if (!-e $request_filename){
                        rewrite . /install/index.php last;
                     }
            }
    
            location /update/ {
                     location /update/assets {
                     }
                     location /update/templates {
                     }
                     if (!-e $request_filename){
                         rewrite . /update/index.php last;
                     }
            }
    
            location /recovery/install/ {
                     location /recovery/install/assets {
                     }
                     if (!-e $request_filename){
                        rewrite . /recovery/install/index.php last;
                     }
            }
    
            location /recovery/update/ {
                     location /recovery/update/assets {
                     }
                     if (!-e $request_filename){
                        rewrite . /recovery/update/index.php last;
                     }
            }
    
    
    
    }
    
     
  17. nowayback

    nowayback Well-Known Member

    Da du ja den Wert aus der nginx.conf überschreibst:

    web14.conf:
    request_terminate_timeout = 1200s;

    nutzt du irgendwelche caching maßnahmen (apc, opcache, etc.) ?
    und du hast keine einträge weiterhin in der php-fpm.log ?
    Hast du nginx und php-fpm neugestartet?
     
  18. An einem request timeout wirds nicht liegen, der error kommt sofort und unter einer Sekunde - also direkt sofort kommt der :)
    nginx und fpm sind restartet jop.
    In der cat /var/log/php5-fpm.log sind keine weiteren Einträge nein :(
     
  19. nowayback

    nowayback Well-Known Member

    Langsam aber sicher bin ich auch am Ende meines Lateins...
    schreib mal in die web14.conf
    Code:
    catch_workers_output = yes
    und restarte php-fpm... dann reproduziere mal den Fehler und schau danach in die /var/log/php-fpm.log
     

Diese Seite empfehlen