Redirect von Aliasdomain auf Webseite, Alias soll als URL erhalten bleiben

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von st2xo, 2. Aug. 2012.

  1. st2xo

    st2xo Member

    kann mir jemand einen Tipp geben für folgendes Problem:

    ganz frische ISPConfig Installation mit zwei Webseiten:
    - domainA.de
    - domainB.de

    Konfiguriert sind die beiden Websieten mit IP-Adressen *, Auto-Subdomain www, ansonsten alles default.
    Die NS-Einträge für diese beiden Domains verweisen noch auf einen anderen Server.

    Daher habe ich einen Alias eingerichtet für
    - www2.DomainA.de
    - www2.DomainB.de
    (NS für die www2 mit IP auf diesen Server existiert natürlich)

    Rufe ich nun www2.DomainB.de auf, erscheint www2.DomainA.de
    Ist ja auch soweit korrekt wegen:
    /etc/apache2/sites-enabled/100-domaina.de.vhost
    /etc/apache2/sites-enabled/100-domainb.de.vhost

    Egal wie ich nun mit dem Redirects im Domainalias herumspiele, ich schaffe es nicht, domainB.de aufzurufen - und diese auch in der Adressleiste zu belassen (denn auf dieser Maschine gibts ja nur den NS für www2.domainB.de)

    Auch habe ich * in der Webseite-Konfig gewählt, die IP wird mir nicht angezeigt, obwohl diese bei
    - /System/Serverkonfiguration/[hostname] aufgeführt ist
    Checkbox Netzwerkkonfiguration nicht markiert. OpenSUSE-System.
    - bei "IP Adressen" hab ich einen Eintrag auf den Client von DomainB.de mit der IP-Adresse in dem Textfeld, vhost=Yes, Ports=80,443

    Vor Anlegen der DomainA.de konnte ich www2.DomainB.de wie erwartet aufrufen (es gab ja die DomainA.de noch nicht in der Apache-vHost-Reihenfolge).
    Insofern ist alles ok - ich bekomme einfach diesen Alias nicht hin.
    Hat jemand nen Tipp? Vielen Dank!!!
     
  2. Till

    Till Administrator

    Die IP Adresse wird Dir nicht angezeigt da Du sie nicht angelegt hast. Füge die IP unter System > Server IP hinzu und wähle sie dann ind en Webseiteneinstellungen aus.
     
  3. st2xo

    st2xo Member

    Es geht, Till, ich danke Dir!

    Grund war: unter System/Server IP bearbeiten hatte ich in der obersten Zeile im, Eingabefeld für die IP die IP drin stehen und vermutlich rechts auf den Filter geklickt.
    Bei Client war dann der client für diese betreffende Domain eingetragen und nicht der Reseller, dem dieser Client zugeordnet ist.
    Jetzt hab ich den Filter raus, die IP dem Resller zugeordnet und bei den Webseiten statt dem * die IP ausgewählt. Und siehe da....
    Manoman ... ganz schön doof ... aber da sieht man´s mal wieder wie man sich verrennen kann. Meine Blindheit hat mich jetzt bestimmt 2,5 Stunden gekostet. Aaargh :)
     

Diese Seite empfehlen