Relay Acces denied

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Thomas Hoffmann, 17. Dez. 2007.

  1. Thomas Hoffmann

    Thomas Hoffmann New Member

    Hallo,

    ich habe ISPConfig nach Anleitung unter Mandriva 2007.1 installiert. Diese System habe ich in VMWare Server 1.0.4 laufen. Ich kann auf die virtuelle Maschine bei meinem Provider zugreifen (übers Webfrontend und per ssh).

    Mail kann ich empfangen und von dem Webfrontend senden.

    Wenn ich eine E-Mail von meinem E-Mail Programm (Evolution) an meine eigene Adresse sende funktioniert dies auch ohne Probleme.

    Sende ich aber über Evolution, dann erhalte ich folgende Fehlermeldung:

    Fehler beim Ausführen eines Vorgangs.

    RCPT TO <siahoff@........> gescheitert: <siahoff@......>: Relay access denied

    [..... = Domäne, wurde entfernt]

    kann mir hier jemand weiterhelfen.


    Vielen Dank.

    Thomas Hoffmann
     
  2. Till

    Till Administrator

    Hallo,

    Du musst SMTP Authentifizierung in Evolution aktivieren. Benutzername und Passwort sind identisch mit den pop3 / IMAP Zugangsdaten.
     
  3. Thomas Hoffmann

    Thomas Hoffmann New Member

    Hallo Till,

    ich denke es liegt nicht am E-Mail Programm. Ich habe es mit K-Mail, Outlook und Outlook Express probiert. Wenn ich innerhalb der Domäne schicke, werden die Mail ausgeliefert. Wenn ich an eine andere Domäne sende wird folgendes mitgeloggt.

    ---------------------------schnipp--------------------------------------

    Dec 17 20:42:09 odin postfix/smtpd[6141]: warning: SASL authentication failure: Password verification failed
    Dec 17 20:42:09 odin postfix/smtpd[6141]: warning: p5B156C3E.dip.t-dialin.net[91.21.108.62]: SASL PLAIN authentication failed: authentication failure
    Dec 17 20:43:09 odin postfix/smtpd[6141]: warning: p5B156C3E.dip.t-dialin.net[91.21.108.62]: SASL LOGIN authentication failed: authentication failure
    Dec 17 20:47:02 odin postfix/smtpd[6253]: warning: SASL authentication failure: Password verification failed
    Dec 17 20:47:02 odin postfix/smtpd[6253]: warning: p5B156C3E.dip.t-dialin.net[91.21.108.62]: SASL PLAIN authentication failed: authentication failure
    Dec 17 21:31:25 odin postfix/smtpd[7103]: warning: SASL authentication failure: All-whitespace username.
    Dec 17 21:31:25 odin postfix/smtpd[7103]: warning: p5B156C3E.dip.t-dialin.net[91.21.108.62]: SASL PLAIN authentication failed: generic failure
    Dec 17 21:31:37 odin postfix/smtpd[7103]: warning: SASL authentication failure: All-whitespace username.
    Dec 17 21:31:37 odin postfix/smtpd[7103]: warning: p5B156C3E.dip.t-dialin.net[91.21.108.62]: SASL PLAIN authentication failed: generic failure

    --------------------------schnapp--------------------------------------

    Es könnte auch sein das ein Fehler in der smtpd.conf ist.

    ---------------------------schnipp--------------------------------------
    smtpd.conf
    SASL library configuration file for postfix
    # all parameters are documented into:
    # /usr/share/doc/cyrus-sasl-2.*/options.html

    # The mech_list parameters list the sasl mechanisms to use,
    # default being all mechs found.
    mech_list: plain login

    # To authenticate using the separate saslauthd daemon, (e.g. for
    # system or ldap users). Also see /etc/sysconfig/saslauthd.
    pwcheck_method: saslauthd
    saslauthd_path: /var/lib/sasl2/mux

    # To authenticate against users stored in sasldb.
    #pwcheck_method: auxprop
    #auxprop_plugin: sasldb
    #sasldb_path: /var/lib/sasl2/sasl.db

    --------------------------schnapp---------------------------------------


    hier noch die main.cf von postfix

    -------------------------schnipp-----------------------------------------
    queue_directory = /var/spool/postfix
    mail_owner = postfix
    global_config_directory = /etc/postfix

    # User configurable parameters

    inet_interfaces = all
    mynetworks_style = host
    #delay_warning_time = 4h
    smtpd_banner = $myhostname ESMTP $mail_name ($mail_version) (Mandriva Linux)
    unknown_local_recipient_reject_code = 450
    smtp-filter_destination_concurrency_limit = 2
    lmtp-filter_destination_concurrency_limit = 2
    recipient_delimiter = +
    owner_request_special = no
    alias_database = hash:/etc/postfix/aliases, hash:/var/lib/mailman/data/aliases
    alias_maps = hash:/etc/postfix/aliases, hash:/var/lib/mailman/data/aliases
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    #smtpd_sasl_security_options = noanonymous
    smtp_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    #smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtp_recipient_restricktions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    mydomain = thosia.de
    myhostname = odin.$mydomain
    mydestination = /etc/postfix/local-host-names,localhost.thosia.de
    mynetworks = 127.0.0.0/8
    smtpd_tls_auth_only = no
    #
    # folgender eintrag wurde geaendert.
    #
    #smtpd_use_tls = yes
    #
    # in
    #
    smtp_use_tls =yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    virtual_maps = hash:/etc/postfix/virtusertable


    -------------------------schnapp----------------------------------------

     
    Zuletzt bearbeitet: 18. Dez. 2007
  4. Till

    Till Administrator

    Die Config Dateien sehen soweit ok aus. Check bitte Deinen Email Client, dass er wirklich den gleichen Usernamen und Passwort für smtp authentifizierung sendet. Ob Du bereits mehrere Clients ausprobiert hast, ist nicht weiter relevant, da Du bei eigentlich allen Clients smtp-auth separat aktivieren musst.
     
  5. Thomas Hoffmann

    Thomas Hoffmann New Member

    Hallo Till,

    ich denke es liegt nicht an den Clients. Es ist mir etwas scheierhaft, wenn ich eine E-Mail an einen anderen (oder an mich selbst) User schicke der in meiner Domäne ist, funktioiniert dies auch ohne Probleme. Die Mail wird versand und auch zugestellt.

    Ebenso funktioniert es, wenn ich vom Webfrontend eine Mail an eine beliebige Person sende, da funktioniert auch, nur halt mit einem Mailprogroamm nicht.

    Hier kommt dann immer der Fehler Relay access denied. Meine Vermutung liegt das es am Zusammenspiel von cyrus sasl2 und postfix liegt. Hier scheint irgendetwas mit der authentivizierung nicht zu klappen.

    Zum Glück ist bald Weihnachten, damit ich mich mit diesem Problem näher beschäftigen kann.

    Es wäre natürlich gut, wenn ich hier Hilfe bekäme was eigentlich los ist.

    Die Logfiles geben auch nicht viel her.

    mfg

    Thomas
     
  6. Till

    Till Administrator

    Das was Du beschreibst, ist eben das ganz normale Verhalten, wenn die SMTP Authentifizierung im Client nicht aktiviert ist oder aber der falsche User oder das Falsche Passwort verwendet wird. Du kannst an lokale Domains verschicken, da dafür keine Authentifizierung notwendig ist und per Webmail an alle Domains, da sich das Webmail Programm auch nicht authentifizieren muss. Also wie gesagt, alles ganz normal.

    Wenn Du nun wirklich nochmal Deinen Client überprüft hast und sicher bist, dass Du dort den Usernamen im Format "web[ID]_username" wie auch bei der pop3 Authentifizierung eingegeben hast, dann scahu nochmal nach, ob sasl wirklich gegen pam oder shadow, also die Linux Benutzerdatenbank authentifiziert.
     
  7. Thomas Hoffmann

    Thomas Hoffmann New Member

    Hallo Till,

    den Fehler habe ich nun gefunden. Es lag an der main.cf von Postfix. Hier hatte ich ein "Leerzeichen" nicht in einem Parameter. Dies habe ich korriegiert und nun "klappt es auch mit dem Nachbarn".


    Vielen Dank für die Hilfe(n).

    Ich denke hier und da werden schon noch ein paar Fragen auftauchen.

    Wünsche allen ein Frohes Weichnachtsfest und ein Gutes Neues Jahr.

    Thomas Hoffmann
     
  8. maison

    maison New Member

    Hallo Thomas,

    Könntest du bitte beschrieben, *wo* du das Leerzeichen eingesetzt hast? Ich habe das gleiche Problem und würde es auch gerne beheben.

    Gruß und Dank!
    maison
     
  9. Till

    Till Administrator

    Hast Du in Deinem Email Clinet die SMTP Authentifizierung aktiviert. Überprüf das bitte nochmal, das ist der häufigste Grund für dei Fehlermeldung. Außerdem stell bitte sicherm dass die Webseite www.domain.com eine co-domain domain.com mit leerem Hostnamen Feld hat.
     
  10. maison

    maison New Member

    Hammer! Danke Till für deine schnelle Antwort! Das ist ja fast wie IRC :)
    Ich habe SMTP Authentifizierung bei mir aktiviert. Der leere Host Eintrag, also domain.com fehlte tatsächlich, aber selbst nach dem Nachtragen und einem Restart des Postfix Servers erhalte ich weiterhin diese Fehlermeldung.

    Hast du evtl. noch eine Idee?
     
  11. maison

    maison New Member

    Wenn ich unter

    mynetworks

    die IP Adresse eintrage, die ich von meinem ISP zugewiesen bekommen habe, dann kann ich die Mail versenden.

    Allerdings kann es ja nicht sein, das die SMTP Authentifizierung doch nicht funktioniert?

    Gruß
     
  12. Till

    Till Administrator

    Welche Fehlermeldung steht denn genau im mail log?
     
  13. maison

    maison New Member

    Das steht im mail.log:

    localhost authdaemond: received auth request, service=imap, authtype=login
    localhost authdaemond: authmysql: trying this module
    localhost authdaemond: SQL query: SELECT email, password, "", uid, gid, homedir, maildir, concat(quota,'S'), "", concat('disableimap=',disabl
    eimap,',disablepop3=',disablepop3) FROM mail_user WHERE email = "<meineEmailAdresse>"
    localhost authdaemond: password matches successfully
    localhost authdaemond: authmysql: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/home/vmail/, address=<meineEmailadresse>,
    fullname=<null>, maildir=/home/vmail/<domain>/<emaillogin>/, quota=0S, options=disableimap=0,disablepop3=0
    localhost authdaemond: authmysql: clearpasswd=<null>, passwd=<meinPasswort>
    localhost authdaemond: Authenticated: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/home/vmail/, address=<meineEmailadresse>
    .de, fullname=<null>, maildir=/home/vmail/<domain>/<emaillogin>/, quota=0S, options=disableimap=0,disablepop3=0
    localhost authdaemond: Authenticated: clearpasswd=_meinPasswort, passwd=_meinPasswort
    localhost imapd: LOGIN, user=<meineIPAdresse>, ip=[::ffff:<meineIPAdresse>], protocol=IMAP
    localhost postfix/smtpd[11322]: connect from <meineIPAdresse>
    localhost postfix/smtpd[11322]: NOQUEUE: reject: RCPT from <meineIPAdresse>: 554 5.7.1 <meineEmailAdresse>: Relay access denied; from=<meineMailadresse> to=<meineMailadresse> proto=ESMTP helo=<[192.168.178.23]>
     
  14. Thomas Hoffmann

    Thomas Hoffmann New Member

    Hallo Maison,

    das ist schon lange her, wo ich den fehler hatte, es war auch nur ein Zufall da s ich diesen entdeckt habe. Wenn Du willst, poste mal deine /etc/postfix/main.cf. Ich denke dann kann ich es vergleichen wo der Fehler liegt.

    Ich weiss es nicht mehr so genau was es war. Was ich auf jeden Fall weiss, war ein Leerzeichen das nicht gesetz war. Ich bin jetzt wieder online zuhause, und werde mal die Parameter nachsehen.

    schau dir mal auf jeden Fall folgende Parameter an (falls vorhanden)

    smtpd_sasl_local_domain = (bei mir leer)
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth clients = yes (der war es warscheinlich)
    smtpd_helo_required = yes
    smtpd_recipient_restrictions =

    permit.....
    permit......
    usw....
    smtpd_delay_reject = yes

    Am besten überprüfe ob nach JEDEM = ein LEERZEICHEN folgt.


    Wenn irgendwo keins ist, bitte einfügen, wenn es dann funktioniert, brauchst du Deine main.cf nicht zu posten.

    Hoffe geholfen zu haben.


    mfg

    Thomas Hoffmann
     
    Zuletzt bearbeitet: 11. Okt. 2008
  15. Till

    Till Administrator

    @maison

    Ich denke Du verwendest ISPConfig 3 nach dem Log Auszug zu urteilen, das ist aber eine ganz andere Software als das ISPConfig 2 das Thomas einsetzt und es wird dann auch eine ganz andere Postfix Konfig eingesetzt. Deshalb besser immer nicht in einen Fremden Thraed posten sondern lieber einen neuen aufmachen :)

    Versuchst Du eine Email an eine ecxterne Domain wie web.de zu schicken oder an eine lokale Domain?
     
  16. maison

    maison New Member

    Hallo Till,

    Sry für die späte Antwort. Ich versuche eine Mail an eine exterene Domain (web.de/gmx.de) zu versenden.

    Viele Grüße && Danke!
     
  17. Till

    Till Administrator

    Laut dieser Log Zeile verschickst Du aber eine Email von Deiner Adresse an Dich selbst. Da Du Dich mit dieser Adressse auch per smtp authentifiziert hast, muss es eine lokale Adresse sein und keine von web.de.
     

Diese Seite empfehlen