ReSync Sites Enabled

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Deex, 9. Dez. 2015.

  1. Deex

    Deex Member

    Hi,

    ich hatte einige erhebliche schwierigikeiten mit dem Server so das die letzten Tage das Filesystem wiederhergestellt werden musste. Nun taucht dabei jetzt ein Problem auf. Die Dateien in "Sites Enabled" haben sich geändert, scheinbar hat ISPConfig entweder keine rechte mehr diese anzulegen oder.. ehrlich gesagt bin ich mir auch nicht sicher was da los ist. Webb ich als Beispiel eine Website Lösche dann bleiben reste in Sites Enabled übrig die er nicht entfernt. Nun habe ich einmal eine neue Domäne angelegt, mit scheint alles wieder in Ordnung zu sein.
    Ich muss zugeben das ich mir nicht so sicher bin wie ich da jetzt vorzugehen habe um diese zu Syncronisieren, einfach mal mit dem Hammer drauf und sie entfernen möchte ich jetzt auch nicht ohne zu wissen was ich da mache.

    Ich denke momentan das die Symlinks defekt sind und würde mich dafür interessieren wie ich die über IspConfig wieder zurücksetze.

    So sieht es aktuell aus.
     

    Anhänge:

  2. Till

    Till Administrator

    In sites enabled stehen nur symlinks, niemals dateien. Es sieht so aus als ob Du beim wiederherstelen die symlinks durch Dateien ersetzt hast. Lösche alle Dateien in sites-enabled und führe dann ein resync in ISPConfig aus damit es die symlinks neu anlegt.
     
  3. Deex

    Deex Member

    Hi, irgendwie lief das nicht so gut

    Ich habe die Dateien gelöscht, dann auf Resync gegangen. Dann fing er an diese neu zu erstellen.. dann passierte nichts mehr und jetzt kann ich ISPConfig nicht mehr aufrufen "Gesicherte Verbindung fehlgeschlagen". Nginx und andere Websites auf diesem laufen problemlos doch ISPConfig will jetzt nicht mehr..

    Nachtrag: Jetzt kommt "Fehler: Verbindung fehlgeschlagen" zu ispconfig

    Maßnahmen
    - Nginx erneut gestartet - Keine änderung
    - Php5 FPM erneut gestartet - Keine änderung
    -Server Reboot - Keine änderung

    Okay fehler gefunden
    000-apps.vhost und 000-ispconfig.vhost

    fehlten in dem /sites-enabled Ordner. Die habe ich einfach dann selbst mit den statischen dingern überschrieben nun kann man ISPConfig wieder aufrufen. Bin mir aber sicher das das so sein soll.
     
    Zuletzt bearbeitet: 9. Dez. 2015
  4. Till

    Till Administrator

    Das sollten auch symlinks sein, wenn Du es mit dateien ersetzt hast, dann lösche die bitte und ersetze sie durch einen symlink auf die Datei in sites-available.
     
  5. Deex

    Deex Member

    Erledigt,- ist es jetzt jedoch notwendig das die auch so heißen

    Orginal:000-ispconfig.vhost
    Mein Symlink: ispconfig.vhost
     
  6. Till

    Till Administrator

    die müssen mit 000- anfangen da sich durch den namen die Reihenfolge bestimmt und sie vor den anderen vhost dateien geladen werden müssen.
     
  7. Deex

    Deex Member

    Alles klar,- danke wieder was gerlernt :)
     

Diese Seite empfehlen