roundcube Forbidden 403

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von delike, 31. März 2011.

  1. delike

    delike New Member

    Hallo an alle.

    Ich werd hier noch verrückt...!

    Ich habe ISPConfig 3 und Roundcube installiert und alles lief wunderbar.

    es war keine IP in ISPConfig angelegt und alle Domains liefen über *.

    Nachdem ich gestern eine zusätzliche IP brauchte habe ich die entsprechend in /etc/interfaces/network angelegt, server neugestartet und die 2 IP´s (Hauptip und zweite IP) im CP angelegt. Alle Domains verweisen jetzt vorerst auf die erste IP und nur eine Domain auf die zweite.

    Soweit alles OK.

    Gestern Abend musste ich dann allerdings feststellen das nur noch phpmyadmin über http://server.tld/phpadmin erreichbar war und sonst nichts.

    Nach einigem lesen habe ich festgestellt das die symlinks im /var/www ordner ja nun nicht mehr funktionieren und hab daher den symlink "webmail" (für roundcube) gelöscht.

    Ich habe mir dann die Datei /etc/apache2/conf.d/phpmyadmin.conf kopiert und als /etc/apache2/conf.d/roundcubemail.conf eingefügt und wie folgt etwas gekürzt und angepasst:

    Code:
    Alias /webmail /usr/share/roundcubemail
    
    <Directory /usr/share/roundcubemail>
        Options FollowSymLinks
        DirectoryIndex index.php
    
        <IfModule mod_php5.c>
            AddType application/x-httpd-php .php
    
            php_flag magic_quotes_gpc Off
            php_flag track_vars On
            php_flag register_globals Off
            php_value include_path .
        </IfModule>
    
    </Directory>
    danach einen /etc/init.d/apache2 reload durchgeführt und ab jetzt erhalte ich auf http://server.tld/webmail immer einen 403 Forbidden...

    Kann mir irgendjemand sagen wo hier das problem liegt?

    Ich find einfach keine Anhaltspunkte mehr die mir irgendwie hilfreich sein könnten.. :(
     
  2. Till

    Till Administrator

  3. delike

    delike New Member

    vielen Dank für deine Antwort!

    Da ich parrallel noch squirrelmail laufen habe und dieses howto auch schon gefunden habe, habe ich dieses befolgt und sqiurrelmail funktioniert auch.

    nur roundcube will nicht.
     
  4. Till

    Till Administrator

    Hast Du denn auch das open_basedir für roundcube in den ispconfig server settings entsptrechend angepasst und danach zusätzlich in allen bisher bestehenden Webseiten geändert?
     
  5. delike

    delike New Member

    Ahh.. du meinst unter System->serverkonfiguration->Web->PHP open_basedir ???

    nee das hab ich noch ne gemacht, hab den open_basedir nur für momentan eine domain gesetzt und dann mit dieser getestet...
     
  6. delike

    delike New Member

    immernoch FEHLER 403 _ Unzulässig! :(
     
  7. Till

    Till Administrator

    Du musst das zusätzlich in allen webs ändern. Die server settings sind nur der default für neue webs.
     
  8. delike

    delike New Member

    also hatte des basedir jetzt in den settings und bei meiner testdomain eingetragen, allerdings immernoch ohne erfolg.. :(
     
  9. Till

    Till Administrator

    Schau ins apache error.log und das error.log der Webseite, dort steht der Grund für den Fehler drin.
     
  10. delike

    delike New Member

    hmm also dir error.log von der domain sagt folgendes:

    [Thu Mar 31 16:06:44 2011] [error] [client xx.xx.xxx.xx] client denied by server configuration: /usr/share/roundcubemail

    .. hilfst mir auch ne weiter..

    und die error.log vom apache sagt gar nichts... :'(
     
  11. Till

    Till Administrator

    Dann füge mal folgendes am Ende der apache2.conf datei ein:

    <Directory /usr/share/roundcubemails>
    Order allow,deny
    Allow from all
    </Directory>

    und starte apache neu.
     
  12. delike

    delike New Member

    das hatt ich auch grad gefunden und getestet. jetzt gehts :D

    Ich dank dir wie verrückt!! ;)

    hier nochmal ein kompletter auszug der /etc/apache2/conf.d/webmail.conf für die Nachwelt ;)

    Code:
    ###########################################
    #This is basically a modified version of /etc/apache2/conf.d/phpmyadmin.conf
    # RoundCube default Apache configuration
    
    Alias /webmail /usr/share/roundcubemail
    
    <Directory /usr/share/roundcubemail>
    Options Indexes FollowSymLinks
    DirectoryIndex index.php
    AllowOverride All
    Order allow,deny
    Allow from all
    
    
    # Authorize for setup
    <IfModule mod_php4.c>
    AddType application/x-httpd-php .php
    
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_value include_path .
    </IfModule>
    <IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_value include_path .
    </IfModule>
    </Directory>
    ######################################### 
     

Diese Seite empfehlen