RoundCube Webmail auf ISPConfig

#1
Hallo,

hat jemand eine Idee wie RoundCube Webmail installieren kann die Anleitung hier klappt nicht wenn ich den Installer aufrufen will kommt imme "Internal Server Error 500"

Hat jemand eine Idee?

Linux: Fedora 9
ISPConfig: 2.2.24
Webmail: v0.2-alpha

Gruß
Alex
 

hahni

Active Member
#4
Ist das neue Neu-Installation von RoundCube oder ein Update? Falls es ein Update ist, müssten nämlich vorher die alten Verzeichnisse gelöscht werden!
 

Till

Administrator
#7
Bei einem 500er Fehler immer erstmal ins error log der Website sehen, um festzustellen was eigentlich der Fehler ist. In vielen Fällen ist es eine nicht erlaubte Anweisung in einem .htaccess File.
 
#8
Sorry aber leider hat die HDD von Server einen defekt und nun muss ich eune Neue HDD anschliessen und alles von vorne installieren sorry für den Thread

Melde mich soweit ich wieder bei der Stelle bin.


Gruß
Alex
 
#10
So nun habe ich Fedora uns ISPConfig wieder drauf, webmail installer startet auch lag an der .htaccess Datei okay aber wenn ich auf punkt 2 gehe zu config erstellen dann ist da nur der Banner und die mitte ist leer uns weiß.


Gruß
Alex
 
#13
Vorallem nervt mich der zeichen satz bei Fedora in der Konsole....arrrrr


chown: ungültiger Benutzer: „\226R“
[root@mrburnz77 web]#


Wie kann das noch ändern ?
 
#14
auch fehler 500

hi,

bekomme auch den fehler 500, kann mir da jemand helfen.

meine .htaccess
# AddDefaultCharset UTF-8
AddType text/x-component .htc
<IfModule mod_php4.c>
php_flag display_errors Off
php_flag log_errors On
php_value error_log logs/errors
php_value upload_max_filesize 5M
php_value post_max_size 6M
php_value memory_limit 64M
php_value session.auto_start 0
php_value zlib.output_compression 0
php_value magic_quotes_gpc 0
</IfModule>
<IfModule mod_php5.c>
php_flag display_errors Off
php_flag log_errors On
php_value error_log logs/errors
php_value upload_max_filesize 5M
php_value post_max_size 6M
php_value memory_limit 64M
php_value session.auto_start 0
php_value zlib.output_compression 0
php_value magic_quotes_gpc 0
</IfModule>
<FilesMatch "(\.inc|\~)$">
Order allow,deny
Deny from all
</FilesMatch>
Order deny,allow
Allow from all
aud dem error.log

/var/www/web3/web/.htaccess: php_flag not allowed here
schon mal danke, leider kenn ich mich halt noch nicht so gut aus damit.

lg
kangoo
 

Till

Administrator
#15
Lösche diesen Teil in der .htaccess Datei:

<IfModule mod_php4.c>
php_flag display_errors Off
php_flag log_errors On
php_value error_log logs/errors
php_value upload_max_filesize 5M
php_value post_max_size 6M
php_value memory_limit 64M
php_value session.auto_start 0
php_value zlib.output_compression 0
php_value magic_quotes_gpc 0
</IfModule>
<IfModule mod_php5.c>
php_flag display_errors Off
php_flag log_errors On
php_value error_log logs/errors
php_value upload_max_filesize 5M
php_value post_max_size 6M
php_value memory_limit 64M
php_value session.auto_start 0
php_value zlib.output_compression 0
php_value magic_quotes_gpc 0
</IfModule>

und füge ihn stattdessen im apache Direktiven Feld der Webseite in ISPConfig ein.
 
#16
fehler 500

hi,

danke für die schnelle info. leider komme ich jetzt aber auf die standard inex seite.

habe im apache direktiven feld der webseite in ispconfig nun folgende drinstehen:

<Directory "/var/www/web3/web">Options FollowSymLinksAllowOverride All</Directory>
<IfModule mod_php4.c>
php_flag display_errors Off
php_flag log_errors On
php_value error_log logs/errors
php_value upload_max_filesize 5M
php_value post_max_size 6M
php_value memory_limit 64M
php_value session.auto_start 0
php_value zlib.output_compression 0
php_value magic_quotes_gpc 0
</IfModule>
<IfModule mod_php5.c>
php_flag display_errors Off
php_flag log_errors On
php_value error_log logs/errors
php_value upload_max_filesize 5M
php_value post_max_size 6M
php_value memory_limit 64M
php_value session.auto_start 0
php_value zlib.output_compression 0
php_value magic_quotes_gpc 0
</IfModule>
 
#18
keine seite

hi,

habe jetzt die standard index seite vor der installation gelöscht und alles so gemacht wie beschrieben.
jetzt sind auch alle fehlermeldungen weg, aber ich erhalte nur eine leere seite wenn ich webmail.xxxx.xx eingebe.

im err. log der seite gibt es keine fehlermeldung. index.php ist im ordner.

was kann nun fehlen?

nachtrag: im apche err.log ist noch das:

[Tue Sep 09 13:06:08 2008] [notice] caught SIGTERM, shutting down
[Tue Sep 09 13:06:10 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
PHP Warning: Module 'json' already loaded in Unknown on line 0
[Tue Sep 09 13:06:10 2008] [notice] Apache/2.2.3 (Debian) PHP/5.2.0-8+etch11 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations

lg
kangoo
 
Zuletzt bearbeitet:

Till

Administrator
#20
Dann hast Du vermutlich falsche Datenbankparameter angegeben, kontrollier das halt nochmal. Ob ein Username einen Unterstrich hat oder nicht ist nicht wichtig, Du musst ihn halt so im Konfig File angeben, wie er ist.
 

Werbung

Top