SASL authentication failure: cannot connect to saslauthd server

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von sven, 17. Jan. 2009.

  1. sven

    sven New Member

    Hallo,

    wenn ich über smtp-auth Emails verschicken möchte, erhalte ich die folgende Fehlermeldung.

    Code:
    Jan 17 13:21:13 server postfix/smtpd[9185]: connect from static.ip.server.de[xx.xx.xx.xx]
    Jan 17 13:21:13 server postfix/smtpd[9185]: warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied
    Jan 17 13:21:13 server postfix/smtpd[9185]: warning: static.xx.xx.xx.xx.server.de[xx.xx.xx.xx]: SASL LOGIN authentication failed: generic failure
    Jan 17 13:21:13 server postfix/smtpd[9185]: NOQUEUE: reject: RCPT from static.xx.xx.xx.xx.server.de[xx.xx.xx.xx]: 554 5.7.1 <webmaster@domain.de>: Relay access denied; from=<info@meinedomain.de> to=<webmaster@domain.de> proto=ESMTP helo=<www.meinedomain.de>
    
    Der saslauthd läuft

    Code:
    server:~# /etc/init.d/saslauthd start
    Starting SASL Authentication Daemon: saslauthd (already running).
    
    server:~# ps aux | grep sasl
    Code:
    root      7524  0.0  0.0  53036   900 ?        Ss   12:48   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      7525  0.0  0.0  53036   632 ?        S    12:48   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      7526  0.0  0.0  53036   512 ?        S    12:48   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      7527  0.0  0.0  53036   512 ?        S    12:48   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      7528  0.0  0.0  53036   512 ?        S    12:48   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root     10757  0.0  0.0   7468   832 pts/0    S+   13:43   0:00 grep sasl
    
    less /etc/default/saslauthd
    Code:
    # Should saslauthd run automatically on startup? (default: no)
    START=yes
    
    # Description of this saslauthd instance. Recommended.
    # (suggestion: SASL Authentication Daemon)
    DESC="SASL Authentication Daemon"
    
    # Short name of this saslauthd instance. Strongly recommended.
    # (suggestion: saslauthd)
    NAME="saslauthd"
    
    # Example: MECHANISMS="pam"
    MECHANISMS="pam"
    
    # Additional options for this mechanism. (default: none)
    # See the saslauthd man page for information about mech-specific options.
    MECH_OPTIONS=""
    
    # How many saslauthd processes should we run? (default: 5)
    # A value of 0 will fork a new process for each connection.
    THREADS=5
    
    # Example for postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
    #OPTIONS="-c -m /var/run/saslauthd"
    OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
    
    Was könnte schief gelaufen sein?


    Kleiner Nachtrag:

    Ich habe auf meiner Webseite das versenden von Emails via smtp-auth eingestellt.
    Wenn ich jetzt Mails verschicke, dann bekomme ich selber Emails über smtp-auth.


    Jedoch an Email Adressen, die NICHT auf dem Server eingerichtet sind, wird die Nachricht nicht verschickt, bzw. es erfolgt eine Ablehnung ...


    Beispiel:

    Code:
    Jan 17 14:19:53 server postfix/smtpd[11549]: warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied
    Jan 17 14:19:53 server postfix/smtpd[11549]: warning: static.server[xx.xx.xx.xx]: SASL LOGIN authentication failed: generic failure
    Jan 17 14:19:53 server postfix/smtpd[11549]: NOQUEUE: reject: RCPT server.xx.xx.xx.xx.server.de[xx.xx.xx.xx]: 554 5.7.1 <webmaster@fremdedoamin.de>: Relay access denied; from=<info@meinedomain.de> to=<webmaster@fremdedoamin.de> proto=ESMTP helo=<www.meinedomain.de>
    Jan 17 14:19:53 server postfix/smtpd[11549]: lost connection after RSET from static.server.de[xx.xx.xx.xx]
    Jan 17 14:19:53 server postfix/smtpd[11549]: disconnect from static.server.de[xx.xx.xx.xx]
    
    Vielen Dank und Grüße
    Sven
     
    Zuletzt bearbeitet: 17. Jan. 2009
  2. Till

    Till Administrator

    Der SASL Username hat die Form web[ID]_user und ist nicht die Emailadresse.
     
  3. sven

    sven New Member

    Danke für den Tipp, leider hat es nicht geklappt ... Was könnte es noch sein?
     
  4. Till

    Till Administrator

    Führe bitte nochmal alle Befehle des email Bereiches des perfect setups durch.
     

Diese Seite empfehlen