SecurityException in Application.cpp / Error 500

#1
Hallo,

ich habe eine neues Web angelegt. Egal mit welcher PHP Option, mit SuEXEC oder ohne, ich es versuche, ich erhalte immer einen Error 500 und im error.log des Web steht folgendes:

[Wed Jun 23 10:07:33 2010] [error] [client 93.104.65.239] SecurityException in Application.cpp:511: Unknown Interpreter: php
[Wed Jun 23 10:07:33 2010] [error] [client 93.104.65.239] Premature end of script headers: index.php

Das ist ein XTCommerce Shop der von einem älteren Server umgezogen werden soll

SW
 
#2
Jetzt hab ich den Shop doch zum laufen bekommen aber nur mit dem PHP-Modus CGI und der Option SuEXEC. Kann mir das mal jemand bitte erklären?

Wenn ich das richtig verstanden habe ist doch SuPHP und Fast-CGI plus der Option SuEXEC am sichersten. Ist das so richtig?

Danke

SW
 

Till

Administrator
#3
Die PHP Dateien gehören dem falschen User oder haben faksche Rechte. Dateien in einem Web müssen dem User und der Gruppe des Webs gehören und sollten nicht World writable sein.

Wenn ich das richtig verstanden habe ist doch SuPHP und Fast-CGI plus der Option SuEXEC am sichersten. Ist das so richtig?
Nicht ganz. cgi + suecex ist genauso sicher wie fcgi-suexec, es ist nur langsamer.
 
#6
Bitteschön:

[global]
;Path to logfile
logfile=/var/log/suphp/suphp.log

;Loglevel
loglevel=info

;User Apache is running as
webserver_user=www-data

;Path all scripts have to be in
docroot=/var/www:${HOME}/public_html

;Path to chroot() to before executing script
;chroot=/mychroot

; Security options
allow_file_group_writeable=false
allow_file_others_writeable=false
allow_directory_group_writeable=false
allow_directory_others_writeable=false

;Check wheter script is within DOCUMENT_ROOT
check_vhost_docroot=true

;Send minor error messages to browser
errors_to_browser=false

;PATH environment variable
env_path=/bin:/usr/bin

;Umask to set, specify in octal notation
umask=0022

; Minimum UID
min_uid=100

; Minimum GID
min_gid=100


[handlers]
;Handler for php-scripts
application/x-httpd-suphp="php:/usr/bin/php-cgi"

;Handler for CGI-scripts
x-suphp-cgi="execute:!self"
x-httpd-suphp=php:/usr/bin/php-cgi
umask=0022
 

Till

Administrator
#9
Entweder das oder aber:

docroot=/var/www

wenn das andere nicht geht. Die Frage ist nur, woher diese Eintraäge bei Dir kommen, Sie stammen weder aus den Defaults der Linux Distribution noch von ISPConfig. Ich vermute mal, das auf dem System vorher bereits ein anderes Controlpanel installiert gewesen ist, das diese falsche Einträge gesetzt hat. Das würde auch die diversen anderen Fehlfunktionen erklären, die Du gehabt hast.
 
#10
Entweder das oder aber:

docroot=/var/www

wenn das andere nicht geht. Die Frage ist nur, woher diese Eintraäge bei Dir kommen, Sie stammen weder aus den Defaults der Linux Distribution noch von ISPConfig. Ich vermute mal, das auf dem System vorher bereits ein anderes Controlpanel installiert gewesen ist, das diese falsche Einträge gesetzt hat. Das würde auch die diversen anderen Fehlfunktionen erklären, die Du gehabt hast.
Also weder das eine noch das andere hat was gebracht - es läuft nur mit CGI. Nein, das ist ein frisch installierter Ubuntu Server 10.04 der absolut jungfräulich war als das ISPCP installiert wurde.
 

Till

Administrator
#11
ISPCP ist eine andere Software als ISPConfig. Wenn Du also erst ISPCP installierst welches die Konfigurationsdatein ändert und danach dann ISPConfig, dann wird ISPConfig nicht richtig funktionieren.
 

Werbung