Sehr gesprächiger Amavisd

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von MBDTeam, 1. März 2012.

  1. MBDTeam

    MBDTeam New Member

    Hallo zusammen,
    ist es normal, das der Amavisd das log so zumüllt, das der rsyslogd sich beschwert:

    Code:
    Mar  1 16:41:55 webserver rsyslogd-2177: imuxsock lost 180 messages from pid 14929 due to rate-limiting
    Mar  1 16:41:55 webserver rsyslogd-2177: imuxsock begins to drop messages from pid 14929 due to rate-limiting
    
    Und gibt es eine Möglichkeit die Logs vom Dovecot und Amavisd aus dem Maillog zu holen?

    Gruß
    Michael
     
  2. Till

    Till Administrator

    Den amvis Loglevel kannst Du in der amavisd.conf Datei einstellen und das Log des Dovecot kannst Du in der dovecot.conf datei festlegen.
     
  3. MBDTeam

    MBDTeam New Member

    So dovecot ist in extra Logfiles. Für die, die das auch möchten: der deliver von Dovecot läuft nicht als root, nicht wie die dovecot Prozess. Deshalb müssen die Recht angepasst werden bzw. die deliver Logmeldung in extra Files mit den entsprechenden Rechten umgeleitet werden Siehe:
    Logging - Dovecot Wiki

    Beim Amavis hatte ich schon am $log_level rumgespielt. Der stand eigentlich auf 0, was für den normalen Betrieb ausreicht. Der war aber auch nicht Schuld an den vielen Meldungen. Schuld war:

    $nanny_details_level = 2;

    Der steht jetzt auf 1 und alles ist gut :)

    Gruß
    Michael
     
  4. st2xo

    st2xo Member

    muss den Thread nochmal aufwärmen ....

    Habe dasselbe Problem, Änderung der /etc/amavisd.conf (und natürlich restart amavis) bringt keine Änderung: jede eingehende Mail verursacht 219 Zeilen im /var/log/mail

    in /etc habe ich allerdings folgendes:

    -rw-r--r-- 1 root root 33715 Aug 6 18:27 amavisd.conf
    -r-------- 1 root root 36284 Jul 13 14:47 amavisd.conf~

    Letzteres steht auf nanny=2 und lässt sich nicht ändern.
    (Edit: chmod 664 und aktualisierung von amavisd.conf~ auf nanny=1 geht natürlich - hat aber keinen Effekt!)

    Was kann ich tun? Danke!


    (ach ja, es ist eine ziemlich jungfräuliche ISPConfig Installation, OpenSUSE, alles aktuell)
     
    Zuletzt bearbeitet: 6. Aug. 2012
  5. st2xo

    st2xo Member

    hier mal die Antwort auf meine eigene Frage, vielleicht stolpert ja noch jemand drüber:

    in meinem /etc/amavisd.conf File war zweimal enthalten

    $log_level = 0 (oben)
    $log_level = 5 (ganz unten, vorletzte Zeil)

    Änderung der 5 auf 0 bringt dann auch die Lösung.
     

Diese Seite empfehlen