Services stoppen einfach plötzlich

#1
hallo, ich bins wieder.

anfangs dachte ich nur das sei weil ich an der konfiguration dran bin oder was auch immer, aber ich habe vermehrt festgestellt das meine dienste machen was sie wollen.

also kann sein das plötzlich pop3 und imap nicht mehr funktionieren, dann ist plötzlich apache down, plötzlich alle dienste, dann nur der ftp, dann alle und so weiter. und das ohne interaktion von mir (system war jetzt ca. 4h unangefasst) und soeben waren alle dienste down.

ist das schon jemanden mal passiert?
wo kann ich am besten nachschauen weshalb und wieso? bsp vom apache log

Code:
[Fri Apr 10 15:39:04 2009] [notice] Graceful restart requested, doing restart
PHP Warning:  Module 'json' already loaded in Unknown on line 0
[Fri Apr 10 15:39:09 2009] [notice] Apache/2.2.3 (Debian) PHP/5.2.0-8+etch13 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
[Fri Apr 10 15:39:09 2009] [warn] long lost child came home! (pid 5492)
[Fri Apr 10 15:40:24 2009] [notice] caught SIGTERM, shutting down
[Fri Apr 10 15:40:26 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
PHP Warning:  Module 'json' already loaded in Unknown on line 0
[Fri Apr 10 15:40:26 2009] [notice] Apache/2.2.3 (Debian) PHP/5.2.0-8+etch13 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
[Fri Apr 10 15:40:50 2009] [error] server reached MaxClients setting, consider raising the MaxClients setting
[Fri Apr 10 15:41:01 2009] [notice] Graceful restart requested, doing restart
PHP Warning:  Module 'json' already loaded in Unknown on line 0
[Fri Apr 10 15:41:05 2009] [notice] Apache/2.2.3 (Debian) PHP/5.2.0-8+etch13 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
[Fri Apr 10 15:41:05 2009] [warn] long lost child came home! (pid 32594)
[Fri Apr 10 15:50:02 2009] [notice] Graceful restart requested, doing restart
PHP Warning:  Module 'json' already loaded in Unknown on line 0
[Fri Apr 10 15:50:10 2009] [notice] Apache/2.2.3 (Debian) PHP/5.2.0-8+etch13 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
[Fri Apr 10 15:50:10 2009] [warn] long lost child came home! (pid 18204)
[Fri Apr 10 15:56:01 2009] [notice] Graceful restart requested, doing restart
PHP Warning:  Module 'json' already loaded in Unknown on line 0
[Fri Apr 10 15:56:04 2009] [notice] Apache/2.2.3 (Debian) PHP/5.2.0-8+etch13 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
[Fri Apr 10 15:56:04 2009] [warn] long lost child came home! (pid 5577)
[Fri Apr 10 16:26:02 2009] [notice] Graceful restart requested, doing restart
PHP Warning:  Module 'json' already loaded in Unknown on line 0
[Fri Apr 10 16:26:06 2009] [notice] Apache/2.2.3 (Debian) PHP/5.2.0-8+etch13 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
[Fri Apr 10 16:26:06 2009] [warn] long lost child came home! (pid 15987)
[Fri Apr 10 20:26:04 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
PHP Warning:  Module 'json' already loaded in Unknown on line 0
[Fri Apr 10 20:26:04 2009] [warn] pid file /var/run/apache2.pid overwritten -- Unclean shutdown of previous Apache run?
[Fri Apr 10 20:26:04 2009] [notice] Apache/2.2.3 (Debian) PHP/5.2.0-8+etch13 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
 

Till

Administrator
#2
Das was Du oben gepostest hats sieht nach ganz normalen restarts tdes apache aus, wie sie nach Konfigurationsänderungen gemacht werden müssen.

Schau doch mal ins /home/admispconfig/ispconfig/ispconfig.log ob die Konfigurationsänderungen übder ISPConfig zu den Zeitpunkkten gemacht wurden.
 
#3
guten morgen till, so früh schon wach?

Code:
server1:/var/log/apache2# locate ispconfig.log
/var/log/ispconfig/ispconfig.log
server1:/var/log/apache2# less /var/log/ispconfig/ispconfig.log
^^ diese datei ist leer

wie gesagt, innerhalb von einigen minuten kann das ganze system offine sein, dann nur mail, dann wieder dies, dann das - extrem strange, und das obwohl ich keine änderungen vornehme, sondern im normalbetrieb
 

Till

Administrator
#4
Ok, dann benutzt Du wahrscheinlich ispconfig 3 und nicht 2. Schreib es am besten das nächste mal dazu wenn Du was postest. Wenn die Datei leer ist liegen keine Fehler vor, Du kannst dann höchstens mal den Debug Level in der config.onc.php datei von 2 auf 0 setzen und dann mal scahuen wes Du im ISPConfig log bekommst.
 
#5
ach ja, sorry, das fast wichtigste hatte ich natürlich vergessen...

also debian 4.0 etch, ispconfig 3
installiert nach der anleitung dafür und inspiriert von dem lenny howto

datei /usr/local/ispconfig/server/lib/config.inc.php
Code:
//** Constants
define("LOGLEVEL_DEBUG",0);
define("LOGLEVEL_WARN",1);
define("LOGLEVEL_ERROR",2);
datei /usr/local/ispconfig/interface/lib/config.inc.php
Code:
//** Constants
define("LOGLEVEL_DEBUG",0);
define("LOGLEVEL_WARN",1);
define("LOGLEVEL_ERROR",2);
kann es sein das du den error eintrag statt den debug meinst?
und welche dieser dateien ist dann dafür relevant?
 
#7
für den moment erscheint dies hier im logfile

Code:
11.04.2009-11:12 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
11.04.2009-11:12 - DEBUG - No Updated records found, starting only the core.
11.04.2009-11:12 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
11.04.2009-11:13 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
11.04.2009-11:13 - DEBUG - No Updated records found, starting only the core.
11.04.2009-11:13 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
11.04.2009-11:14 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
11.04.2009-11:14 - DEBUG - No Updated records found, starting only the core.
11.04.2009-11:14 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
 
#9
hmmm... wo könnte man dann das problem noch anpacken?

nur als beispiel, für den moment siehts so aus:

Code:
monitor_services_web_txt      monitor_services_online_txt
[I][B]monitor_services_ftp_txt     monitor_services_offline_txt[/B][/I]
monitor_services_smtp_txt     monitor_services_online_txt
monitor_services_pop_txt     monitor_services_online_txt
[I][B]monitor_services_imap_txt     monitor_services_offline_txt[/B][/I]
monitor_services_mydns_txt     monitor_services_online_txt
monitor_services_mysql_txt     monitor_services_online_txt
und nachher sieht das dann wieder komplett anderst aus.

und die logfiles sagen leider nichts aussagekräftiges aus und die dienste werden nicht von mir gestoppt
 

Till

Administrator
#10
Und was soll das genau sein was Du da gepostet hast?

hattest Du oder Dein provider vielleicht ein anderes Controlpanel vorher auf dem server installiert oder ist da noch sowas wie webmin drauf?
 
#11
das ist aus dem ispconfig, bei status.
sieht jetzt ja einfach so aus weil ja der debug modus anderst ist.
nein, es läuft kein webmin, kein anderes control pannel.
das ganze system war frisch neu installiert und hatte nichts drauf...

gibt es bei ispconfig ein script den man ausführen kann der dann automatisch alle dienste startet/stopt?
 

Werbung