Sichere FTP Übertragung erzwingen?

Dieses Thema im Forum "Server Administration" wurde erstellt von katasun, 29. Mai 2014.

  1. katasun

    katasun Member

    Inzwischen habe ich schon einiges durchsucht, aber ich suche noch immer eine Anleitung, bei ISPConfig 3 eine sichere FTP Übertragung zu erzwingen.

    Vielleicht gibt es die Möglichkeit auch nicht. Als Hintergrund ich nutze das aktuelle ISPConfig3 und ich kann auch eine gesicherte Übertragung im Filezilla einstellen. Alternativ kann ich aber auch die Übetragung im Klartext benutzen.

    *Heute bekam ich Post von meinem Provider mit dem Hinweis, das meine Passworte ausgespäht worden sind.

    Vielen Dank für Tipps, wie ich dieses Sicherheitsloch stopfen kann.

    Danke Katasun

    Ist das die richtige Antwort?

    ------------------------ ACCEPTING TLS SESSIONS ------------------------

    Once the certificate has been installed, you need to start a TLS-enabled pure-ftpd daemon with the -Y (or --tls=) switch.

    Example : /usr/local/sbin/pure-ftpd --tls=1 & - With "--tls=0", support for SSL/TLS is disabled.

    This is the default. - With "--tls=1", clients can connect either the traditional way or through an SSL/TLS layer.

    This is probably the setting you need if you want to enable TLS without having too much angry customers. -

    With "--tls=2", cleartext sessions are refused and only SSL/TLS compatible clients are accepted. -

    With "--tls=3", cleartext sessions are refused and only SSL/TLS compatible clients are accepted.

    Clear data connections are also refused, so private data connections are enforced.

    This is an extreme setting. When SSL/TLS has been successfully negociated for a connection, you'll see something similar to this in log files :
     
    Zuletzt bearbeitet: 29. Mai 2014
  2. robotto7831a

    robotto7831a Member

    Wenn Du tls=2 in die entsprechende Datei schreibst, dann werden nur noch gesicherte Verbindungen von dem FTP Server akzeptiert. Klartextverbinden werden komplett unterbunden.

    Welche Datei es ist, muss ich zu Hause erst nachauen wenn Interesse besteht.
     
  3. katasun

    katasun Member

    Danke für die Antwort

    jetzt habe ich alles gefunden. Es steht auch in der Anleitung. Trotzdem hatte ich es einfach übersehen.

    Jetzt ist alles OK.

    Vielen Dank
     

Diese Seite empfehlen