Sieve-Fehler nach Upgrade auf 3.0.4

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von nekr2005, 17. Nov. 2011.

  1. nekr2005

    nekr2005 New Member

    Hallo Leute,

    seit dem Upgrade von 3.0.3.3 funktioniert bei uns das Mailfilter bei den Mailboxen nicht mehr. Die Mails wie z.B. Junk werden nicht mehr verschoben, sondern landen in der INBOX.

    Als IMAP-Server wird dovecot verwendet und ispconfig läuft auf einem
    Debian 5.0, der auf dem aktuellen Stand ist.

    In der Maillog tauchen seit Upgrade bei der Auslieferung der Mails
    folgende Meldungen auf:

    sieve parse error: line 1: Unsupported features in require line
    msgid=<...>: saved mail to INBOX

    Beim genauen Hinschauen in die Datei .sieve bei den Mailboxen
    findet man raus, dass die erste Zeile so aussieht:

    require ["fileinto", "regex", "date", "relational", "vacation"];

    bei der vorigen Version hat die noch so ausgesehen:

    require ["fileinto", "regex", "vacation"];

    Wo könnte der Fehler liegen? Ich habe über die Forum-Suche nicht gefunden, das der so bei jemandem auftritt.

    bin für jeden Tipp dankbar.
     
  2. Till

    Till Administrator

    Möglicherweise hat die Dovecot Version von Debian 5 noch nicht alle Module, die für den Autoresponder mit datumsaktivierung notwendig sind.

    Ich denke da gibt es nur 2 Möglichkeiten:

    a) Update auf Debian 6
    oder b) die Vorlage der Sieve Datein in /usr/local/ispconfig/server/conf/ ändern und die beiden fehlenden Module aus der require Zeile entfernen.

    Bei Lösung b) wird dann jedoch der Auoresponder nicht nach Datum funktionieren und Du solltest wahrscheinlich am besten das komplette sieve Template durch die alte Version aus 3.0.3.3 erstezen:

    Code:
    require ["fileinto", "regex", "vacation"];
    
    <tmpl_if name="cc">
    # Send a copy of email to
    redirect "<tmpl_var name='cc'>";
    keep;
    </tmpl_if>
    
    <tmpl_if name="move_junk" op="==" value="y">
    # Move spam to spam folder
    if header :contains "X-Spam-Flag" "YES" {
      fileinto "Junk";
      # Stop here so that we do not reply on spams
      stop;
    }
    </tmpl_if>
    
    <tmpl_var name='custom_mailfilter'>
    
    <tmpl_if name="autoresponder" op="==" value="y">
    #################################################################
    # Autoreply
    #################################################################
    
    # Move spam to spam folder
    if header :contains "X-Spam-Flag" "YES" {
      fileinto "Junk";
      # Stop here so that we do not reply on spams
      stop;
    }
    vacation  :days 1
      :subject "Out of office reply"
      # :addresses ["test@test.int", "till@test.int"]
      "<tmpl_var name='autoresponder_text'>";
    </tmpl_if>
    
     
  3. nekr2005

    nekr2005 New Member

    Danke für die schnelle Antwort!

    Bei dem produktiven Server werde ich wohl die Lösung B
    nehmen, da ist es mir mit Distribution-Upgrade zu gefährlich.

    Habe hier aber auch einen Server mit ispconfig stehen,
    wo nur Test-Accounts drauf sind, da werde ich den Ditribution-Upgrade-Weg
    gehen, muss nur die Zeit noch dazu finden :)
     
  4. nekr2005

    nekr2005 New Member

    Inzwischen habe ich einen der ispconfig-Server auf Debian 6.0 aktualisiert.

    Es tut soweit, wie ich es auf die schnelle überprüft hab, alles.

    Auch die Mailfilter-Funktion funktioniert jetzt einwandfrei und
    die Sieve-Vorlage von der Version 3.0.4 ist wieder drin.

    Was jetzt nicht funktioniert, ist der Autoresponder.

    Der wird zwar einwandfrei gespeichert sowohl über Roundcube-Webmail
    als auch über admin-Interface, aber die Mails werden nicht beantwortet.

    Die Dateumsangaben werden auch einwandfrei in die Datei .sieve
    bei der jeweiligen Mailbox rein geschrieben. Diese sieht dann so aus:

    #####################################
    require ["fileinto", "regex", "date", "relational", "vacation"];





    #################################################################
    # Autoreply
    #################################################################

    # Move spam to spam folder
    if header :contains "X-Spam-Flag" "YES" {
    fileinto "Junk";
    # Stop here so that we do not reply on spams
    stop;
    }

    if allof(currentdate :value "ge" "date" "2011-11-21 19:25:00", currentdate :value "le" "date" "2011-11-23 00:00:00") {
    vacation :days 1
    :subject "Out of office reply"

    "TEST TEST TEST";
    }
    ###############################################

    Laut Log wird die auch verarbeitet, ich habe auch versucht da den
    Debug-Level hoch zu setzen, sehe ich aber auch da keinen Fehler:

    Info: Loading modules from directory: /usr/lib/dovecot/modules/lda
    Info: Module loaded: /usr/lib/dovecot/modules/lda/lib10_quota_plugin.so
    Info: Module loaded: /usr/lib/dovecot/modules/lda/lib90_sieve_plugin.so
    Info: auth input: home=/var/vmail/mail11.za-mail.de/sg
    Info: auth input: mail=maildir:/var/vmail/mail11.za-mail.de/sg/Maildir
    Info: auth input: uid=5000
    Info: auth input: gid=5000
    Info: auth input: quota_rule=*:storage=52428800B
    Info: auth input: sieve=/var/vmail/mail11.za-mail.de/sg/.sieve
    Info: Quota root: name= backend=maildir args=
    Info: Quota rule: root= mailbox=* bytes=52428800 messages=0
    Info: maildir: data=/var/vmail/mail11.za-mail.de/sg/Maildir
    Info: maildir++: root=/var/vmail/mail11.za-mail.de/sg/Maildir, index=, control=, inbox=/var/vmail/mail11.za-mail.de/sg/Maildir
    Info: sieve: using sieve path for user's script: /var/vmail/mail11.za-mail.de/sg/.sieve
    Info: sieve: opening script /var/vmail/mail11.za-mail.de/sg/.sieve
    Info: sieve: executing compiled script /var/vmail/mail11.za-mail.de/sg/.sieve
    Info: Namespace : Using permissions from /var/vmail/mail11.za-mail.de/sg/Maildir: mode=0700 gid=-1
    Info: sieve: msgid=<130F2C27E664804A844345513831274C03303FD0@EXCHSRV.zainternet.local>: stored mail into mailbox 'INBOX'

    Es wird laut Mail-Log nicht mal versucht die automatische Antwort zu versenden.

    Hat evtl. jemand eine Idee woran es liegen könnte?
     
  5. nowayback

    nowayback Well-Known Member

    Moinsen,

    Jepp... die Idee hatte wohl jemand... siehe -> FS#1681 : Out-of-Office too early

    Grüße
    nwb
     
  6. nekr2005

    nekr2005 New Member

    ok, danke für die Antwort.

    Es wird also, so wie es aussieht in 3.0.4.1 dann gefixt werden.

    Bei mir scheint es auch allein an den Datums-Angaben zu liegen,
    allerdings greift der Autoresponder später als gesetzt.
    (Gestern gesetzt - heute funktioniert der plötzlich)
    Setze ich den jetzt neu mit heutigem Datum - tut's wieder nicht

    Zeit/Datum vom Server stimmt.
     
  7. nekr2005

    nekr2005 New Member

    nur um das Ganze abzuschließen:

    Nach Upgrade auf 3.0.4.1 funktioniert auch die Abwesenheitsnotiz,
    so wie vermutet, jetzt einwandfrei :)
     

Diese Seite empfehlen