Singel Server nach Server Umzug in Multi Server?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von MegaBlue, 21. Jan. 2013.

  1. MegaBlue

    MegaBlue New Member

    Habe nun schon einiges hier gelesen und bin mir grad nicht sicher ob ich es
    richtig verstanden habe.

    Ist es möglich einen Server mit ISPConfig zu einem Multiserver zu machen
    und wenn ja was genau muss ich ab welchem schritt der Multiserver
    konfiguration machen?

    Gleichzeitig wird das alles dann auch noch auf einer neuen Maschiene
    gemacht wo ich für den Web / Master Server eine VM mit eindeutiger IP benutze und die restlichen sollen über einen Router mit internen IPs versorkt werden z.b. 10.0.0.2 - 5 .

    Der eigendliche Host ist ein ESXi 5.1.
    Die VM's alle unter Debian 6.

    Stellt das irrgendwelche Probleme dar?

    Mit freundlichem Gruß
    MegaBlue
     
  2. MegaBlue

    MegaBlue New Member

    So habe das nun so mal Umgesetzt habe aber scheinbar noch einige Fehler
    aber noch ka wo.
    Wie und wo werden die Datenbanken dann genau angelegt?
    Denke mal auf dem Datenbank Server!
    Wenn ich mich dort aber mit mysql einloge finde ich keine Datenbanken
    die ich angelegt habe.
    Daraufhin habe ich mich versucht per Mysqldumper anzumelden vom Master aus und bekamm folgende Meldung.

    Code:
    [COLOR=red]Host 'web.domain.tld' is not allowed to connect to this MySQL server[/COLOR] 
    Fehler bei der Anfrage:
    [COLOR=#990099][B]Database[/B][/COLOR] connection error: 
    
    Dachte bei der Installation wird da ein User eingetragen wie beim Master?

    Woran könnte es den liegen?

    Danke schonmal
     
  3. Till

    Till Administrator

    Das ist ok, denn in einem ispconfig setup meldet sich der master nicht beim slave an.

    Ein Multiservers etup funktioniert anders herum, der slave fragt in Regelmäßigen Abständen beim master nach ob es Änderungen gibt die ihn betreffen, ist das der fall so übernimmt der slave diese Änderungen ins eine lokale dbispconfig Datenbank und führt danach die notwendigen konfigurationsänderungen aus.

    Wenn die Synchronistaion fehlcshlägt dann liegt es in den meisten Fällen an einer fehlerhaften /etc/hosts Konfiguration auf Master oder Slave. im Multiserver Tutorial ist beschrieben wie diese xekat auszusehen hat bevor ispconfig installiert wird, ist die Datei vor der Installation nicht so angepasst worden dann kann sich mysql nachher nicht snchronisieren da der Login des ispcsrv Users vom slave aus beim Master fehl schlägt.

    Um das zu testen logge Dich auf der Shell des Slave ein, hole Dir die exakten Zugangsdaten für den Master aus der Datei /usr/local/ispconfig/server/lib/config.inc.php und versuche Dich per mysql Kommandozeilenbefehl vom slave aus in die mysql DB des masters einzuloggen.
     
  4. MegaBlue

    MegaBlue New Member

    Ok das hab ich nun soweit verstanden aber wie komme ich per Phpmyadmin
    auf die Userdatenbanken oder wie könnte ich mit Mysqldumper darauf zugreifen ohne eigendlich nen Webserver auf den db Server zu installieren?

    Danke
     
  5. Till

    Till Administrator

    phpmyadmin konfigurationsdatei auf dem webserver editeieren und eine Config Sektion für den dbserver einfügen. Phpmyadmin kann auf beliebig veiel DB Server zugreifen.

    Falls Du die Datenbanken mit ispconfig auf dem remote dn Server angelegt hast, dann muss die Ip des webserver bei erlaupte Ip adressen der DB eingefügt sein und der externe Zugang aktiviert werden.
     
  6. MegaBlue

    MegaBlue New Member

    Die Datenbanken hab ich alle frisch angelegt über den Webserver.
    Also meinst du das ich bei den Einstellungen der Datenbanken den Remote zugriff einschalten und die IP vom Webserver freigeben damit ich an diese ran
    komme?
     
  7. F4RR3LL

    F4RR3LL Member

    Jop so isses, irgendwie auch klar, wie soll der Webserver(phpmyadmin) auf weitere DB Server zugreifen wenn diese nur localhost aktzeptieren.

    Gruß Sven
     
  8. MegaBlue

    MegaBlue New Member

    Ich habe bei meinem Multiserver das Problem das die Email weiterleitung nicht funktioniert.

    hier der auszug aus dem Mail.log

    Sender = forward Empfänger

    Wenn ihr noch was braucht sagt bescheid!

    Code:
    Jan 25 00:10:01 mails dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Jan 25 00:10:01 mails dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Jan 25 00:10:01 mails postfix/smtpd[21443]: connect from localhost[127.0.0.1]
    Jan 25 00:10:01 mails postfix/smtpd[21443]: lost connection after CONNECT from localhost[127.0.0.1]
    Jan 25 00:10:01 mails postfix/smtpd[21443]: disconnect from localhost[127.0.0.1]
    Jan 25 00:15:01 mails dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Jan 25 00:15:01 mails dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Jan 25 00:15:01 mails postfix/smtpd[21559]: connect from localhost[127.0.0.1]
    Jan 25 00:15:01 mails postfix/smtpd[21559]: lost connection after CONNECT from localhost[127.0.0.1]
    Jan 25 00:15:01 mails postfix/smtpd[21559]: disconnect from localhost[127.0.0.1]
    Jan 25 00:15:09 mails postfix/smtpd[21559]: connect from mail-lb0-f173.google.com[209.85.217.173]
    Jan 25 00:15:09 mails postfix/smtpd[21559]: 8023F9D74D: client=mail-lb0-f173.google.com[209.85.217.173]
    Jan 25 00:15:09 mails postfix/cleanup[21605]: 8023F9D74D: message-id=<CALBQQWjwk9HVvp1erzvHaFKNqRKh+Kth1M+Y+-us1AfoSJtUug@mail.gmail.com>
    Jan 25 00:15:09 mails postfix/qmgr[25437]: 8023F9D74D: from=<name@gmail.com>, size=1742, nrcpt=1 (queue active)
    Jan 25 00:15:09 mails postfix/smtpd[21559]: disconnect from mail-lb0-f173.google.com[209.85.217.173]
    Jan 25 00:15:09 mails postfix/smtpd[21609]: connect from localhost[127.0.0.1]
    Jan 25 00:15:09 mails postfix/smtpd[21609]: C3D529D84F: client=localhost[127.0.0.1]
    Jan 25 00:15:09 mails postfix/cleanup[21605]: C3D529D84F: message-id=<CALBQQWjwk9HVvp1erzvHaFKNqRKh+Kth1M+Y+-us1AfoSJtUug@mail.gmail.com>
    Jan 25 00:15:09 mails postfix/qmgr[25437]: C3D529D84F: from=<name@gmail.com>, size=2186, nrcpt=1 (queue active)
    Jan 25 00:15:09 mails amavis[1709]: (01709-09) Passed CLEAN, [209.85.217.173] [209.85.217.173] <name@gmail.com> -> <admin@no-melody.de>, Message-ID: <CALBQQWjwk9HVvp1erzvHaFKNqRKh+Kth1M+Y+-us1AfoSJtUug@mail.gmail.com>, mail_id: vic2LUW8l0BE, Hits: -0.799, size: 1742, queued_as: C3D529D84F, 176 ms
    Jan 25 00:15:09 mails postfix/smtpd[21609]: disconnect from localhost[127.0.0.1]
    Jan 25 00:15:09 mails postfix/smtp[21606]: 8023F9D74D: to=<admin@no-melody.de>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.35, delays=0.16/0.01/0/0.18, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=01709-09, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as C3D529D84F)
    Jan 25 00:15:09 mails postfix/qmgr[25437]: 8023F9D74D: removed
    Jan 25 00:15:10 mails postfix/smtp[21610]: C3D529D84F: to=<name@gmail.com>, orig_to=<admin@no-melody.de>, relay=gmail-smtp-in.l.google.com[173.194.70.27]:25, delay=0.45, delays=0/0.01/0.1/0.33, dsn=2.0.0, status=sent (250 2.0.0 OK 1359069310 u2si20212212eeo.102)
    Jan 25 00:15:10 mails postfix/qmgr[25437]: C3D529D84F: removed
    

    Edit: Es geht doch gmail hat die nachrichten wieso auch immer gleich als gelesen makiert und archiviert und ich habe es nicht gesehen.
     
    Zuletzt bearbeitet: 25. Jan. 2013

Diese Seite empfehlen