SMTP funktioniert nicht von externem Netzwerk (SASL)

#1
Hallo,

Kurz zu meiner Konfiguration:
  • Ubuntu 18.04 Server
  • ISPConfig 3.1
  • Postfix
  • Dovecot
  • Roundcube
Weiteres
  • ISPConfig für HTTPS eingerichtet
  • Postfix / Dovecot soll verschlüsselte / unverschlüsselte Verbindungen zulassen
  • SSL Zertifikate sind konfiguriert und gültig

Ich habe folgendes Problem:
POP, IMAP, SMTP sei es unverschlüsselt / verschlüsselt funktionieren im internen Netzwerk mit jedem Emailclient ohne Probleme. Sobald ich extern verbinden will, fehlt die Verbindung beim SMTP Server immer fehl.
Die IpTables bzw Firewall-Konfiguration habe ich bereits kontrolliert, passt soweit Alles. Um auf Nummer sicher zu gehen haben ich den ganzen Verkehr auch einmal durchgelassen -> selbiges Problem
Dadurch wurde mir klar, dass es sich wahrscheinlich um ein Konfigurationsproblem handeln muss.

Folgendes ist in den Logs (/var/log/mail.log) bei einem Login Versuch über einen Emailclient aus dem externen Netzwerk zu sehen:
warning: unknown HOST[x.x.x.x]: SASL LOGIN authentication failed: UGFzc3dvcmQ6

Bei der Konfiguration des Servers entspricht hauptsächlich der vom HowToForge Tutorial.

Hat jemand eine Idee wodurch dieses Problem auftritt? Es scheint so als ob man für den SMTP - Server externe Netzwerke irgendwie zulassen muss.

Danke im Voraus!
 

Till

Administrator
#2
Im email client hast Du die vollständige Emailadresse als Login namen angegeben, prüf das bitte bochmal in den SMTP Einstellungen des client, einige clients wie thunderbird schneiden gern mal den Domain teil ungefragt ab.
 
#3
Im email client hast Du die vollständige Emailadresse als Login namen angegeben, prüf das bitte bochmal in den SMTP Einstellungen des client, einige clients wie thunderbird schneiden gern mal den Domain teil ungefragt ab.
Habe das erweiterte Logging eingeschaltet und tatsächlich wurde das Domain nicht mitgeschickt.

Das einzige Problem, das ich noch habe. Der SMTP sollte auch unverschlüsselt verfügbar sein. (Port25) Allerdings kommt die Fehlermeldung vom Client, dass der Server STARTTLS erfordert.

/etc/postfix/main.cf

smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
#smtpd_tls_auth_only=yes

Gibt es noch eine weitere Konfiguration, die ich übersehen habe?
 

Till

Administrator
#4
Schau mal bitte in die Postfix master.cf Datei, ich vermnute Du hast vergessen das # vor der smtps oder der submission Zeile zu entfernen wie im Tutorial beschrieben.
 
#5
Danke
Habe folgendes kommentiert
# -o smtpd_tls_wrappermode=yes
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticated,reject
 

Till

Administrator
#6
Das hatte ich nicht gemeint. Schau bitte mal die beiden Zeilen an die mit smtps und mit submission anfangen, vor denen drf kein # stehen.
 

Till

Administrator
#8
Ok, dann ist auf port 25 aber kein ssl sondern nur auf port 587 und dem smtps port und dort soll es ja auch aktiv sein.
 

Till

Administrator
#10
Die Zeilen die Du auskommentiert hast stehen aber nicht bei port 25 (smtp) sondern be smtps, also wirken sie sich auch nicht auf port 25 aus. Ausnahme ist wenn man vergisst das # vor smtps und submission zu entfernen. Was Du gemacht hast ist SSL auf dem smtps und nicht smtp port auszuschalten, denn auf dem smtp port ist es laut dieser master.cf nicht aktiv.
 

Werbung

Top