Smtp-login schlägt fehlt - ISPconfig3

#1
Hi,

Server: Ubuntu 10.04 mit ISPConfig 3 Perfect Setup :(

Imap-Login funktioniert, mails per Webmail senden auch, aber smtp-auth schlögt fehl:
/var/log/mail:
Nov 5 13:03:16 Server postfix/smtpd[4181]: warning: SASL authentication failure: Password verification failed
Nov 5 13:03:16 Server postfix/smtpd[4181]: warning: lacal[888.888.888.888]: SASL PLAIN authentication failed: authentication failure
Nov 5 13:03:16 Server postfix/smtpd[4181]: warning:local[888.88.888.88]: SASL LOGIN authentication failed: authentication failure
In der auth.log:
Nov 5 13:34:071 postfix/smtpd[5664]: sql_select option missing
Nov 5 13:34:07 postfix/smtpd[5664]: auxpropfunc error no mechanism available
Nov 5 13:34:07 postfix/smtpd[5664]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
main.cf:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = hostname
alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
myorigin = /etc/mailname
mydestination = hostname, localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
html_directory = /usr/share/doc/postfix/html
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_tls_security_level = may
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
smtpd_client_message_rate_limit = 100
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = maildrop
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
owner_request_special = no
dovecot_destination_recipient_limit = 1
#smtpd_sasl_type = cyrus
smtpd_sasl_path = private/auth
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
message_size_limit = 0
Module sind alle da, habe alle nochmal händisch nachinstalliert. Bin ratlos..

Gruß

Arne
 
Zuletzt bearbeitet:

Till

Administrator
#2
Das ist je eine ziemlich alte Ubuntu Version, es kann sein dass sich die sasl config syntax inzwischen geändert hat und Dein Server noch nicht die neue Syntax unterstützt. Poste bitte mal die Ausgabe von:

/etc/postfix/sasl/smtpd.conf
 
#3
smtp.conf

Hier die smtp.conf. Ich finde die sieht gut aus ;)

pwcheck_method: saslauthd
mech_list: plain login
allow_plaintext: true
auxprop_plugin: mysql
sql_hostnames: 127.0.0.1
sql_user: ispconfig
sql_passwd: passwort
sql_database: dbispconfig
sql_select: select password from mail_user where login = '%u'
Aber vielleicht siehst Du ja mehr... Hätte ich mal bei CentOs bleiben sollen, aber da war alles noch schlimmer... ;)

Gruß
Arne
 
#4
... Zustand davor

Hallo Till,

vielleicht sollte ich noch dazuschreiben, dass ich zuerst einen fehler hatte, er würde die /etc/sasl2db nicht finden, die habe ich dann in /var/spool/postfix/etc kopiert um die jetzige Fehlermeldung zu erhalten...

Möglicherweise liegt auch da der Hase im Pfeffer... Warum er da reinschauen will, erschließt sich mir allerdings nicht, die ist ziemlich alt und kann neue User eigentlich nicht enthalten.

Gruß

Arne
 

Till

Administrator
#5
Aber vielleicht siehst Du ja mehr... Hätte ich mal bei CentOs bleiben sollen, aber da war alles noch schlimmer...
Ubuntu ist schon deutlich besser als centos, waber warum hast Du so ein uraltes Ubuntu genommen? Wenn Du jetzt einen neuen Windows Rechner installieren würdest dann würdest Du ja auch nicht Windows 98 nehmen :)

vielleicht sollte ich noch dazuschreiben, dass ich zuerst einen fehler hatte, er würde die /etc/sasl2db nicht finden, die habe ich dann in /var/spool/postfix/etc kopiert um die jetzige Fehlermeldung zu erhalten...
Diese Datei wird auf einem ISPConfig Server weder verwendet noch benötigt, auch da manuelle umkopieren von Dateien ist nicht notwendig wenn es nicht in der Installationsanleitung steht.

Der Server war aber "leer" bevor ispconfig nach dem Tutorial installiert wurde,es war also kein anderes Controlpanel vorher dort installiert?
 
#6
leer...

Hallo Till,

ja war er, kein Controlpanel. Nur eine Grundinstallation von Ubuntu, bei dem ich das Dovecot entfernt habe, weil Dein howto auf courier ausgerichtet war...

die alte ubuntu-version habe ich genommen, weil es bei server4you keine andere gibt und ich dafür ein howto gefundem habe... Nun kann ich auhc nicht wieder zurück, ich habe schon diverse Domains drauf, die ich von einer ispconfig2 installtion rüberhole, weil der server abgeschaltet wird. die haben aber bisher nur mailumleitungen bzw. Adressen die hier den lokalen mailserver zum versand nutzen., deswegen war das nicht aufgefallen.

ich mache die datei mal wieder weg und gebe die neue fehlermeldung durch.

gruß
Arne
 
Zuletzt bearbeitet:
#7
ohne kopierte datei

Hallo Till,

ohne die hinkopierte datei kommt zwischen der PLAIN und LOGIN zeile noch

Nov 5 17:34:09 SERVER postfix/smtpd[16142]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Nov 5 17:34:09 SERVER postfix/smtpd[16142]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
sonst ändert sich nix...

Gruß
Arne
 

Till

Administrator
#8
generell funktioniert das natürlich auch mit der alten Version, kriegen wir schon hin :) Poste mal bitte die postfix main.cf Datei (hostnamen unkenntlich machen) und gibt es noch weitere Fehlermeldungen im mail.log?
 
#9
weiter im text

main.cf s.oben ;)

Fehler, das hier ist alles, was beim loginversuch mit thunderbird im mail log passiert:
HTML:
Nov  5 18:35:26 SERVER postfix/smtpd[18501]: warning: xxx: SASL PLAIN authentication failed: authentication failure
Nov  5 18:35:26 SERVER postfix/smtpd[18501]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Nov  5 18:35:26 SERVER postfix/smtpd[18501]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Nov  5 18:35:26 SERVER postfix/smtpd[18501]: warning:xxx: SASL LOGIN authentication failed: authentication failure
SERVER=hostname, XXX= name und ip meines internetanschlusses

Irgendwie scheint der ja die Anweisung Pam zu nutzen fiese zu ignorieren.. die msql-geschichte in der auth.log kann man wohl vernachlässigen denke ich, oder?

Gruß
Arne
 
#10
/etc/default/saslauthd

Zur Vollständigkeit:

#
# Settings for saslauthd daemon
# Please read /usr/share/doc/sasl2-bin/README.Debian for details.
#

# Should saslauthd run automatically on startup? (default: no)
START=yes

# Description of this saslauthd instance. Recommended.
# (suggestion: SASL Authentication Daemon)
DESC="SASL Authentication Daemon"

# Short name of this saslauthd instance. Strongly recommended.
# (suggestion: saslauthd)
NAME="saslauthd"

# Which authentication mechanisms should saslauthd use? (default: pam)
#
# Available options in this Debian package:
# getpwent -- use the getpwent() library function
# kerberos5 -- use Kerberos 5
# pam -- use PAM
# rimap -- use a remote IMAP server
# shadow -- use the local shadow password file
# sasldb -- use the local sasldb database file
# ldap -- use LDAP (configuration is in /etc/saslauthd.conf)
#
# Only one option may be used at a time. See the saslauthd man page
# for more information.
#
# Example: MECHANISMS="pam"
#MECHANISMS="pam"
MECHANISMS="pam"

# Additional options for this mechanism. (default: none)
# See the saslauthd man page for information about mech-specific options.
MECH_OPTIONS=""

# How many saslauthd processes should we run? (default: 5)
# A value of 0 will fork a new process for each connection.
THREADS=5

# Other options (default: -c -m /var/run/saslauthd)
# Note: You MUST specify the -m option or saslauthd won't run!
#
# WARNING: DO NOT SPECIFY THE -d OPTION.
# The -d option will cause saslauthd to run in the foreground instead of as
# a daemon. This will PREVENT YOUR SYSTEM FROM BOOTING PROPERLY. If you wish
# to run saslauthd in debug mode, please run it by hand to be safe.
#
# See /usr/share/doc/sasl2-bin/README.Debian for Debian-specific information.
# See the saslauthd man page and the output of 'saslauthd -h' for general
# information about these options.
#
# Example for postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
 
#11
Support kaufen

kann man bei Euch eigentlich Support käuflich erwerben? Das scheint mir ne schwere Geburt zu werden ;). Und ob ich meine Arbeit nicht schaffe oder euch dafür bezahle und derweil weitermache bleibt sich eigentlich gleich...

Gruß
Arne
 

Till

Administrator
#12

Werbung