Spam wird nicht mehr gelöscht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von s.rose, 29. Apr. 2008.

  1. s.rose

    s.rose New Member

    Moin,

    nach dem Update von ClamAV, wie in http://www.howtoforge.de/forum/showthread.php?t=485 beschrieben, erhalten die Benutzer wieder allen Spam, der vorher so wundervoll gefiltert wurde. Woran kann das liegen?

    EDIT:
    Klar, wenn man gleichzeitig den Haken bei 'Use URILib' macht und keine Liste angibt, wird SPAM nicht mehr erkannt - und folglich nicht gelöscht :-/

    Sorry.
     
    Zuletzt bearbeitet: 29. Apr. 2008
  2. s.rose

    s.rose New Member

    Problem bleibt

    Das Spam-Problem beibt mir leider erhalten. Nach dem Entfernen des Häckchens hinter 'Use URIBL:' kommt weiterhin viel Spam. Leider ist auch die Benutzung von URIBL so garnicht dokumentiert. Wo stelle ich denn die zu benutzende Blacklist ein?
     
  3. Till

    Till Administrator

    Es werden die Listen von uribl.com benutzt (siehe Link URIBL vor der Checkbox).

    Poste bitte mal den Inhalt der datei .procmailrc aus dem Home Verzeichnis des Users und den Inhalt der .spamassassin.rc Datei.
     
  4. s.rose

    s.rose New Member

    ~/.procmailrc
    Code:
    MAILDIR=$HOME/Maildir/
    DEFAULT=$MAILDIR
    ORGMAIL=$MAILDIR
    
    INCLUDERC=/var/www/web1/user/username/.mailsize.rc
    ## INCLUDERC=/var/www/web1/user/username/.quota.rc
    INCLUDERC=/var/www/web1/user/username/.antivirus.rc
    ## INCLUDERC=/var/www/web1/user/username/.local-rules.rc
    ## INCLUDERC=/var/www/web1/user/username/.html-trap.rc
    INCLUDERC=/var/www/web1/user/username/.spamassassin.rc
    ## INCLUDERC=/var/www/web1/user/username/.autoresponder.rc
    
    /var/www/web1/user/username/.spamassassin.rc
    Code:
    
    # SpamAssassin sample procmailrc
    #
    # Pipe the mail through spamassassin (replace 'spamassassin' with 'spamc'
    # if you use the spamc/spamd combination)
    # The condition line ensures that only messages smaller than 250 kB
    # (250 * 1024 = 256000 bytes) are processed by SpamAssassin. Most spam
    # isn't bigger than a few k and working with big messages can bring
    # SpamAssassin to its knees.
    :0fw
    * < 256000
    | /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --prefs-file=/var/www/web1/user/username/.user_prefs
    
    # Mails with a score of 15 or higher are almost certainly spam (with 0.05%
    # false positives according to rules/STATISTICS.txt). Let's put them in a
    # different mbox. (This one is optional.)
    #:0:
    #* ^X-Spam-Level: \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*
    #/dev/null
    
    # All mail tagged as spam (eg. with a score higher than the set threshold)
    # is moved to "/dev/null".
    :0:
    * ^X-Spam-Status: Yes
    /dev/null
    
    # Work around procmail bug: any output on stderr will cause the "F" in "From"
    # to be dropped.  This will re-add it.
    :0
    * ^^rom[ ]
    {
      LOG="*** Dropped F off From_ header! Fixing up. "
    
      :0 fhw
      | sed -e '1s/^/F/'
    }
    
    Beide Dateien werden von ISPConfig auch immer brav neu geschrieben, wenn ich etwas an den Maileinstellungen ändere.
     
  5. Till

    Till Administrator

    Steht denn beid en Spam Emails im Header:

    X-Spam-Status: Yes
     
  6. s.rose

    s.rose New Member

    Nein :-(
    Kein solcher Header...
     
  7. Till

    Till Administrator

    Dann wurde die Mail auch nicht als Spam erkannt, dein Problem liegt also nicht im Löschen von Spam sondern in der Erkennung von Spam. Setzt doch mal den Score von spamassassin runter.
     
  8. s.rose

    s.rose New Member

    Danke erstmal Till

    OK - habe das getan. Danke für die Geduld ;-)
     

Diese Seite empfehlen