SquirrelMail über https:// zeigt nur den PHP Quelltext im Browser an

wlbi

New Member
#1

wlbi

New Member
#3
Installiert ist es:
Code:
# dpkg -l | grep mod-php
ii  libapache2-mod-php5  5.5.9+dfsg-1ubuntu4.4  amd64  server-side, HTML-embedded scripting language (Apache 2 module)
Wo sollte man das zusätzlich aktivieren?
 
#4
trage mal in der Squirrel Apache conf noch das ein , zwischen <IfModule mod_php5.c> und </IfModule>
Code:
<FilesMatch ".+\.php$">
SetHandler application/x-httpd-php
</FilesMatch>
und mach dann ein apache2ctl restart
 

wlbi

New Member
#5
Das ist jetzt etwas verwirrend.
Es gibt nur eine Datei die diese Stelle beinhaltet:
Code:
grep -r "IfModule mod_php5.c" /etc/apache2/*
/etc/apache2/sites-available/apps.vhost:  <IfModule mod_php5.c>
Ich denke das ist nicht der richtige Platz dafür, zumal es dort auch nicht funktioniert.
vi /etc/apache2/sites-available/apps.vhost
Code:
  <IfModule mod_php5.c>
    DocumentRoot /var/www/apps
    AddType application/x-httpd-php .php
    <Directory /var/www/apps>
                Options FollowSymLinks
                AllowOverride None
                                Require all granted
                    </Directory>

<FilesMatch ".+\.php$">
SetHandler application/x-httpd-php
</FilesMatch>

  </IfModule
Habe dann in der /etc/apache2/apache2.conf einen zusätzlichen Eintrag am Dateiende erstellt:
Code:
<IfModule mod_php5.c>
<FilesMatch ".+\.php$">
SetHandler application/x-httpd-php
</FilesMatch>
</IfModule>
Apache neu gestartet, aber auch das blieb Erfolglos und der Quelltext wird zum Download angezeigt.
Hab ich jetzt was falsch verstanden?
 

wlbi

New Member
#7
Habe nichts bearbeitet, sondern das mit dem Script https://github.com/dclardy64/ISPConfig-3-Debian-Installer/tarball/master installiert.
Die Datei /etc/apache2/mods-available/suphp.conf hat folgenden Inhalt:
Code:
<IfModule mod_suphp.c>
    #<FilesMatch "\.ph(p3?|tml)$">
    #    SetHandler application/x-httpd-suphp
    #</FilesMatch>
        AddType application/x-httpd-suphp .php .php3 .php4 .php5 .phtml
        suPHP_AddHandler application/x-httpd-suphp

    <Directory />
        suPHP_Engine on
    </Directory>

    # By default, disable suPHP for debian packaged web applications as files
    # are owned by root and cannot be executed by suPHP because of min_uid.
    <Directory /usr/share>
        suPHP_Engine off
    </Directory>

# # Use a specific php config file (a dir which contains a php.ini file)
#       suPHP_ConfigPath /etc/php5/cgi/suphp/
# # Tells mod_suphp NOT to handle requests with the type <mime-type>.
#       suPHP_RemoveHandler <mime-type>
</IfModule>
und die Datei /etc/suphp/suphp.conf
Code:
[global]
;Path to logfile
logfile=/var/log/suphp/suphp.log

;Loglevel
loglevel=info

;User Apache is running as
webserver_user=www-data

;Path all scripts have to be in
docroot=/var/www:${HOME}/public_html

;Path to chroot() to before executing script
;chroot=/mychroot

; Security options
allow_file_group_writeable=false
allow_file_others_writeable=false
allow_directory_group_writeable=false
allow_directory_others_writeable=false

;Check wheter script is within DOCUMENT_ROOT
check_vhost_docroot=true

;Send minor error messages to browser
errors_to_browser=false

;PATH environment variable
env_path="/bin:/usr/bin"

;Umask to set, specify in octal notation
umask=0022

; Minimum UID
min_uid=100

[handlers]
;Handler for php-scripts
application/x-httpd-suphp="php:/usr/bin/php-cgi"

;Handler for CGI-scripts
x-suphp-cgi="execute:!self"
x-httpd-suphp="php:/usr/bin/php-cgi"
 

wlbi

New Member
#9
Code:
# a2enmod php5
Module php5 already enabled
Das ist ein Server bei server4you. Da war schon Ubuntu 14.04 minimal vorinstalliert.
Dann wie schon geschrieben, mit diesem Script https://github.com/dclardy64/ISPConfig-3-Debian-Installer/tarball/master
ISPConfig installiert.
PHP funktioniert ja an sich, nur eben Squirrelmail nicht über die gesicherte Verbindung.
https://triton707.startdedicated.de:8080/webmail/src/login.php

Habe gerade eine Datei angelegt:
/usr/local/ispconfig/interface/web/info.php
und das funktioniert über https.
https://triton707.startdedicated.de:8080/info.php
Ich schätze, dass es irgend wie an einem Alias zu squirrelmail liegt.
 
#12
aktuell nutze ich noch kein SSL, bzw. habe ich die 8080/8081 aus meiner ispconfig.vhost entfernt und ruf das Panel direkt über Port 80 auf, da die SSL-Verschlüsselung nachträglich über Port 443 mit richtigen Zertifikaten noch kommt.
Dennoch hatte ich das Problem, das ich die suphp.conf Einstellungen im Howto übersehen hatte und deshalb der PHPMyAdmin bei mir nicht ging.
Willst du unbedingt Squirrelmail nutze, oder doch lieber Roundcude?
 

wlbi

New Member
#13
Roundcube sieht auch ganz schick aus. :D
Habe eben die letzten über 10 Jahre Squirrelmail verwendet, daher.
Das ist aber eine sehr gute Idee und Gelegenheit zu Roundcube zu wechseln, bei einem neuen Server....
So auf den ersten Blick sieht das echt gut aus und ich denke es bietet auch mehr Möglichkeiten. Muss es mal antesten.
Hast du das bei dir installiert? Kennst du dafür eine nette Installationsanleitung in Verbindung mit Ubuntu und ISPConfig?
 

Werbung

Top