SSI - Zertifikat zum Start erforderlich?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von sanadorm, 24. Dez. 2013.

  1. sanadorm

    sanadorm New Member

    Hallo

    Wenn ich versuche ISPConfig 3 zu erreichen kam eine Fehlerseite im Textformat.
    Also nach Suchen kam raus, dass ein Zertifikat eingebaut werden muss, damit ISPConfig mit https://.... erreichbar ist und die Seite in html dargestellt wird.

    Da ich aber die Anmeldung mit dem für etwa 10 Sekunden Fehlermeldung "Wir müssen Ihre Daten überprüfen" beendet wurde, habe ich vielleicht die Chance ISPConfig erst im neuen Jahr bearbeiten zu können.

    Ich habe bereits gesucht, aber nichts dazu gefunden.

    Es könnte sein, dass bei der Angabe der Adresse keine Hausnummer vor kommt.
    Meine Adresse hat keine Hausnummer. Das Haus hat einen Namen in einem Ort. Die Straße hat keinen Namen.

    Gruß und Schöne Weihnachten Antonius

    Sorry falsche Rubrik. Gehört eigentlich unter selben Rubrik unter ISPConfig.
     
    Zuletzt bearbeitet: 24. Dez. 2013
  2. nowayback

    nowayback Well-Known Member

    ispconfig erstellt bei der installation ein selbstsigniertes zertifikat womit der aufruf per https dann auch funktioniert.

    Bitte verwende eine aktuelle distribution und benutze als ausgangssituation ein perfect server setup wie in den vielen anleitungen beschrieben. Dann bleiben dir viele Probleme erspart.

    Grüße
    nwb
     
  3. sanadorm

    sanadorm New Member

    Hallo

    Danke und frohe Weihnachten.

    Ich habe Ubuntu 10.04 auf dem Server., ein Update ist nicht möglich.
    Ich will dazu die aktuelle Version von ISPConfig installieren.
    Beschrieben wird aber die Installation mit einer alten ISPConfig, es wird aber das aktuelle herunter geladen.
    Dann habe ich Kapazitätsprobleme und pure-ftpd kann nicht installiert werden.
    Nachdem das alles aber fertig war, wurde Fehler 400 angezeigt.
    Dazu gab es die Antwort, dass SSL installiert werden muss.
    Bei der Installation von SSL wird zur Verifizierung einer Domain, für die das Zertifikat sein soll, eine E-Mail verlangt. Leider habe ich kein ISPConfig installiert mit dem ich eine E-Mail bereit stellen kann.

    Es sind einfach zu viele Fehler die da beschrieben und gemacht werden.
    Ich bin nun etwa zwei Woche beim Versuch ISPConfig zu installieren.

    Mein var/www/... sieht so aus.
    /var/www/apps/
    /var/www/ispconfig/
    /var/www/php-fcgi-scripts/
    /var/www/webalizer/
    /var/www/webmail/
    /var/www/index.html

    Es gibt auch ein anderes Thema von mir.

    Gruß Antonius
     
    Zuletzt bearbeitet: 25. Dez. 2013
  4. nowayback

    nowayback Well-Known Member

    hi,

    dir auch ein frohes fest :)

    Warum ist das nicht möglich? apt-get do-release-upgrade sollte doch funktionieren oder nicht?

    natürlich wird das aktuelle geladen und genau dieses sollte auch verwendet werden. Die konfiguration der Dienste übernimmt ispconfig ja dann.

    Welche Probleme hast du? Zu wenig Ram? Dann dann denk drüber nach amavis wegzulassen. Andere Probleme kann ich mir beim FTP Server nicht wirklich vorstellen

    ISPConfig erzeugt bei der Installation ein Zertifikat. Dabei wirst du nach einer E-Mail Adresse gefragt. Diese E-Mail Adresse braucht noch nicht zu existieren, denn es wird nix da hin geschickt. Es ist einfach nur für das Zertifikat erforderlich. Wenn du irgendwann ein Zertifikat von Startssl oder irgendeiner anderen Zertifizierungsstelle haben willst, dann kannst du das auch noch nachträglich machen wenn erstma alles läuft.

    Im Laufe der Zeit ändern sich nun mal einige Pakete und genau deshalb hab ich dir eine aktuelle Version empfohlen bei der du dich auch problemlos an das Perfect Server Setup halten kannst.

    Zur Zeit sind alle Glaskugeln am Nordpol, sonst hätte der Weihnachtsmann es einfach nicht geschafft die richtigen Geschenke zu erraten. Bis wir die wieder haben musst du uns also einfach schreiben wo genau es hakt, ggf. mit entsprechenden Logfileauszügen, dann gibts da bestimmt auch einen Weg :)

    Schöne Feiertage
    nwb
     
  5. sanadorm

    sanadorm New Member

    Den Befahl zum upgrade nimmt er schon an.

    HTML:
    sudo apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Setting up pure-ftpd-mysql (1.0.24-1) ...
    Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -b -D -E -8 UTF-8 -u 1000 -A -H -O clf:/var/log/pure-ftpd/transfer.log -B
    421 Unable to switch capabilities : Operation not permitted
    invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
    dpkg: error processing pure-ftpd-mysql (--configure):
     subprocess installed post-installation script returned error exit status 252
    Errors were encountered while processing:
     pure-ftpd-mysql
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Er kann Ihn aber nicht ausführen.
    Ich denke aber den Server neu zu installieren und dann nochmal versuchen.

    Gruß Antonius
     
  6. nowayback

    nowayback Well-Known Member

    hi,

    Ich denke auch dass das besser wäre, bei dem was du schon alles geändert haben könntest.

    grüße
    nwb
     
  7. sanadorm

    sanadorm New Member

    Es scheint nicht zu gehen.

    apt-get update
    apt-get upgrade
    apt-get install update-manager-core
    do-release-upgrade


    PHP:
    Checking for new ubuntu release
    Done Upgrade tool signature
    Done Upgrade tool
    Done downloading
    authenticate 
    'precise.tar.gz' against 'precise.tar.gz.gpg'
    extracting 'precise.tar.gz'
    WARNING:root:estimate_kernel_size_in_boot() returned '0'?
    The upgrade has abortedYour system could be in an unusable stateA
    recovery will run now 
    (dpkg --configure -a).

    Please report this bug in a browser at
    http
    ://bugs.launchpad.net/ubuntu/+source/update-manager/+filebug and
    attach the files in /var/log/dist-upgradeto the bug report.
    installArchives() failed

    dpkg
    dependency problems prevent configuration of libnih-dbus1:
     
    libnih-dbus1 depends on libnih1 (= 1.0.3-4ubuntu9.1); however:
      
    Version of libnih1 on system is 1.0.1-1.
    dpkg
    error processing libnih-dbus1 (--configure):
     
    dependency problems leaving unconfigured
    Errors were encountered 
    while processing:
     
    libnih-dbus1

    Upgrade complete

    The upgrade has completed but there were errors during the upgrade
    process
    .

    To continue please press [ENTER]
    === 
    Command detached from window (Wed Dec 25 16:40:54 2013) ===

    Den Bug habe ich mit allen Protokollen http://bugs.launchpad.net/ubuntu/ source/u...... Beim Abschicken gab es einen Fehler und dann war alles weg.
    Leider habe ich auch vergessen es vor dem Abschicken zu kopieren.

    Kann von jedem den Inhalt oder Teile kopieren.
    /var/log/dist-upgrade/apt-term.log (74B)
    /var/log/dist-upgrade/apt.log (320KiB)
    /var/log/dist-upgrade/history.log (0)
    /var/log/dist-upgrade/main.log (18 KiB
    /var/log/dist-upgrade/screenlog.0 (7,5 KiB)
    /var/log/dist-upgrade/xorg_fixup.log (13,%KiB)

    kernel: 2.6.18-028stab101.1
    hostname: schöne_weihnachten.de
    arch: amd64
    uname_arch: x86_64

    Gruß Antonius
     
  8. nowayback

    nowayback Well-Known Member

    is das ein openvz server? wenn ja welche libc ist installiert?

    es gab/gibt da glaub ich ein prob mit dem zusammenspiel mitm kernel... ich kram mal meine bookmarks durch. da war irgendwo ne lösung dabei...

    *** edit ***
    Code:
    apt-add-repository ppa:izx/ovz-libc
    apt-get update
    apt-get -f install
    do-release-upgrade
    
    Quelle: http://askubuntu.com/questions/1257...-not-found-or-libc6-or-requires/130717#130717

    *** Edit Ende ***
     
    Zuletzt bearbeitet: 25. Dez. 2013
  9. sanadorm

    sanadorm New Member

    [FONT=Arial, serif]Moin

    apt-add-repository ppa:izx/ovz-libc
    (-bash: apt-add-repository: command not found)
    Kann ich nicht ausführen
    Auch nicht in anderen Variationen
    apt-get sudo apt-add apt add re...
    Immer wird eine Funktion als nicht existent verweisgert.

    Auch nicht nach:
    apt-get install update-manager-core
    und
    apt-get update

    Damit ich apt-add ausführen kann, muss das her.
    sudo apt-get install apt-file && apt-file update
    (-bash: apt-add-repository: command not found)
    Aber das stimmt nicht

    sudo apt-get install python-software-properties
    [/FONT] [FONT=Arial, serif]
    PHP:
    gpgkeyring `/tmp/tmpm1Qqbo/secring.gpg' created
    gpg: keyring 
    `/tmp/tmpm1Qqbo/pubring.gpg' created
    gpg: requesting key BFAB4BD9 from hkp server keyserver.ubuntu.com
    gpg: /tmp/tmpm1Qqbo/trustdb.gpg: trustdb created
    gpg: key BFAB4BD9: public key "Launchpad PPA for Ishaan Dalal" imported
    gpg: Total number processed: 1
    gpg: imported: 1 (RSA: 1)
    apt-get -f install
    PHP:
    Reading package lists... Done
    Building dependency tree
    Reading state information
    ... Done
    0 upgraded
    0 newly installed0 to remove and 7 not upgraded.
    [/FONT] [FONT=Arial, serif]do-release-upgrade
    E: Invalid operation do-release-upgrade

    apt-get install update-manager-core
    ok

    do-release-upgrad
    PHP:
    .....The upgrade has completed but there were errors during the upgrade
    process
    .....
    Auch nach einer Neuinstallation hat es nicht geklappt.

    Ich habe jetzt einmal
    [/FONT][FONT=Arial, serif]Debian 6.0 / Minimal / 64 bit installiert.
    Alternativ kann ich auch
    [/FONT][FONT=Arial, serif]Debian 6.0 / Lighttpd / 64 bit installieren.

    Zu Debian 6 gehört ISPConfig 3. Ich hoffe das es mit der Anleitung besser klappt.

    Antonius
    [/FONT]
     
  10. nowayback

    nowayback Well-Known Member

    bei ubuntu gehört halt immer ein sudo dazu... aber wenn du nun debian hast, dann füge die wheezy repos mit hinzu und update erstma auf debian 7, dann ispconfig nach perfect server setup installieren.

    Bei welchem Anbieter bist du denn das du ispconfig vorinstalliert hast? etwa ovh? Die haben ne alte ispconfig version. wenn du das vorinstallierte nutzen willst, dann auch erst debian updaten, danach ispconfig updaten.

    Grüße
    nwb
     
  11. sanadorm

    sanadorm New Member

    Hallo

    Ich werde morgen das angebotene, Name vergessen (nicht Plesk) nehmen, da ich einiges zu tun habe in der nächsten Zeit.

    Gruß und Dank Antonius
     

Diese Seite empfehlen