SSL Fehlercode -12263

#1
Hallo,

habe da noch zwei Probleme...
1. bei Aufruf von "https://" Seiten bekomme ich nur die Fehlemeldung

"...falsche oder unerwartete Nachricht gesendet. Fehlercode: -12263

2. wird bei jedem Aufruf einer .php Seite folgender Fehler in die /var/log/apache2/error.conf geschrieben

[Fri Dec 07 11:16:03 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
PHP Warning: Module 'json' already loaded in Unknown on line 0

[Fri Dec 07 11:16:06 2007] [notice] Apache/2.2.3 (Ubuntu) PHP/5.2.1 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations

[Fri Dec 07 11:16:09 2007] [notice] caught SIGTERM, shutting down

[Fri Dec 07 11:16:19 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
PHP Warning: Module 'json' already loaded in Unknown on line 0
[Fri Dec 07 11:16:20 2007] [notice] Apache/2.2.3 (Ubuntu) PHP/5.2.1 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
[Fri Dec 07 11:20:58 2007] [error] an unknown filter was not added: PHP
[Fri Dec 07 11:20:58 2007] [error] an unknown filter was not added: PHP
[Fri Dec 07 11:21:00 2007] [error] an unknown filter was not added: PHP
[Fri Dec 07 11:21:00 2007] [error] an unknown filter was not added: PHP
[Fri Dec 07 11:21:06 2007] [error] an unknown filter was not added: PHP
[Fri Dec 07 11:21:06 2007] [error] an unknown filter was not added: PHP
[Fri Dec 07 11:21:07 2007] [error] an unknown filter was not added: PHP
[Fri Dec 07 11:21:07 2007] [error] an unknown filter was not added: PHP
[Fri Dec 07 11:21:08 2007] [error] an unknown filter was not added: PHP
 

Till

Administrator
#2
1) http://www.mozilla.org/projects/security/pki/nss/ref/ssl/sslerr.html

Vermutlich hast Du beim Erstellen des SSL-Zertifikats etwas eingegeben, was nach der Spezifikation nicht erlaubt ist. Leg das Zertifikat am besten nochmal neu an.

2) Ändere die Einstellung für den PHP Modus in der Datei /home/admispconfig/ispconfig/lib/config.inc.php con "both" auf "addtype". Danach musst Du die Einstellungen eines beliebigen Webs in ISPConfig ändern und auf speichern klicken.
 
#3
Habe nun den install_config Ordner gelöscht, neu entpackt und das ./setup ausgeführt.
Somit wurden ja auch die Zertifikate neu erstellt, oder :confused:

Jedenfalls kommt immer noch die beschriebene Fehlermeldung...

Der zweite Fehler ist erledigt.

Hier nochmal der Apache2 log "error.conf" nach reboot:

[Fri Dec 07 13:29:33 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Fri Dec 07 13:29:35 2007] [notice] Apache/2.2.3 (Ubuntu) PHP/5.2.1 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
[Fri Dec 07 13:29:38 2007] [notice] caught SIGTERM, shutting down
[Fri Dec 07 13:29:49 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Fri Dec 07 13:29:49 2007] [notice] Apache/2.2.3 (Ubuntu) PHP/5.2.1 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
 

Till

Administrator
#4
Der Fehler hat mit ISPConfig und dem ISPConfig Installer überhaupt nichts zu tun. Es handelt sich um einen Fehler im "Haupt" Apache Webserver und nicht im Webserver von ISPConfig. Du musst also einfach das SSL Zertifikat in den Webseiten Einstellungen der Webseite in ISPConfig neu erzeugen.
 

Till

Administrator
#6
Das hat mit Code nichts zu tun. Loggg Dich in ISPConfig ein, gehe zur entsprechenden Webseite, wechsel auf das SSL Tab, gib die Daten für das SSL Cert ein, wähle als aktion dass Du das Cert erzeugen möchtest und klicke auf speichern.
 

Werbung

Top