SSL Keine Verbindung - SSLSessionCache?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von bts_freak, 16. Sep. 2010.

  1. bts_freak

    bts_freak New Member

    Hi!

    Ich habe ISP Config 3.0.2.2 auf Suse.
    http der Seite funktioniert super.
    https: hat keine Verbindung.
    IP Adresse ist richtig eingerichtet in Systemeinstellungen (kein (*))

    SSL Section in der vhost Datei sieht gut aus.
    Zertifikatdateien in /ssl Folder auch.

    netstat -tap zeigt allerdings, dass apache nicht auf https lauscht.

    a2enmod ssl sagt "ssl already present".

    error_log sagt beim Neustart:
    [Thu Sep 16 07:16:29 2010] [notice] caught SIGTERM, shutting down
    [Thu Sep 16 07:16:30 2010] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Thu Sep 16 07:16:30 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php5/extensions/xsl.so' - /usr/lib64/php5/extensions/xsl.so: undefined symbol: dom_node_class_entry in Unknown on line 0
    [Thu Sep 16 07:16:30 2010] [notice] Apache/2.2.13 (Linux/SUSE) mod_ssl/2.2.13 OpenSSL/0.9.8k PHP/5.3.2 configured -- resuming normal operations

    Kann es was mit dem SSLSessionCache zu tun haben? Die in der Config definierte Datei existiert nämlich nicht.

    Irgendwelche Ideen?
     
  2. Till

    Till Administrator

    Dann ist mod_ssl im apache nicht richtig geladen. Schau mal in die Datei:

    /etc/sysconfig/apache2

    dort muss die folgende Zeile drin stehen:

    APACHE_SERVER_FLAGS="SSL"

    danach ausführen:

    SuSEconfig
    /etc/init.d/apache2 restart
     
  3. bts_freak

    bts_freak New Member

    Wow! Das wars. Super und vielen Dank!!!
     

Diese Seite empfehlen