SSL Konfiguration unter Debian / ISPConfig 3

Dieses Thema im Forum "Server Administration" wurde erstellt von Weitdenker, 25. Jan. 2010.

  1. Weitdenker

    Weitdenker New Member

    Ich habe meinen Server nach den HowTo "The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3]" aufgesetzt. Es läuft alles prima.

    Nun möchte ich gerne eine Seite über SSL laufen lassen. Jedoch nicht die komplette Seite sondern nur den Ordner /warenkorb.

    Was ich jedoch nicht ganz verstehe. Die Seite läuft über port *.80, SSL Seiten über Port *.443. Wie bringe ich es nun fertig die Seite über 80 laufen zu lassen und für die Seiten im /warenkorb über SSL also 443?

    Was ist hierfür der beste Weg?
     
  2. fuxifux

    fuxifux Member

    Also am Einfachsten ist es, den Link auf den Warenkorb ganz auszuschreiben, und mit einem https:// zu versehen - Die Links vom Warenkorb zurück aber mit einem http://

    Dann wird die Verbindung automatisch richtig aufgebaut.
     
  3. Weitdenker

    Weitdenker New Member

    Danke für die Info, leider ist es aber nicht so einfach. Ich habe erstmal das Problem, dass ich https oder http zum laufen bekomme. Beides parallel nicht. Wähle ich für den VHost den Port 443 aus gelange ich über https auf die seite über http jedoch nur auf dich apache "It Works" seite.

    Wenn ich Port 80 gewählt habe gelange ich über https auf eine ISPConfig "Willkommen" Seite wo sie auch immer liegen mag und über http gelange ich auch meine Seite. Schon alles sehr komisch. Nur was mache ich falsch?
     
  4. Weitdenker

    Weitdenker New Member

    Port 80 und 443 in einer Konfiguration

    Ich würde gerne http und https für eine Domain nutzen. Grundlage für meine Serverkonfiguration ist das Tutorial:
    "The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3]"

    Eine Domain habe ich /etc/apache2/sites-available/domain.de.vhost hab ich nun manuel konfiguriert:

    Code:
    <Directory /var/www/domain.de>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <VirtualHost *:80>
          DocumentRoot /var/www/domain.de/web
      
        ServerName domain.de
        ServerAlias www.domain.de
        ServerAdmin webmaster@domain.de
    
        ErrorLog /var/log/ispconfig/httpd/domain.de/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
        
        <Directory /var/www/domain.de/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
            
            # ssi enabled
            AddType text/html .shtml
            AddOutputFilter INCLUDES .shtml
            Options +Includes
            <Files ~ '.php[s3-6]{0,1}$'>
                Order allow,deny
                Deny from all
                Allow from none
            </Files>
        </Directory>
        <Directory /var/www/clients/client1/web1/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
            
            # ssi enabled
            AddType text/html .shtml
            AddOutputFilter INCLUDES .shtml
            Options +Includes
            <Files ~ '.php[s3-6]{0,1}$'>
                Order allow,deny
                Deny from all
                Allow from none
            </Files>
        </Directory>
    
        # cgi enabled
        <Directory /var/www/clients/client1/web1/cgi-bin>
          Order allow,deny
          Allow from all
        </Directory>
        ScriptAlias  /cgi-bin/ /var/www/clients/client1/web1/cgi-bin/
        AddHandler cgi-script .cgi
        AddHandler cgi-script .pl
        # suexec enabled
        SuexecUserGroup web1 client1
    
    
    </VirtualHost>
    
    <VirtualHost *:443>
          DocumentRoot /var/www/domain.de/web
      
        ServerName domain.de
        ServerAlias www.domain.de
        ServerAdmin webmaster@domain.de
    
        ErrorLog /var/log/ispconfig/httpd/domain.de/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
        
        <Directory /var/www/domain.de/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
            
            # ssi enabled
            AddType text/html .shtml
            AddOutputFilter INCLUDES .shtml
            Options +Includes
            <Files ~ '.php[s3-6]{0,1}$'>
                Order allow,deny
                Deny from all
                Allow from none
            </Files>
        </Directory>
        <Directory /var/www/clients/client1/web1/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
            
            # ssi enabled
            AddType text/html .shtml
            AddOutputFilter INCLUDES .shtml
            Options +Includes
            <Files ~ '.php[s3-6]{0,1}$'>
                Order allow,deny
                Deny from all
                Allow from none
            </Files>
        </Directory>
    
        # cgi enabled
        <Directory /var/www/clients/client1/web1/cgi-bin>
          Order allow,deny
          Allow from all
        </Directory>
        ScriptAlias  /cgi-bin/ /var/www/clients/client1/web1/cgi-bin/
        AddHandler cgi-script .cgi
        AddHandler cgi-script .pl
        # suexec enabled
        SuexecUserGroup web1 client1
    
    SSLEngine On
    
    SSLCertificateFile /etc/ssl/apache/apache_server.crt
    
    SSLCertificateKeyFile /etc/ssl/apache/apache_private.key
    
    SSLProtocol All -SSLv2
    SSLCipherSuite ALL:!EXP:!NULL:!ADH:!LOW
    SetEnvIf User-Agent “.*MSIE.*” nokeepalive ssl-unclean-shutdown
    
    </VirtualHost>
    
    
    Wie man sieht habe ich <VirtualHost *:80> dupliziert und in<VirtualHost *:443> geändert.
    Ist das so möglich, denn funktionieren tuts auf jeden Fall! Aber ist das auch der richtige Weg?
     
  5. Till

    Till Administrator

    Das ist ganz schlecht. Mach das bitte rückgängig und aktivier stattdessen einfach ssl für die Domain in ispconfig. Deine Manuellen Änderungen werden eh automatisch wieder entfernt werden. Also niemals die vhost datein manuell ändern!
     

Diese Seite empfehlen