Standard php.ini wird nicht geladen

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von shadowcast, 21. Aug. 2016.

  1. shadowcast

    shadowcast Member

    Hallo,

    ich hab unter /opt/phpfcgi-7.0.10 eine zusätzliche PHP Version, welche ich im ISPConfig für einige Webs verwende.
    Die php.ini liegt unter /opt/phpfcgi-7.0.10/lib.
    Hier habe ich nun auch z.b. Erweiterungen geladen wie z.B. IonCube Loader oder OPCache.

    Die werden aber nur so lange geladen, solange ich keine "Individuellen php.ini Einstellungen" bei einem Web vornehmen.
    Trage ich hier z.B. für ein Web ein "upload_max_filesize=16M" ein, werden die Erweiterungen nicht mehr geladen.

    PHPInfo zeigt dann an:
    Configuration File Path: /opt/phpfcgi-7.0.10/lib
    Loaded Configuration File: /var/www/conf/webXX/php.ini
    Letztere enthält lediglich die eingetragenen Werte, die ganzen anderen Einträge von der standarad php.ini werden offensichtlich ignoriert?

    Wenn ich wieder auf Standard PHP umstelle (also nicht die zusätzliche PHP 7 Version sondern in dem Fall Jessie Standard PHP 5.6) sehe ich in der PHPInfo das Selbe, jedoch enthält die geladene php.ini auch die Werte der Standard php.ini unter /etc/php5/cgi

    Da hab ich wohl irgendwo irgendetwas vergessen?

    LG
     
  2. shadowcast

    shadowcast Member

    Hallo,

    ich hab inzwischen zumindest die Ursache dafür, dass offensichtlich ISPConfig die ursprüngliche php.ini nicht lesen kann und diese deshalb leer ist bzw. nur dies beinhaltet, was ich unter "Individuelle php.ini Einstellungen" eingetragen hab.

    Wie gesagt es handelt sich um eine zusätzlich installierte PHP Version, bei mir sieht das so aus:
    Code:
    /opt/phpfcgi-7.0.9
    /opt/phpfcgi-7.0.10
    /opt/phpfcgi-7.0 -> /opt/phpfcgi-7.0.10
    Der letzte Eintrag phpfcgi-7.0 ist ein Systemlink auf den aktuellsten PHP Ordner.
    Dessen Pfade sind auch in der "Zusätzlichen PHP Version" im ISPConfig eingetragen.

    Dies erlaubt mir einfach eine neue PHP Version einzuspielen, lediglich den Systemlink anzupassen, den Apache neu zu starten und alle haben automatisch das neueste PHP.
    Würde ich nun einen Fehler feststellen, könnte ich solange ich die vorherige noch nicht gelöscht habe, einfach den Systemlink wieder auf die vorherige Version setzen und alles ist gut.

    Aber genau diese Systemlinks sorgen nun für diesen php.ini Umstand. Alles andere passt einfwandfrei.

    LG
     
  3. shadowcast

    shadowcast Member

    Code:
    WARNING - Action aborted, file is a symlink: /opt/phpfcgi-7.0/lib/php.ini
    Steht so wohl auch im Logfile wenn ich das Loglevel auf Debug setz.
    Aber warum wirft er hier ein Warning aus? Ein Symlink ist doch nichts schlimmes???
     
  4. shadowcast

    shadowcast Member

    Meine Lösung des Problems wäre an dieser Stelle ja denkbar einfach.

    Anstelle des Symlinks einfach immer den Ordner mit der aktuellen PHP Version auf /opt/phpfcgi-7.0 umbenennen bzw. den mit der vorherigen einfach wieder die ganze Version anhängen.
    Auch hätte ich mit diesem neuen Handling die Option, schnell auf die vorherige PHP Version zu wechseln, sollte etwas nicht klappen.

    Aber rein vom Verständnis? Warum ist das an dieser Stelle so, dass hier keine Symlinks akzeptiert werden?
     
  5. shadowcast

    shadowcast Member

    Hi nochmal,
    leider war der letzte Post doch nicht meine Optimalste Lösung.
    Denn sobald ich eine individuelle PHP Einstellung an den Pfaden was ändere z.B. die PHP.INI einen neuen Pfad hat, werden alle Webs aufs Default PHP umgestellt.
    Ich bräuchte also eigentlich schon die vorher angedachte Lösung, welche ja bis auf die genannten eigenen PHP Einstellungen gut funktionierte, einafch mit Symlinks.
    Eh mal anders gefragt? Ich bin doch sicher nicht der Einzige, der mehrere PHP Versionen mit ISPConfig betreibt? Wie löst denn Ihr das Thema wenn PHP Updates erscheinen?
    LG
     

Diese Seite empfehlen