Statt client-web kommt immer die ispconfig Standard-Index-Seite

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Cuver77, 13. Okt. 2010.

  1. Cuver77

    Cuver77 New Member

    Hallo, habe heute das Update auf 3.0.3 installiert und einen neuen Kunden angelegt. Wenn ich jetzt Kundendomain aufrufe, wird nicht der Inhalt des Kundenverzeichnisses angezeigt, sondern die Standard-Index-Seite von ispconfig.

    Im Kundenverzeichnis (also z.B. /var/www/clients/client5/web8/web) ist diese Standard-Index-Seite gar nicht enthalten. Also ist die Domain anscheinend mit einem anderen Verzeichnis verbunden oder gibt es einen anderen Grund?

    Es sind alle eingerichteten Webs betroffen. Ich bin ziemlich ratlos.

    Hier mal eine entsprechende vhost.

    <Directory /var/www/xxx.de>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/martin-hoeck.de/web

    ServerName xxx.de
    ServerAlias www.xxx.de
    ServerAlias www.xxx.de xxx.de
    ServerAlias webmail.xxx.de
    ServerAdmin webmaster@xxx.de

    ErrorLog /var/log/ispconfig/httpd/xxx.de/error.log


    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/xxx.de/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client5/web8/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>


    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    # php as fast-cgi enabled
    <IfModule mod_fcgid.c>
    # SocketPath /tmp/fcgid_sock/
    IdleTimeout 3600
    ProcessLifeTime 7200
    # MaxProcessCount 1000
    DefaultMinClassProcessCount 3
    DefaultMaxClassProcessCount 100
    IPCConnectTimeout 8
    IPCCommTimeout 360
    BusyTimeout 300
    </IfModule>
    <Directory /var/www/martin-hoeck.de/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web8/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client5/web8/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web8/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^webmail.xxx.de [NC]
    RewriteRule ^/(.*)$ http://www.webcoreserver.de/webmail$1 [R]

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
    AssignUserId web8 client5
    </IfModule>

    <IfModule mod_dav_fs.c>
    # DO NOT REMOVE THE COMMENTS!
    # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
    # WEBDAV BEGIN
    # WEBDAV END
    </IfModule>


    </VirtualHost>
     
    Zuletzt bearbeitet: 14. Okt. 2010
  2. Cuver77

    Cuver77 New Member

    Das Problem hat sich geklärt. Ich habe die apache gestoppt und dann wieder gestartet. Danach ging wieder alles. Vorher hatte ich etliche restarts durchgeführt - ohne Erfolg.

    Trotzdem ist der ganze Vorfall merkwürdig. Hat jemand eine Ahnung was die Ursache dafür gewesen sein könnte?
     
  3. Till

    Till Administrator

    Vermutlich ein hängender apache Prozess, das kann vorkommen das der auch nach einem restart immer noch existiert und somit faktisch kein Restart gemacht wurde.

    Wenn Du nochmal so ein problem hast, dann stoppe den apache und checke mit:

    ps aux | grep apache

    ob noch prozesse laufen und beebde die dann mit kill bevor Du apache neu startest.
     
  4. iddQQp

    iddQQp New Member

    Hi,

    sorry für die Grabschändung des Threads hier. Habe das selbe Problem wie der Threadersteller. Der Dienst wurde mehrmals angehalten, überprüft ob noch ein Prozess läuft und neu gestartet, leider ohne Erfolg.

    ISPConfig Version: 3.0.3.3

    Edit: selbige Standardeinstellungen wie beim Threadersteller - FastCGI + suEXEC


    Grüße
     
    Zuletzt bearbeitet: 13. Okt. 2011
  5. Till

    Till Administrator

    Mach am besten mal einen neuen Thread auf und beschreibe dann exakt Dein Problem. Denn in den meisten Fällen wenn gepostet wird dass das das Problem auch hat, ist es nachher etwas anderes. Denn ansonsten hätte die Antwort in diesem Thread Dein Problem bereits gelöst :)
     

Diese Seite empfehlen