subdomain,vhosts

planet_fox

Super-Moderator
#1
Hi

Ich hab da ein komisches Problem.

1. mal es gibt eine system Doamin für die keine webseite eingerichtet ist sagen wir mal xhorst.de . Wenn ich nun xhorst.de eingebe sollt ja das directory des ordners /var/www/ zu sehen sein aller Apache Server läuft.

so jedoch leite er ohne das eine weiterleitung existiert auf ahorst.de in ein web weiter.

2. wenn ich nun ein web anlege mit domain news.ahorst.de sollte ich über news.ahorst.de danach folgendes sehen Willkommen auf ihrer Webseite so nun hier lande ich aber wieder inm hauptweb ahorst.de

so jetzt frage ich mich wo ist der fehler mydns oder apache ?
 

Till

Administrator
#2
1) Wenn ahorst.de in alphabetischer Reihenfolge die erste Webseite mit der gleichen IP ist, dann ist es das normale Verhalten das apache.

2) Hast Du eine neue Webseite oder eine neue subdomain angelegt? Wurde hier die IP oder * ausgewählt und wurde beim hauptweb IP oder * ausgewählt?
 

planet_fox

Super-Moderator
#5
Code:
<Directory /var/www/news.ahorst.de>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
      DocumentRoot /var/www/news.ahorst.de/web

    ServerName xmail.ahorst.de
    ServerAlias *.xmail.ahorst.de
    ServerAlias *.newsletter.ahorst.de newsletter.ahorst.de

    ErrorLog /var/log/ispconfig/httpd/xmail.ahorst.de/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/xmail.ahorst.de/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    <Directory /var/www/clients/client3/web33/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
 # cgi enabled
        <Directory /var/www/clients/client3/web33/cgi-bin>
      Order allow,deny
      Allow from all
    </Directory>
    ScriptAlias  /cgi-bin/ /var/www/clients/client3/web33/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # php as fast-cgi enabled
    <IfModule mod_fcgid.c>
      # SocketPath /tmp/fcgid_sock/
      IdleTimeout 3600
      ProcessLifeTime 7200
      # MaxProcessCount 1000
      DefaultMinClassProcessCount 3
      DefaultMaxClassProcessCount 100
      IPCConnectTimeout 8
      IPCCommTimeout 360
      BusyTimeout 300
    </IfModule>
    <Directory /var/www/ahorst.de/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /var/www/php-fcgi-scripts/web33/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
        <Directory /var/www/clients/client3/web33/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /var/www/php-fcgi-scripts/web33/.php-fcgi-starter.php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
      AssignUserId web33 client3
    </IfModule>
 
Zuletzt bearbeitet:

Till

Administrator
#6
Da stimmt irgend was nicht. Diese vhost Datei ist von der Webseite
xmail.ahorst.de und nicht news.ahorst.de. Und der name der vhost Datei ist wirklich news.ahorst.de? Hast Du die Domain des Webs vielleicht mal geändert?
 

planet_fox

Super-Moderator
#7
es geht mit folgender Lösung wenn ich in der ahost.de den * raus nehme bei Auto-subdomain gehts . *grübel* ist normal ?

Gruß

alex
 

Till

Administrator
#8
Ja, das sit normal. Apache geht alle vhosts alphabetisch durch und stoppt beim ersten zutereffenden vhost. wenn Du eine Wildcard für die Domain benutzt, kannst Du keine Subdomain Websites mehr anlegen.

Du solltest keine Wildcard einsetzen sondern stattdessen auto subdomain www, das macht selten Sinn und ist auch schlecht fürs Google Ranking.

Wilrcards braucht man nur für eine einzige Sache, das sind Websites bei denen sich user selbst Unterwebsites registrieren können, also sowas wie WordpressMU, die Multiuser Version von Wordpress.
 

planet_fox

Super-Moderator
#9
hm ok, ich werde mal schaun ob das im wiki drin steht diese Information ist wichtig. ich wer jetzt nicht so direkt drauf gekommen . Mercy dir .
was passiert dann mit http://ahost.de ohne www
 
Zuletzt bearbeitet:

planet_fox

Super-Moderator
#11
Ich meine sogar die aussage schon mal gelesen zu haben im Forum nur hier, das is das was in meinem Unterbebusten Howtoforge Cache gewesen ist und der wusste auch nicht nach was er genau suchen sollte hier.Die erste antwort von till

glaub der satz ist schon ein binding bei till, der schreibt nur noch
Code:
vhost alpahabeth
und der satz wird autovervollständigt :D .
 

Werbung