SubDomains

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von vpns2000, 8. Juli 2008.

  1. vpns2000

    vpns2000 Member

    Hallo,
    ich habe nach langem wieder mal das selbe Problem mit den Subdomains.
    Nun habe ich ein neues Web angelegt xxx.xxxx.info und dafür eine neue Apache Direktive erstellt die wie folgt ausschaut.
    Code:
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^123.xxxxx.info [NC]
    RewriteRule ^/(.*)$ /123/$1 [L]
    
    
    leider bekomme ich aber schonwieder die Seite auf der steht:
    die IP wird mehrfach verwendet ........

    Der DNS eintrag zeigt auf 123.xxxxx.info und auf die IP die ISPConfig verwendet so wie bei den anderen Domains auch.

    Kan mir jemand sagen was da schon wieder falsch ist????
    Danke


    LG
     
    Zuletzt bearbeitet: 8. Juli 2008
  2. Till

    Till Administrator

    Kriegst Du denn die richtige Seite, wenn Du die Rewrite Rule raus lässt?
     
  3. vpns2000

    vpns2000 Member

    Hallo Till,
    ja ich bekommer die Hauptdomain unter www.xxxx.info wie auch das Verzeichnis in in welches ich gerne die Sub Domain hätte. Also www.xxxx.info/123. Wenn ich aber 123.xxxx.info aufrufe bekomme ich immer Shared IP und nicht das Verzeichnis 123.

    DANKE
    LG
     
  4. Till

    Till Administrator

    Ok, dann setll bitte sicher, dass die Domain 123.xxxx.info mit einem DNS A-Record auf die selbe IP verweist wie die Domain www.xxxx.info.
     
  5. vpns2000

    vpns2000 Member

    Hallo Till,
    diesen DNS Eintrag mache ich eigentlich immer zu erst da es ja immer einwenig dauert bis es auch alle DNS mitbekommen haben. Ich habe mich nun auch nochmal via PING versichert und ich bekomme auch die gleiche IP auf der auch der ISP Config läuft, also so wie bei den anderen Domains auch.
    nur ist es nach wie vor nicht möglich das ich die SUB Domain 123.xxxx.info aufrufen kann und ich in das verzeichnis komme in der ich sogar eine index.htm hinein gestellt habe um zu sehen das ich auch richtig bin.
    Leider ohne erfolg.

    Kann es da noch wo anders hinken???

    LG
     
  6. Till

    Till Administrator

    Scahu mal nach, ob Du kopien der datei Vhost_ispconfig.conf mit angehängtem Datum hast, die erst vor kurzem erstellt wurden.
     
  7. vpns2000

    vpns2000 Member

    hallo Till,
    ja die habe ich wie zum Bsp. "Vhosts_ispconfig.conf_08-07-08_13-27-56" und noch einige andere.

    LG
     
  8. Till

    Till Administrator

    Ok, dann hast Du einen Fehler in Deiner Apache Konfuguration und ISPConfig kann diese daher nicht mer ändern.

    Benenn die letzte Datei mit Datum in Vhosts_ispconfig.conf, ruf httpd -t auf und behebe den Fehler, der Dir angezeigt wird.
     
  9. vpns2000

    vpns2000 Member

    Hallo Till,
    das habe ich soeben gemacht.
    und bei
    Code:
    [root@xx vhosts]# httpd -t
    Syntax OK
    [root@xx vhosts]#
    
    
    ist auch alles Okay. Doch funktionieren wills einfach noch immer nicht.

    LG
     

Diese Seite empfehlen