Suche Anregungen & Tips physischen Server nach VM

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Feanwulf, 1. Feb. 2013.

  1. Feanwulf

    Feanwulf Member

    Hallo,

    ich habe einen Root Server bei Hetzner da läuft noch ganz normal ein Debian 6 mit ISPConfig2.

    Ich habe seit heute einen neuen Rootserver bei Hetzner da läuft ESXi und ich erstelle dann dort neue VMs. Da ich den alten Rootserver bald schon kündigen möchte, aber dort auch produktiv Daten liegen, hatte ich mir gedacht:

    * Erstelle eine VM aus dem physischen Server und binde diese im ESXi ein


    Ich habe den VMware Standalone Converter geladen und es dort versucht, aber der Converter Hilfsserver startet nicht. Ursache hierfür ist wohl, dass die Mac-Adresse automatisch erstellt wird und ich dem Converter leider keine Adresse manuell (damit per DHCP von Hetzner die IP-Adresse übergeben wird).

    Gibt es andere Wege, um dies zu machen?

    Letzter Weg - wäre natürlich die neue VM die ich eh erstellen muss, mit ISPConfig3 vorzubereiten und dann vom physischen Server nach und nach die Daten rüber zu kopieren und zu migrieren. Ich würde mir aber gerne etwas Zeitdruck nehmen und dachte über eine VM (sofern diese läuft) kann ich dann den alten Rootserver auch direkt kündigen ;)


    Wäre für jeden Tip wie ich den physischen Debian auf VM Debian bekomme dankbar.

    Grüße,
    Patric
     
  2. Till

    Till Administrator

    Du kannst z.B. versuchen ein Harddisk Image des alten Servers mit dd zu erstellen, da es sich ja um ein exaktes Abbild der Festplatte handelt müsste sich das auch irgendwie in vmware laden bzw. konvertieren lassen. Das Image sollte man aber wahrscheinlich vom rescue system aus machen, bedeutet also Ausfallzeit.

    Ich könnte mir aber auch vorstellen dass sich so ein Umzug ggf auch wie folgt machen ließe:

    1) Debian in der gleichen Version wie auf dem alten system installieren (egal wie alt es ist, updaten kannst Du später), aber nur Minimalimage.
    2) per rsync den Pfad / des alten servers auf / des neuen Servers syncen (bei den flags aufpassen dass wirklich alles mitkopiert wird, also Rechte, links etc.), dann ggf nochmal grub auf dem neuen System aufrufen falls da was beim bootloader / mbr im argen liegt und dann beten dass der neue Server rebootet.
    Da der Arbeitsaufwand für diese Methode recht gering ist ist sie meines Erachtens einen Versuch Wert, Linux ist bei sowas erstaunlich fehlertolerant :)
     
  3. mare

    mare Member

    Bei dem rsync aber /dev /proc ggf. /sys /etc/fstab und /etc/mtab weglassen !
     
  4. Feanwulf

    Feanwulf Member

    Werde heute Abend das mit dem resync probieren und heute Nacht um 3 Uhr schalte ich mal alle Dienste ab und mache per Rescue System ein DD Image ;) Dann kann ich ja sehen was am Besten gelaufen ist ;)
     
  5. Feanwulf

    Feanwulf Member

    Hat wunderbar geklappt mit:

    rsync -aAXv /* IPADRESSE:/ --exclude={/dev/*,/proc/*,/sys/*,/tmp/*,/run/*,/mnt/*,/media/*,/lost+found,/var/cache/rsnapshot/*,/etc/fstab,/etc/mtab,/boot,/files,/backup,home/admispconfig/ispconfig/temp}

    Bootet auch, habe nur das Problem, dass irgendwie kein Datenverkehr REIN geht auf die IP-Adresse und da bin ich gerade überfragt. RAUS geht interessanterweise ;)
     
  6. mare

    mare Member

    Evtl. iptables auf einem falschen Interface?
    Siehst du denn den eingehenden Traffic mit tcpdump?
     
  7. Feanwulf

    Feanwulf Member

    über tcmpdump sehe ich dass die SSH Verbindung aufgebaut wird - nur halt antwortet dann der Server ni9cht weiter . seltsam - ich weiss auch nicht wonach ich googlen soll ;)

    Stoppen der Firewall hilt dass ich wieder auf den Server per SSH komme - muss ich nur schauen wie ich die Firewall wieder hinbekomme ;)

    ISPConfig2 startet seine Firewall und dann sind die Verbindungen alle getrennt - Liegt wahrscheinlich daran, dass ich ja auf der VM eine andere IP-Adresse habe - lider bricht ISPConfig2 beim "neuinstallieren" bzw "Updaten" ab!
     
    Zuletzt bearbeitet: 2. Feb. 2013
  8. Feanwulf

    Feanwulf Member

    Habe gerade bemerkt das irgendwie dpkg probleme macht - kann daher aktuell keine Packages entfernen oder installieren und die iptables -vL -n sieht auf dem Server auch anders aus als auf dem "original"
     

Diese Seite empfehlen