Suexec + Fast-CGI geht nicht, wo ist der Fehler?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von stefanw, 22. Juni 2010.

  1. stefanw

    stefanw New Member

    Wenn ich das bei einer Domain so einstelle dann bekomme ich einen 403 und im error.log steht

    Symbolic link not allowed or link target not accessible: /var/www/domain.tld

    Das ist eine Domain die ich frisch angelegt habe da ist noch keinerlei Content drin, lediglich die Standard index.html usw.

    Was mache ich denn hier falsch?

    Danke

    SW
     
    Zuletzt bearbeitet: 22. Juni 2010
  2. Till

    Till Administrator

    1) Welche ISPConfig Version?
    2) Welchen security Level hast Du unter System > server config > server xyz > web eingestellt?
    3) hast Du auto subdomain www im web domain.tld eingestellt?
     
  3. stefanw

    stefanw New Member

    1) Welche ISPConfig Version?

    3.0.2.2

    2) Welchen security Level hast Du unter System > server config > server xyz > web eingestellt?

    High, den habe ich nicht geändert, das scheint wohl Standard zu sein

    3) hast Du auto subdomain www im web domain.tld eingestellt?

    Ja
     
    Zuletzt bearbeitet: 22. Juni 2010
  4. Till

    Till Administrator

    Soweit alles ok. Was genau steht denn als Fehlermeldung im error.log der Webseite? Oder steht da garkein Fehler und der Fehler erscheint im haupt error.log des apache?
     
  5. stefanw

    stefanw New Member

    Im Haupt error.log des Apache steht nix. Nur im error.log der Webseite steht die Meldung die ich ganz am Anfang schon geschrieben habe:

    Symbolic link not allowed or link target not accessible: /var/www/domain.tld
     
  6. Till

    Till Administrator

    - Ist /var/www/domain.tld vorhanden und enthält auch das "web" Verzeichnis?
    - Welche Optionen hast Du in dem Web aktiviert?
     
  7. stefanw

    stefanw New Member

    - Ist /var/www/domain.tld vorhanden und enthält auch das "web" Verzeichnis?

    Ja, als Symlink mit einer ~ vorne dran

    - Welche Optionen hast Du in dem Web aktiviert?

    siehe Screenshot
     

    Anhänge:

  8. Till

    Till Administrator

    Wie kommt denn das ~ da hin. Lösche mal das web und lege es neu an.
     
  9. stefanw

    stefanw New Member

    Das ist aber bei allen Webs so! Hab Sie gelöscht und neu angelegt. Ist wieder so. Alle webs sind Symlinks die auf /var/www/clients/clientx/webx verweisen. Ist das nicht richtig so?
     
  10. Till

    Till Administrator

    Doch, das ist absolut richtig.Ich hatte es aber so verstanden dass Du eine ~ im Symlinknamen hattest.
     
  11. stefanw

    stefanw New Member

    Verzeihung, der MC stellt das so dar.

    > Doch, das ist absolut richtig

    Aber jetzt sind wir keinen Schritt weiter - richtig?
     
  12. Till

    Till Administrator

    Du kannst ja mal die vhost Datei einer funktionierenden Website mit der nicht funktionierenden Website vergleichen.
     
  13. stefanw

    stefanw New Member

    Also ich seh auf anhieb nicht wo der Fehler sein soll.

    Domain die nicht geht:

    <Directory /var/www/domain.tld>
    Options FollowSymLinks
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/domain.tld/web

    ServerName domain.tld
    ServerAlias www.domain.tld
    ServerAdmin webmaster@domain.tld

    ErrorLog /var/log/ispconfig/httpd/domain.tld/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/domain.tld/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web52/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    # suexec enabled
    SuexecUserGroup web52 client1
    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    # php as fast-cgi enabled
    <IfModule mod_fcgid.c>
    # SocketPath /tmp/fcgid_sock/
    IdleTimeout 3600
    ProcessLifeTime 7200
    # MaxProcessCount 1000
    DefaultMinClassProcessCount 3
    DefaultMaxClassProcessCount 100
    IPCConnectTimeout 8
    IPCCommTimeout 360
    BusyTimeout 300
    </IfModule>
    <Directory /var/www/domain.tld/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web52/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web52/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web52/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
    AssignUserId web52 client1
    </IfModule>


    </VirtualHost>


    Domain die funktioniert:

    <Directory /var/www/domain.tld>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/clients/client18/web31/web

    ServerName domain.tld
    ServerAlias www.domain.tld
    ServerAdmin webmaster@domain.tld

    ErrorLog /var/log/ispconfig/httpd/domain.tld/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/domain.tld/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client18/web31/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    # suphp enabled
    <Directory /var/www/clients/client18/web31/web>
    suPHP_Engine on
    # suPHP_UserGroup web31 client18
    AddHandler x-httpd-suphp .php .php3 .php4 .php5
    suPHP_AddHandler x-httpd-suphp
    </Directory>

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
    AssignUserId web31 client18
    </IfModule>


    </VirtualHost>
     
  14. stefanw

    stefanw New Member

    Noch eine Info: Suexec mit SuPHP funktioniert
     
  15. stefanw

    stefanw New Member

    So jetzt habe ich eine zweite Maschine mit Debian, anstatt Ubuntu, aufgesetzt. Da funktioniert alles einwandfrei. Ich habe auch die /etc/suphp/suphp.conf auf beiden Maschinen abgeglichen. Auf der Ubuntu Maschine will es nicht klappen.
     

Diese Seite empfehlen