suphp 0.7.1 - nu hab ichs kaputt gemacht ,)

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Feanwulf, 23. März 2009.

  1. Feanwulf

    Feanwulf Member

    Hallo,

    habe ISPConfig aktuelle Version laufen - wollte suPHP upgraden und habe nach der Anleitung von 0.6.2 suPHP 0.7.1 installiert, allerdings erhalte ich nun folgende Fehlermeldung:

    [Mon Mar 23 14:30:31 2009] [error] [client 212.144.101.198] SoftException in Application.cpp:555: Directory /var/www is not owned by utopic.de-ftp
    [Mon Mar 23 14:30:31 2009] [error] [client 212.144.101.198] Premature end of script headers: index.php

    Mir ist klar, daß da irgendwie die Rechte nicht korrekt sind, aber ich blick gerade nicht was ich richtig setzen muss!
     
  2. Till

    Till Administrator

    Die Rechte sind ok, das Problem liegt in den suphp Einstellungen. Poste mal die suphp.conf Datei.
     
  3. Feanwulf

    Feanwulf Member

    Code:
    [global]
    ;Path to logfile
    logfile=/var/log/suphp.log
    
    ;Loglevel
    loglevel=warn
    
    ;User Apache is running as
    webserver_user=www-data
    
    ;Path all scripts have to be in
    docroot=/
    
    ;Path to chroot() to before executing script
    ;chroot=/mychroot
    
    ; Security options
    allow_file_group_writeable=true
    allow_file_others_writeable=false
    allow_directory_group_writeable=true
    allow_directory_others_writeable=false
    
    ;Check wheter script is within DOCUMENT_ROOT
    check_vhost_docroot=true
    
    ;Send minor error messages to browser
    errors_to_browser=false
    
    ;PATH environment variable
    env_path=/bin:/usr/bin
    
    ;Umask to set, specify in octal notation
    umask=0022
    
    ; Minimum UID
    min_uid=100
    
    ; Minimum GID
    min_gid=100
    
    [handlers]
    ;Handler for php-scripts
    x-httpd-php="php:/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper"
    
    ;Handler for CGI-scripts
    x-suphp-cgi="execute:!self"
    
    Hab zurückgestellt auf 0.6.2 und da klappt alles :( will aber gerne neuste Version haben - das probier ich aber erst heute abend wieder ;)
     
  4. Till

    Till Administrator

    Poste bitte mal die Ausgabe von:

    ls -la /var | grep www

    die suphp.conf sieht soweit ok aus.
     
  5. Feanwulf

    Feanwulf Member

    web-ng:/var# ls -la /var | grep www
    drwxr-xr-x 38 www-data root 4.0K 2008-12-08 09:23 www
     
  6. Till

    Till Administrator

    Hmm, sieht auch ok aus. Soweit ich weiß haben im en forum auch schon ein paar Leute auf diese Version aktualisiert und es scheint funktioniert zu haben, wichtig sind vor allem die "" beim handler.
     
  7. Feanwulf

    Feanwulf Member

    ich probiers heute Abend nochmal - hat gestern nicht geklappt ;) Von der Arbeit aus ist Port 81 leider gesperrt ;)
     
  8. hambuergaer

    hambuergaer New Member

    Gibt es hier schon Fortschritte? Habe ISPConfig 2.2.30 und das aktuelle suphp 0.7.1 installiert. Mit der Version 0.6.2 hat zuvor alles gut geklappt :-(
     
  9. Till

    Till Administrator

    Hast Du mal im en Forum nachgefragt, soweit ich weiß benutzen es doert einige bereits ohne Probleme.
     

Diese Seite empfehlen