suPHP auf debian lenny zum laufen bekommen...

#1
moin.

schaffe es einfach nicht suPHP zum laufen zu bekommen. benutze debian 5 lenny. bekomme diese meldung bei der eingabe von:

cd /tmp
wget http://www.suphp.org/download/suphp-0.6.2.tar.gz
tar xvfz suphp-0.6.2.tar.gz
cd suphp-0.6.2
./configure –prefix=/usr –sysconfdir=/etc –with-apache-user=www-data –with-setid-mode=paranoid –with-apxs=/usr/bin/apxs2
make
make install

Code:
dubb:/tmp/suphp-0.6.2# cd /tmp
dubb:/tmp# wget http://www.suphp.org/download/suphp-0.6.2.tar.gz
--2009-02-23 02:03:15--  http://www.suphp.org/download/suphp-0.6.2.tar.gz
Resolving www.suphp.org... XXXXXXXXXX
Connecting to www.suphp.org|XXXXXXXXXX|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 372228 (364K) [application/x-gzip]
Saving to: `suphp-0.6.2.tar.gz.1'

100%[===============================================================================================================================================>] 372,228     --.-K/s   in 0.03s

2009-02-23 02:03:15 (10.2 MB/s) - `suphp-0.6.2.tar.gz.1' saved [372228/372228]

dubb:/tmp# tar xvfz suphp-0.6.2.tar.gz
suphp-0.6.2/
suphp-0.6.2/configure
suphp-0.6.2/Makefile.in
suphp-0.6.2/configure.ac
suphp-0.6.2/doc/
suphp-0.6.2/doc/apache/
suphp-0.6.2/doc/apache/CONFIG
suphp-0.6.2/doc/apache/INSTALL
suphp-0.6.2/doc/apache/README
suphp-0.6.2/doc/LICENSE
suphp-0.6.2/doc/CONFIG
suphp-0.6.2/doc/INSTALL
suphp-0.6.2/doc/suphp.conf-example
suphp-0.6.2/doc/README
suphp-0.6.2/AUTHORS
uns so weiter........
suphp-0.6.2/src/SecurityException.hpp
suphp-0.6.2/src/API_Linux_Logger.hpp
suphp-0.6.2/COPYING
suphp-0.6.2/Makefile.am
suphp-0.6.2/NEWS
suphp-0.6.2/aclocal.m4
suphp-0.6.2/README
dubb:/tmp# cd suphp-0.6.2
dubb:/tmp/suphp-0.6.2# ./configure .prefix=/usr .sysconfdir=/etc .with-apache-user=www-data .with-setid-mode=paranoid .with-apxs=/usr/bin/apxs2
configure: error: invalid variable name: .prefix
dubb:/tmp/suphp-0.6.2# make
make: *** No targets specified and no makefile found.  Stop.
dubb:/tmp/suphp-0.6.2# make install
beim neustart den ich trotz der anscheinend mislungen installtion versucht habe kam diese meldung:

Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration

dazu habe ich nur was im englischen forum gefunden, leider fuer mich recht unversätndlich.


falls jemand weiss was da nicht ganz richtig laueft ~ bitte was dazu posten. thx.
 

Till

Administrator
#2
Die Zeile muss so lauten:

./configure --prefix=/usr --sysconfdir=/etc --with-apache-user=www-data --with-setid-mode=paranoid --with-apxs=/usr/bin/apxs2
 
#5
die suphp.log ist leer (vergessen zu schreiben)
in der /var/log/apache2/error.log finde ich nichts verdächtiges, nur das:
[Sun Feb 22 20:40:57 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
 
#7
Uhh. aso. Also in der Datei /var/www/web1/log/error.log findet sich nichts sonderliches nur oft die Zeile:
[Mon Feb 23 01:07:14 2009] [error] [client 65.36.241.76] File does not exist: /var/www/web1/web/error
In /var/www/web1/log/web.log ist auch nichts auffälliges
:(

Was gibt's noch wie moeglichkeiten den fehler zu finden? :(
thx
 
Zuletzt bearbeitet:
#10
Habe es gerade nochmal versucht (die Installtion) jetzt - hat anscheinend jetzt geklappt, jetzt kann ich aber Apache nicht mehr starten :(

kann den Server jetzt auch nicht über ISPConfig erreichen, da auch offline.

In der oben benannten Zeile steht:

Code:
php_admin_flag safe_mode Off
In der Datei /usr/lib/apache2/modules/mod_suphp.so habe ich...
Code:
#LoadModule suphp_module       /usr/lib/apache2/modules/mod_suphp.so
wieder auskommentiert. Start von Apache klappt aber dan auch nicht (gleiche Meldugn)

Was jetzt ? :confused: kleiner, echter, notfall :(
welche logs soll ich genau posten?
thx

ps:
in der datei /home/admispconfig/ispconfig/lib/config.inc.php steht immer noch addtype, auch nach wechsel auf suphp funktioniert der neustart aber nicht (gleiche meldung).
 
Zuletzt bearbeitet:

Till

Administrator
#11
Du musst in der Datei:

/home/admispconfig/ispconfig/lib/config.inc.php

auf suphp umstellen, danach in ISPConfig einloggen und die Einstellungen eines Webs ändern und auf speichern klicken.
 

Till

Administrator
#13
ISPConfig 2 hat seinen eigene apache, hat also überhaupt nichts damit zu tun ob der Hauptserver einen 500er Fehler hat oder nicht. Wenn der ISPconfig Server nicht läuft, musst Du ihn neu starten:

/etc/init.d/ispconfig_server restart
 
#14
Ach so, das ist natürlich clever.
Der 500-Fehler kommt schon lange nicht mehr den ich mal durch suPHP hatte (der kam nur wenn ich 'suphp' anstatt des Standards-Eintrag 'addtype' war) beim Neustart-Befehl kommt das:

Code:
box:~# /etc/init.d/ispconfig_server restart
Shutting down ISPConfig system...
/root/ispconfig/httpd/bin/apachectl stop: httpd stopped
ISPConfig system stopped!
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
Failed loading /usr/local/lib/ioncube/ioncube_loader_lin_5.2_ts.so:  /usr/local/lib/ioncube/ioncube_loader_lin_5.2_ts.so: undefined symbol: ts_allocate_id
Failed loading /usr/local/lib/Zend/ZendOptimizer.so:  /usr/local/lib/Zend/ZendOptimizer.so: undefined symbol: empty_string
ISPConfig system is now up and running!
ISPConfig ist immer noch nicht erreichbar. Jetzt weiß ich aber warum nicht, gut, nur bekomme ich die 2 Fehlermeldungen weg? Eig. dachte ich hätte die misglückten Installtionsversuche weitensgehend wieder entfernt...
 

Till

Administrator
#15
Du hast den Ioncube loader in den ispconfig server installiert, dass kann natürlich nicht gehen. Also ioncube aus der php.ini unter /root/ispconfig/php/ entfernen.
 
#16
Ach so klar, man man wie blöd von mir .....:rolleyes:
Schön, jetzt funktioniert der Befehl. Allerdings trotzdem nicht unter der IP erreichbar dawohl er sagt:

Code:
Shutting down ISPConfig system...
/root/ispconfig/httpd/bin/apachectl stop: httpd stopped
ISPConfig system stopped!
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
ISPConfig system is now up and running!
Und wenn ich das eingebe...:
Code:
/etc/init.d/apache2 restart
Restarting web server: apache2Syntax error on line 103 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration
 failed!
läufts auch nicht.
 

Werbung

Top