suPHP läuft nicht (im Webspace)

Dieses Thema im Forum "Allgemein" wurde erstellt von Nordin, 24. Dez. 2012.

  1. Nordin

    Nordin New Member

    [gelöst] suPHP läuft nicht (im Webspace)

    Hallo und Frohe Weihnachten!!!

    Ich habe mir lokal einen Debian squeeze 6 installiert.

    Nach ein wenig hin und her habe ich ISPConfig zum laufen bekommen.
    Habe mir dann zum testen einen Reseller und dort einen User angelegt... Noch eine Domain zugeordnet und probiert...

    Super funktioniert auch... naja zumindest die index.html

    Sobald ich ein *.php Datei aufrufe, bekomme ich jedoch einen 500 Fehler.

    Im error-Log steht folgendes:
    Code:
    [Mon Dec 24 17:08:17 2012] [error] [client 79.221.149.212] SecurityException in Application.cpp:496: Handler not found in configuration
    [Mon Dec 24 17:08:17 2012] [error] [client 79.221.149.212] Caused by KeyNotFoundException in Configuration.cpp:234: Handler "x-httpd-suphp" not found
    [Mon Dec 24 17:08:17 2012] [error] [client 79.221.149.212] Premature end of script headers: index.php
    Nach vielen suchen stoße ich immer wieder nur darauf, dass ich in der /etc/suphp/suphp.conf daruf achten soll das es so drin steht:
    Code:
    [handlers]
    ;Handler for php-scripts
    application/x-httpd-suphp="php:/usr/bin/php-cgi"
    
    ;Handler for CGI-scripts
    x-suphp-cgi="execute:!self"
    und in der /etc/apache2/mods-enabled/suphp.conf sollte folgendes drin stehen:
    Code:
        AddType application/x-httpd-suphp .php .php3 .php4 .php5 .phtml
        suPHP_AddHandler application/x-httpd-suphp
    ...so stehts auch drin.

    Somit sollte doch der Handler geladen werden oder nicht?
    Ich weiß echt nicht weiter. Ich hoffe einer von euch kann mir helfen und schöne Weihnachten bescheren.

    Gruß Nordin
     
    Zuletzt bearbeitet: 27. Dez. 2012
  2. Nordin

    Nordin New Member

    Keiner ne Idee?
     
  3. magenbrot

    magenbrot Member

    ergänze mal diese Zeile unter [handlers]:
    x-httpd-suphp="php:/usr/bin/php-cgi"

    der komplette Bereich sieht bei mir so aus:
     
  4. Nordin

    Nordin New Member

    Perfekt! Das war's, Danke!!
     

Diese Seite empfehlen