suse 11 maildrop "Failed dependencies"

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von heman87, 29. Juli 2009.

  1. heman87

    heman87 New Member

    Hallo zusammen,
    ich habe mich dazu entschlossen eine ISPConfig Nutzer zu werden :D ... doch die Installation spielt nicht so recht mit.

    Ich versuche Schritt für Schritt die Anleitung (http://www.ispconfig.org/docs/INSTALL_OPENSUSE_11.txt) abzuarbeiten, doch schon bei der Installation von "maildrop" gibt es die ersten Probleme.

    Code:
    rpm --force -i http://download.opensuse.org/repositories/home:/atzewilms/openSUSE_11.1_Update/i586/maildrop-2.1.0-3.2.i586.rpm
    warning: /var/tmp/rpm-xfer.QMvlsu: Header V3 DSA signature: NOKEY, key ID 6530cd38
    error: Failed dependencies:
            libcourierauth.so is needed by maildrop-2.1.0-3.2.i586
            libfam.so.0 is needed by maildrop-2.1.0-3.2.i586
            libgcc_s.so.1 is needed by maildrop-2.1.0-3.2.i586
            libgcc_s.so.1(GCC_3.0) is needed by maildrop-2.1.0-3.2.i586
            libgdbm.so.3 is needed by maildrop-2.1.0-3.2.i586
            libpcre.so.0 is needed by maildrop-2.1.0-3.2.i586
            libstdc++.so.6 is needed by maildrop-2.1.0-3.2.i586
            libstdc++.so.6(CXXABI_1.3) is needed by maildrop-2.1.0-3.2.i586
            libstdc++.so.6(GLIBCXX_3.4) is needed by maildrop-2.1.0-3.2.i586
            libstdc++.so.6(GLIBCXX_3.4.9) is needed by maildrop-2.1.0-3.2.i586
    ...andere Probleme Libs fehlern bei der Installation von "pam_mysql".

    Code:
    rpm -i http://download.opensuse.org/repositories/home:/buschmann23/openSUSE_11.1/i586/pam_mysql-0.7RC1-11.1.i586.rpm
    warning: /var/tmp/rpm-xfer.gwolB8: Header V3 DSA signature: NOKEY, key ID 3d7dbcb6
    error: Failed dependencies:
            libcrypto.so.0.9.8 is needed by pam_mysql-0.7RC1-11.1.i586
            libmysqlclient.so.15 is needed by pam_mysql-0.7RC1-11.1.i586
            libmysqlclient.so.15(libmysqlclient_15) is needed by pam_mysql-0.7RC1-11.1.i586
            libssl.so.0.9.8 is needed by pam_mysql-0.7RC1-11.1.i586
            libz.so.1 is needed by pam_mysql-0.7RC1-11.1.i586
    Wäre super wenn mir jemand sagen könnte, woher ich diese
    Libs bekomme oder was ich sonst falsch mache?

    Viele Grüße,
    heman
     
  2. Till

    Till Administrator

    Das kommt bei OpenSuSE häufig vor, da es nicht in der Lage ist die Pakete inkl. Dependencies von sich aus aus den repositories anzubieten was dann regelmäßig zu Dependency Errors führt.

    Meine Empfehlung ist dass Du lieber Debian nimmst, damit hast Du auf Dauer ein deutlich stabileres System.

    Wenn es denn unbedingt SuSE sein muss, dann nimm besser die aktualisierte Anleitung da die Redame Dateien nicht immer aktuell sind, SuSE ändert die Paketnamen zum Teil alle paar Tage.

    http://www.howtoforge.com/perfect-server-opensuse-11.1-ispconfig-3
     

Diese Seite empfehlen