Symbolic link not allowed or link target not accessible

Dieses Thema im Forum "Server Administration" wurde erstellt von tocwi, 25. Juni 2013.

  1. tocwi

    tocwi New Member

    [solved] Symbolic link not allowed or link target not accessible

    Hallo,

    seit 2 Tagen erhalte ich auf einem Server für alle Webseiten folgende Fehlermeldung:
    You don't have permission to access / on this server.
    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


    Hier ein Auszug aus einer error.log:
    [Tue Jun 25 12:50:48 2013] [error] [client 89.15.65.159] Symbolic link not allowed or link target not accessible: /var/www/TLD
    [Tue Jun 25 12:50:48 2013] [error] [client 89.15.65.159] Symbolic link not allowed or link target not accessible: /var/www/TLD


    Hier meine vHost:
    <Directory /var/www/TLD>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/TLD/web

    ServerName TLD
    ServerAlias www.TLD
    ServerAdmin webmaster@TLD

    ErrorLog /var/log/ispconfig/httpd/TLD/error.log

    Alias /error/ "/var/www/TLD/web/error/"
    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 502 /error/502.html
    ErrorDocument 503 /error/503.html

    <IfModule mod_ssl.c>
    </IfModule>

    <Directory /var/www/TLD/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    <Files ~ '.php[s3-6]{0,1}$'>
    Order allow,deny
    Deny from all
    Allow from none
    </Files>
    </Directory>
    <Directory /var/www/clients/client24/web36/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    <Files ~ '.php[s3-6]{0,1}$'>
    Order allow,deny
    Deny from all
    Allow from none
    </Files>
    </Directory>




    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>


    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
    AssignUserId web36 client24
    </IfModule>

    <IfModule mod_dav_fs.c>
    # Do not execute PHP files in webdav directory
    <Directory /var/www/clients/client24/web36/webdav>
    <ifModule mod_security2.c>
    SecRuleRemoveById 960015
    SecRuleRemoveById 960032
    </ifModule>
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    </Directory>
    DavLockDB /var/www/clients/client24/web36/tmp/DavLock
    # DO NOT REMOVE THE COMMENTS!
    # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
    # WEBDAV BEGIN
    # WEBDAV END
    </IfModule>


    </VirtualHost>



    Rechte habe ich überprüft und mit denen auf anderen laufenden Server verglichen. Sieht alles gut aus. An diesem System wurde definitiv nicht geändert.


    Habe eine neue Webseite erstellt. Kein PHP. Gleiches Problem.
    Auch wird nicht zu der eingestellten Fehlerseite ErrorDocument 403 /error/403.html geleitet. Im Browser kommt die Standard 403er Fehlermeldung.





    Hat jemand eine Idee?


    Vielen Dank und Grüße
    Tom



    [solved]
    Die Ursache waren die Rechte für /var/www/clients. Standen auf 754 anstelle von 755. Warum auch immer. Nicht ordentlich genug kontrolliert.
     
    Zuletzt bearbeitet: 25. Juni 2013

Diese Seite empfehlen